Bug 214016 - Crash happends when I click on the KOrganizer systry icon
Summary: Crash happends when I click on the KOrganizer systry icon
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-10 18:49 UTC by iferca
Modified: 2009-11-10 22:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iferca 2009-11-10 18:49:58 UTC
Application that crashed: kontact
Version of the application: 4.3.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Just that, clicking on the system notification icon, I've tried to reproduce it with no success.
Secods before clicking on «Start Reminder Daemon ar Login» to activate it.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x0074f6d0 in Kontact::Plugin::part() () from /usr/lib/libkontactinterfaces.so.4
#7  0x0301b39a in ?? () from /usr/lib/kde4/kontact_todoplugin.so
#8  0x00751ff9 in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterfaces.so.4
#9  0x00752084 in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterfaces.so.4
#10 0x006e17b4 in QDBusConnectionPrivate::deliverCall (this=0x9b63c90, object=0x9ec8270, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x006e295d in QDBusConnectionPrivate::activateCall (this=0x9b63c90, object=0x9ec8270, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x006e2fc3 in QDBusConnectionPrivate::activateObject (this=0x9b63c90, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x006e34da in QDBusActivateObjectEvent::placeMetaCall (this=0xa4df2e0) at qdbusintegrator.cpp:1464
#14 0x096835fe in QObject::event (this=0x9ec8270, e=0xa4df2e0) at kernel/qobject.cpp:1111
#15 0x00cf2f54 in QApplicationPrivate::notify_helper (this=0x9b705d8, receiver=0x9ec8270, e=0xa4df2e0) at kernel/qapplication.cpp:4056
#16 0x00cfa67c in QApplication::notify (this=0xbfb9d224, receiver=0x9ec8270, e=0xa4df2e0) at kernel/qapplication.cpp:3603
#17 0x004d114a in KApplication::notify (this=0xbfb9d224, receiver=0x9ec8270, event=0xa4df2e0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x096736cb in QCoreApplication::notifyInternal (this=0xbfb9d224, receiver=0x9ec8270, event=0xa4df2e0) at kernel/qcoreapplication.cpp:610
#19 0x096742b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9b4b820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9b4b820) at kernel/qcoreapplication.cpp:1247
#21 0x0967447d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x0969e3ff in QCoreApplication::sendPostedEvents (s=0x9b6d510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x9b6d510) at kernel/qeventdispatcher_glib.cpp:210
#24 0x03a75e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x03a79720 in ?? () from /lib/libglib-2.0.so.0
#26 0x03a79853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0969e02c in QEventDispatcherGlib::processEvents (this=0x9b4b9f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x00d93be5 in QGuiEventDispatcherGlib::processEvents (this=0x9b4b9f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x09671c79 in QEventLoop::processEvents (this=0xbfb9d184, flags=) at kernel/qeventloop.cpp:149
#30 0x096720ca in QEventLoop::exec (this=0xbfb9d184, flags=...) at kernel/qeventloop.cpp:201
#31 0x0967453f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00cf2dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in _start ()

This bug may be a duplicate of or related to bug 213629

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-10 22:42:53 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***