Bug 235496 - Kontact crashes hours after being quit
Summary: Kontact crashes hours after being quit
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-26 23:23 UTC by Leonardo La Malfa
Modified: 2010-06-06 17:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo La Malfa 2010-04-26 23:23:52 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-21-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I opened Kontact in the afternoon, then quit and forgot about it. In the evening I hit Akregator, and was informed of this crash. I expected it was the last programme, instead it was Kontact.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7770990 (LWP 6155))]

Thread 2 (Thread 0xb2017b70 (LWP 6259)):
#0  0x00cda422 in __kernel_vsyscall ()
#1  0x008b1b86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x0225f4eb in g_poll () from /lib/libglib-2.0.so.0
#3  0x022520ac in ?? () from /lib/libglib-2.0.so.0
#4  0x022524b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x010e660f in QEventDispatcherGlib::processEvents (this=0x97631d0, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x010b9059 in QEventLoop::processEvents (this=0xb2017270, flags=) at kernel/qeventloop.cpp:149
#7  0x010b94aa in QEventLoop::exec (this=0xb2017270, flags=...) at kernel/qeventloop.cpp:201
#8  0x00fb55a8 in QThread::exec (this=0x95c5970) at thread/qthread.cpp:487
#9  0x01098c1b in QInotifyFileSystemWatcherEngine::run (this=0x95c5970) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00fb832e in QThreadPrivate::start (arg=0x95c5970) at thread/qthread_unix.cpp:248
#11 0x04b5396e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x008bfa0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7770990 (LWP 6155)):
[KCrash Handler]
#6  0x00f4bb50 in KontactInterface::Plugin::part (this=0x93454a8) at ../../kontactinterface/plugin.cpp:190
#7  0x0309a45d in ?? () from /usr/lib/kde4/kontact_akregatorplugin.so
#8  0x00f4d7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0xbfb5f55c, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00f4d874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x9338830, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb5f70c) at ./uniqueapphandler.moc:79
#10 0x00c07b34 in QDBusConnectionPrivate::deliverCall (this=0x8ffcd60, object=0x9338830, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00c08ddf in QDBusConnectionPrivate::activateCall (this=0x8ffcd60, object=0x9338830, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00c095ac in QDBusConnectionPrivate::activateObject (this=0x8ffcd60, node=..., msg=..., pathStartPos=25) at qdbusintegrator.cpp:1383
#13 0x00c09b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9722f98) at qdbusintegrator.cpp:1477
#14 0x010cb3fe in QObject::event (this=0x9338830, e=0x9722f98) at kernel/qobject.cpp:1248
#15 0x05cdb4dc in QApplicationPrivate::notify_helper (this=0x9006240, receiver=0x9338830, e=0x9722f98) at kernel/qapplication.cpp:4300
#16 0x05ce205e in QApplication::notify (this=0xbfb60124, receiver=0x9338830, e=0x9722f98) at kernel/qapplication.cpp:3704
#17 0x004f8f2a in KApplication::notify (this=0xbfb60124, receiver=0x9338830, event=0x9722f98) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x010baa3b in QCoreApplication::notifyInternal (this=0xbfb60124, receiver=0x9338830, event=0x9722f98) at kernel/qcoreapplication.cpp:704
#19 0x010bd473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8fe54e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8fe54e0) at kernel/qcoreapplication.cpp:1345
#21 0x010bd5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x010e6adf in QCoreApplication::sendPostedEvents (s=0x9008910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x9008910) at kernel/qeventdispatcher_glib.cpp:276
#24 0x0224e5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x022522d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x022524b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x010e65d5 in QEventDispatcherGlib::processEvents (this=0x8fe5070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x05d9b135 in QGuiEventDispatcherGlib::processEvents (this=0x8fe5070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x010b9059 in QEventLoop::processEvents (this=0xbfb60084, flags=) at kernel/qeventloop.cpp:149
#30 0x010b94aa in QEventLoop::exec (this=0xbfb60084, flags=...) at kernel/qeventloop.cpp:201
#31 0x010bd69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x05cdb577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in _start ()

Possible duplicates by query: bug 234971, bug 234172, bug 232851, bug 229766, bug 218747.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 17:35:06 UTC

*** This bug has been marked as a duplicate of bug 194268 ***