Bug 243710 - Kontact didn't start up again, after the first startup.
Summary: Kontact didn't start up again, after the first startup.
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-06 01:39 UTC by Thoar
Modified: 2010-09-19 13:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thoar 2010-07-06 01:39:23 UTC
Application: kontact (4.3.5)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.31.12-0.2-default i686
Distribution: "openSUSE 11.2 (i586)"

-- Information about the crash:
The first time starting Kontact, no problems occurs. But after closing it, and trying to start Kontact again, it repeatedly crashes. When starting KMail, Kontact opens along with KMail with the bug notification.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb7792695 in Kontact::Plugin::part() () from /usr/lib/libkontactinterfaces.so.4
#7  0xb083b995 in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#8  0xb779511d in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterfaces.so.4
#9  0xb77951ac in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterfaces.so.4
#10 0xb563defe in QDBusConnectionPrivate::deliverCall (this=0x806ca98, object=0x82f9850, msg=..., metaTypes=..., slotIdx=137240776) at qdbusintegrator.cpp:904
#11 0xb563ed7c in QDBusConnectionPrivate::activateCall (this=0x806ca98, object=0x82f9850, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0xb563f628 in QDBusConnectionPrivate::activateObject (this=0x806ca98, node=..., msg=..., pathStartPos=-1079135600) at qdbusintegrator.cpp:1383
#13 0xb563fbe8 in QDBusActivateObjectEvent::placeMetaCall (this=0x99bd508) at qdbusintegrator.cpp:1477
#14 0xb6ecb69f in QObject::event (this=0x82f9850, e=0x99bd508) at kernel/qobject.cpp:1248
#15 0xb63e3e3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb63eac78 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb73d8d21 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0xb6eba71e in QCoreApplication::notifyInternal (this=0xbfadbaf4, receiver=0x82f9850, event=0x99bd508) at kernel/qcoreapplication.cpp:726
#19 0xb6ebe227 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1367
#21 0xb6ebe3ac in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#22 0xb6ee789d in sendPostedEvents () at kernel/qcoreapplication.h:220
#23 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:276
#24 0xb43dc4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0xb43dfd98 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0xb43dfebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0xb6ee7381 in QEventDispatcherGlib::processEvents (this=0x8056b50, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0xb64a4c3a in ?? () from /usr/lib/libQtGui.so.4
#29 0xb6eb8d8d in QEventLoop::processEvents (this=0xbfadba54, flags=) at kernel/qeventloop.cpp:149
#30 0xb6eb91d9 in QEventLoop::exec (this=0xbfadba54, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6ebe480 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#32 0xb63e3ee4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#33 0x0804b546 in _start ()

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 235761, bug 235277, bug 233641, bug 232822, bug 227577.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-09-19 13:48:14 UTC

*** This bug has been marked as a duplicate of bug 194268 ***