Bug 196149 - kaddressbook crashed when upon startup
Summary: kaddressbook crashed when upon startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: contacts (show other bugs)
Version: 1.4.90
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-12 11:02 UTC by 20120808_bugs.kde.org
Modified: 2009-06-12 15:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 20120808_bugs.kde.org 2009-06-12 11:02:52 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I clicked on kaddressbook in the kickoff menu but received a message that kontact had crashed. 

Both nepomuk and akonadi are installed and enabled.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x8ce8e80) at /build/buildd/kdepim-4.2.90/kontactinterfaces/plugin.cpp:186
#7  0xb16d424e in KABUniqueAppHandler::newInstance (this=0x8cd1af0) at /build/buildd/kdepim-4.2.90/kontact/plugins/kaddressbook/kaddressbook_plugin.cpp:206
#8  0xb78b9f39 in Kontact::UniqueAppHandler::newInstance (this=0x8cd1af0, asn_id=@0xb720dc0, args=@0x9baf778) at /build/buildd/kdepim-4.2.90/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb78b9fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x8cd1af0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8426b8)
    at /build/buildd/kdepim-4.2.90/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5d6dd7a in QDBusConnectionPrivate::deliverCall (this=0x8941ec0, object=0x8cd1af0, msg=@0xbfa2740, metaTypes=@0xbf842768, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5d6ef92 in QDBusConnectionPrivate::activateCall (this=0x8941ec0, object=0x8cd1af0, flags=272, msg=@0xbfa2740) at qdbusintegrator.cpp:796
#12 0xb5d6f501 in QDBusConnectionPrivate::activateObject (this=0x8941ec0, node=@0xbfa272c, msg=@0xbfa2740, pathStartPos=28) at qdbusintegrator.cpp:1375
#13 0xb5d6f9fa in QDBusActivateObjectEvent::placeMetaCall (this=0xbfa2700) at qdbusintegrator.cpp:1469
#14 0xb5c643a0 in QObject::event (this=0x8cd1af0, e=0xbfa2700) at kernel/qobject.cpp:1118
#15 0xb6133e9c in QApplicationPrivate::notify_helper (this=0x89497c8, receiver=0x8cd1af0, e=0xbfa2700) at kernel/qapplication.cpp:4084
#16 0xb613c19e in QApplication::notify (this=0xbf842f38, receiver=0x8cd1af0, e=0xbfa2700) at kernel/qapplication.cpp:3631
#17 0xb6d59e8d in KApplication::notify (this=0xbf842f38, receiver=0x8cd1af0, event=0xbfa2700) at /build/buildd/kde4libs-4.2.90/kdeui/kernel/kapplication.cpp:302
#18 0xb5c53a3b in QCoreApplication::notifyInternal (this=0xbf842f38, receiver=0x8cd1af0, event=0xbfa2700) at kernel/qcoreapplication.cpp:602
#19 0xb5c54695 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8929c08) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5c5488d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1132
#21 0xb5c7f7ef in postEventSourceDispatch (s=0x894b920) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4d19b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4d1d0eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4d1d268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5c7f438 in QEventDispatcherGlib::processEvents (this=0x895ff78, flags={i = -1081856504}) at kernel/qeventdispatcher_glib.cpp:323
#26 0xb61d5365 in QGuiEventDispatcherGlib::processEvents (this=0x895ff78, flags={i = -1081856456}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5c5206a in QEventLoop::processEvents (this=0xbf842eb0, flags={i = -1081856392}) at kernel/qeventloop.cpp:149
#28 0xb5c524aa in QEventLoop::exec (this=0xbf842eb0, flags={i = -1081856328}) at kernel/qeventloop.cpp:200
#29 0xb5c54959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#30 0xb6133d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#31 0x0804bfef in main (argc=1, argv=0xbf843234) at /build/buildd/kdepim-4.2.90/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 165845

Reported using DrKonqi
Comment 1 Dario Andres 2009-06-12 15:35:52 UTC
This looks like related to bug 194268 (Kontact crash on initialization of the uniqueapp handler for the requested PIM app). Thanks

*** This bug has been marked as a duplicate of bug 194268 ***