Bug 215466 - Kontact/KMail randomly crashes on start
Summary: Kontact/KMail randomly crashes on start
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-20 19:20 UTC by Joe
Modified: 2009-11-20 19:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe 2009-11-20 19:20:28 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.1 (KDE 4.3.1) "release 6"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

What I was doing when the application crashed:
OS: Linux 2.6.31-openSUSE 11.2 x86
Kontact version: 4.5.5-i586
KDE version: 4.3.1
libqt4 version: 4.5.3-2.4.2-i586

Kontact and/or KMail crash on starting. Sometimes the Crash Reporting Assistant comes up and reports a SIGSEV, other times Kontact simply does not start with no error message. Typically, multiple attempts to start Kontact in a row will fail. Starting KMail separately sometimes works, and sometimes does not. Not sure how to reproduce.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x824a1c0) at /usr/src/debug/kdepim-4.3.1/kontactinterfaces/plugin.cpp:186
#7  0xb0f6b995 in KMailUniqueAppHandler::newInstance (this=0x82f0200) at /usr/src/debug/kdepim-4.3.1/kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0xb77d511d in Kontact::UniqueAppHandler::newInstance (this=0x82f0200, asn_id=..., args=...) at /usr/src/debug/kdepim-4.3.1/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb77d51ac in Kontact::UniqueAppHandler::qt_metacall (this=0x82f0200, _c=InvokeMetaMethod, _id=0, _a=0xbfa23edc) at /usr/src/debug/kdepim-4.3.1/build/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb580db4f in ?? () from /usr/lib/libQtDBus.so.4
#11 0xb580e9e2 in ?? () from /usr/lib/libQtDBus.so.4
#12 0xb580f0f0 in ?? () from /usr/lib/libQtDBus.so.4
#13 0xb580f658 in ?? () from /usr/lib/libQtDBus.so.4
#14 0xb6f5e796 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0xb65948fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb659c34e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0xb7489ce1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0xb6f4e32e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb6f4efdc in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#20 0xb6f4f19c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#21 0xb6f7a4dd in ?? () from /usr/lib/libQtCore.so.4
#22 0xb489e4c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb48a1d98 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb48a1ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb6f7a011 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0xb663629a in ?? () from /usr/lib/libQtGui.so.4
#27 0xb6f4c98d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb6f4cdd9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0xb6f4f270 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0xb6594774 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#31 0x0804b546 in main (argc=1, argv=0xbfa249c4) at /usr/src/debug/kdepim-4.3.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 194268

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-20 19:32:39 UTC

*** This bug has been marked as a duplicate of bug 194268 ***