Bug 235761 - Kontact crashes when started
Summary: Kontact crashes when started
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-29 22:15 UTC by Mats Kindahl
Modified: 2010-06-07 00:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mats Kindahl 2010-04-29 22:15:45 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When starting Kontact, it just crashes. Nothing special was done to trigger this behaviour.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x0078b6d0 in Kontact::Plugin::part() () from /usr/lib/libkontactinterfaces.so.4
#7  0x06e9339a in ?? () from /usr/lib/kde4/kontact_todoplugin.so
#8  0x0078dff9 in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterfaces.so.4
#9  0x0078e084 in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterfaces.so.4
#10 0x00b467b4 in QDBusConnectionPrivate::deliverCall (this=0x9272c90, object=0x960d8e8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x00b4795d in QDBusConnectionPrivate::activateCall (this=0x9272c90, object=0x960d8e8, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00b47fc3 in QDBusConnectionPrivate::activateObject (this=0x9272c90, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x00b484da in QDBusActivateObjectEvent::placeMetaCall (this=0x9850660) at qdbusintegrator.cpp:1464
#14 0x003985fe in QObject::event (this=0x960d8e8, e=0x9850660) at kernel/qobject.cpp:1111
#15 0x0107af54 in QApplicationPrivate::notify_helper (this=0x92799b0, receiver=0x960d8e8, e=0x9850660) at kernel/qapplication.cpp:4056
#16 0x0108267c in QApplication::notify (this=0xbfc62424, receiver=0x960d8e8, e=0x9850660) at kernel/qapplication.cpp:3603
#17 0x00965bfa in KApplication::notify (this=0xbfc62424, receiver=0x960d8e8, event=0x9850660) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x003886cb in QCoreApplication::notifyInternal (this=0xbfc62424, receiver=0x960d8e8, event=0x9850660) at kernel/qcoreapplication.cpp:610
#19 0x003892b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x925a820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x925a820) at kernel/qcoreapplication.cpp:1247
#21 0x0038947d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x003b33ff in QCoreApplication::sendPostedEvents (s=0x927a350) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x927a350) at kernel/qeventdispatcher_glib.cpp:210
#24 0x03d04e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x03d08730 in ?? () from /lib/libglib-2.0.so.0
#26 0x03d08863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x003b302c in QEventDispatcherGlib::processEvents (this=0x925a9f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x0111bbe5 in QGuiEventDispatcherGlib::processEvents (this=0x925a9f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00386c79 in QEventLoop::processEvents (this=0xbfc62384, flags=) at kernel/qeventloop.cpp:149
#30 0x003870ca in QEventLoop::exec (this=0xbfc62384, flags=...) at kernel/qeventloop.cpp:201
#31 0x0038953f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x0107add7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-07 00:58:55 UTC

*** This bug has been marked as a duplicate of bug 194268 ***