Bug 232822 - korganizer crashes after kontact is closed
Summary: korganizer crashes after kontact is closed
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-31 12:47 UTC by sedo_5
Modified: 2010-03-31 17:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sedo_5 2010-03-31 12:47:33 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic-pae i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I have korganizer in the system tray (autostarts at every session) and never gave me problems or crashed. Now that i decided to constantly use Kontact (because i decided to move to Kmail instead of thunderbird or other) with all of its features (kagregator,kmail,kontact,korganizer), it usually crashes after i close kmail or kontact. Usually, at the next startup, it happens that kmail (or kontact) autostarts with korganizer (but i chose from the settings to launch the korganizer daemon only).

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb77d16d0 in Kontact::Plugin::part (this=0x8d53c50) at ../../kontactinterfaces/plugin.cpp:186
#7  0xb101939a in KOrganizerUniqueAppHandler::newInstance (this=0x8d566a0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb77d3ff9 in Kontact::UniqueAppHandler::newInstance (this=0x8d566a0, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb77d4084 in Kontact::UniqueAppHandler::qt_metacall (this=0x8d566a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc6b1dc) at ./uniqueapphandler.moc:73
#10 0xb58fd7b4 in QDBusConnectionPrivate::deliverCall (this=0x89a6c90, object=0x8d566a0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb58fe95d in QDBusConnectionPrivate::activateCall (this=0x89a6c90, object=0x8d566a0, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0xb58fefc3 in QDBusConnectionPrivate::activateObject (this=0x89a6c90, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0xb58ff4da in QDBusActivateObjectEvent::placeMetaCall (this=0x9479f78) at qdbusintegrator.cpp:1464
#14 0xb66515fe in QObject::event (this=0x8d566a0, e=0x9479f78) at kernel/qobject.cpp:1111
#15 0xb6a9df54 in QApplicationPrivate::notify_helper (this=0x89adb10, receiver=0x8d566a0, e=0x9479f78) at kernel/qapplication.cpp:4056
#16 0xb6aa567c in QApplication::notify (this=0xbfc6bb24, receiver=0x8d566a0, e=0x9479f78) at kernel/qapplication.cpp:3603
#17 0xb74edbfa in KApplication::notify (this=0xbfc6bb24, receiver=0x8d566a0, event=0x9479f78) at ../../kdeui/kernel/kapplication.cpp:302
#18 0xb66416cb in QCoreApplication::notifyInternal (this=0xbfc6bb24, receiver=0x8d566a0, event=0x9479f78) at kernel/qcoreapplication.cpp:610
#19 0xb66422b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x898e820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x898e820) at kernel/qcoreapplication.cpp:1247
#21 0xb664247d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0xb666c3ff in QCoreApplication::sendPostedEvents (s=0x89b8b10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x89b8b10) at kernel/qeventdispatcher_glib.cpp:210
#24 0xb4936e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0xb493a730 in ?? () from /lib/libglib-2.0.so.0
#26 0xb493a863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0xb666c02c in QEventDispatcherGlib::processEvents (this=0x898e9f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0xb6b3ebe5 in QGuiEventDispatcherGlib::processEvents (this=0x898e9f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0xb663fc79 in QEventLoop::processEvents (this=0xbfc6ba84, flags=) at kernel/qeventloop.cpp:149
#30 0xb66400ca in QEventLoop::exec (this=0xbfc6ba84, flags=...) at kernel/qeventloop.cpp:201
#31 0xb664253f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0xb6a9ddd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in main (argc=1, argv=0xbfc6bd44) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-03-31 17:55:31 UTC

*** This bug has been marked as a duplicate of bug 194268 ***