Bug 215361 - Kontact crash at startup
Summary: Kontact crash at startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-20 01:55 UTC by Sebastián Ramírez
Modified: 2009-11-20 02:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastián Ramírez 2009-11-20 01:55:25 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kontact crash at startup 

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x009c36d0 in Kontact::Plugin::part (this=0x92e7390) at ../../kontactinterfaces/plugin.cpp:186
#7  0x01f3239a in KOrganizerUniqueAppHandler::newInstance (this=0x95fd1e8) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0x009c5ff9 in Kontact::UniqueAppHandler::newInstance (this=0x95fd1e8, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x009c6084 in Kontact::UniqueAppHandler::qt_metacall (this=0x95fd1e8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8f027c) at ./uniqueapphandler.moc:73
#10 0x006457b4 in QDBusConnectionPrivate::deliverCall (this=0x9289ca8, object=0x95fd1e8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x0064695d in QDBusConnectionPrivate::activateCall (this=0x9289ca8, object=0x95fd1e8, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00646fc3 in QDBusConnectionPrivate::activateObject (this=0x9289ca8, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x006474da in QDBusActivateObjectEvent::placeMetaCall (this=0x9ad58e0) at qdbusintegrator.cpp:1464
#14 0x008135fe in QObject::event (this=0x95fd1e8, e=0x9ad58e0) at kernel/qobject.cpp:1111
#15 0x00f8ef54 in QApplicationPrivate::notify_helper (this=0x9299160, receiver=0x95fd1e8, e=0x9ad58e0) at kernel/qapplication.cpp:4056
#16 0x00f9667c in QApplication::notify (this=0xbf8f0bc4, receiver=0x95fd1e8, e=0x9ad58e0) at kernel/qapplication.cpp:3603
#17 0x00c16bfa in KApplication::notify (this=0xbf8f0bc4, receiver=0x95fd1e8, event=0x9ad58e0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x008036cb in QCoreApplication::notifyInternal (this=0xbf8f0bc4, receiver=0x95fd1e8, event=0x9ad58e0) at kernel/qcoreapplication.cpp:610
#19 0x008042b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9271820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9271820) at kernel/qcoreapplication.cpp:1247
#21 0x0080447d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x0082e3ff in QCoreApplication::sendPostedEvents (s=0x9297cc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x9297cc0) at kernel/qeventdispatcher_glib.cpp:210
#24 0x0196ae78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x0196e720 in ?? () from /lib/libglib-2.0.so.0
#26 0x0196e853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0082e02c in QEventDispatcherGlib::processEvents (this=0x92719f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x0102fbe5 in QGuiEventDispatcherGlib::processEvents (this=0x92719f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00801c79 in QEventLoop::processEvents (this=0xbf8f0b24, flags=) at kernel/qeventloop.cpp:149
#30 0x008020ca in QEventLoop::exec (this=0xbf8f0b24, flags=...) at kernel/qeventloop.cpp:201
#31 0x0080453f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00f8edd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in main (argc=1, argv=0xbf8f0de4) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-20 02:10:59 UTC

*** This bug has been marked as a duplicate of bug 194268 ***