Bug 231080 - Kontact / Korganizer-Taskbar-Applet crashes
Summary: Kontact / Korganizer-Taskbar-Applet crashes
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-17 11:20 UTC by Frank Sagurna
Modified: 2010-03-26 01:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Sagurna 2010-03-17 11:20:06 UTC
Application: kontact (4.4.1)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-16-generic x86_64
Distribution: Ubuntu lucid (development branch)

-- Information about the crash:
I have the problem, that when i close kontact, i can not start it again. Only killing the kontact process lets me start it after that.
When kontact is closed and not killed, clicking on the korganizer-taskbar-applet causes this crash.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f15b5050820 (LWP 4521))]

Thread 2 (Thread 0x7f158c23c710 (LWP 4549)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f158c23b9e0 in ?? ()
#2  0x00007fff9a9ff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f15b5050820 (LWP 4521)):
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007f15b46b8ffb in QWidget::show (this=0x1e90e20) at /usr/include/qt4/QtGui/qwidget.h:485
#7  KontactInterface::UniqueAppHandler::newInstance (this=0x1e90e20) at ../../kontactinterface/uniqueapphandler.cpp:138
#8  0x00007f15b46b90a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x1e90e20, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f15b46b9114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x1e90e20, _c=QMetaObject::InvokeMetaMethod, _id=30374080, _a=0x7fff9a9a51b0) at ./uniqueapphandler.moc:79
#10 0x00007f15b0930486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#11 0x00007f15b09316ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1e90e20, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007f15b0931f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007f15b0932468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2636770) at qdbusintegrator.cpp:1477
#14 0x00007f15b34f1cc9 in QObject::event (this=0x1e90e20, e=0x2636770) at kernel/qobject.cpp:1243
#15 0x00007f15b289b22c in QApplicationPrivate::notify_helper (this=0x196de40, receiver=0x1e90e20, e=0x2636770) at kernel/qapplication.cpp:4300
#16 0x00007f15b28a16fb in QApplication::notify (this=0x7fff9a9a5f30, receiver=0x1e90e20, e=0x2636770) at kernel/qapplication.cpp:4183
#17 0x00007f15b3ecf506 in KApplication::notify (this=0x7fff9a9a5f30, receiver=0x1e90e20, event=0x2636770) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f15b34e1fdc in QCoreApplication::notifyInternal (this=0x7fff9a9a5f30, receiver=0x1e90e20, event=0x2636770) at kernel/qcoreapplication.cpp:719
#19 0x00007f15b34e4757 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x19426a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x19426a0) at kernel/qcoreapplication.cpp:1345
#21 0x00007f15b350b943 in socketNotifierSourceCheck (source=0x19f6770) at kernel/qeventdispatcher_glib.cpp:99
#22 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-03-26 01:15:14 UTC

*** This bug has been marked as a duplicate of bug 194268 ***