Bug 200968 - Kontact crashed when starting korganizer
Summary: Kontact crashed when starting korganizer
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-21 10:34 UTC by karaluh
Modified: 2009-07-21 11:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description karaluh 2009-07-21 10:34:12 UTC
Application that crashed: kontact
Version of the application: 4.3.0 rc2
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.2
Operating System: Linux 2.6.31-3-generic i686
Distribution: Ubuntu karmic (development branch)

What I was doing when the application crashed:
After I quit contact I started it again. The resource migration dialog box appeared, but kontact didn't start. It was listed in ksysguard though. Ten I tried to start korganizer from krunner and Kontact crashed.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00c146b0 in Kontact::Plugin::part (this=0x9c1b7c8) at ../../kontactinterfaces/plugin.cpp:186
#7  0x0267a36a in KOrganizerUniqueAppHandler::newInstance (this=0x9c1b980) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0x00c16fd9 in Kontact::UniqueAppHandler::newInstance (this=0x9c1b980, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00c17064 in Kontact::UniqueAppHandler::qt_metacall (this=0x9c1b980, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbc5d7c) at ./uniqueapphandler.moc:73
#10 0x00eb4774 in QDBusConnectionPrivate::deliverCall (this=0x98d4160, object=0x9c1b980, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x00eb591d in QDBusConnectionPrivate::activateCall (this=0x98d4160, object=0x9c1b980, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00eb5f83 in QDBusConnectionPrivate::activateObject (this=0x98d4160, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x00eb649a in QDBusActivateObjectEvent::placeMetaCall (this=0x99a5018) at qdbusintegrator.cpp:1464
#14 0x004826de in QObject::event (this=0x9c1b980, e=0x99a5018) at kernel/qobject.cpp:1111
#15 0x010b3c34 in QApplicationPrivate::notify_helper (this=0x98dbf20, receiver=0x9c1b980, e=0x99a5018) at kernel/qapplication.cpp:4056
#16 0x010bb35c in QApplication::notify (this=0xbfbc66c4, receiver=0x9c1b980, e=0x99a5018) at kernel/qapplication.cpp:3603
#17 0x00898aaa in KApplication::notify (this=0xbfbc66c4, receiver=0x9c1b980, event=0x99a5018) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x004727ab in QCoreApplication::notifyInternal (this=0xbfbc66c4, receiver=0x9c1b980, event=0x99a5018) at kernel/qcoreapplication.cpp:610
#19 0x00473392 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x98bbb00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x98bbb00) at kernel/qcoreapplication.cpp:1247
#21 0x0047355d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x0049d4df in QCoreApplication::sendPostedEvents (s=0x98ddf18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x98ddf18) at kernel/qeventdispatcher_glib.cpp:210
#24 0x020d2bc8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x020d6470 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x020d65a3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0x0049d10c in QEventDispatcherGlib::processEvents (this=0x98bbcd8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x011547a5 in QGuiEventDispatcherGlib::processEvents (this=0x98bbcd8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00470d59 in QEventLoop::processEvents (this=0xbfbc6624, flags=) at kernel/qeventloop.cpp:149
#30 0x004711aa in QEventLoop::exec (this=0xbfbc6624, flags=...) at kernel/qeventloop.cpp:201
#31 0x0047361f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x010b3ab7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4d6 in main (argc=3, argv=0xbfbc68c4) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-07-21 11:16:31 UTC

*** This bug has been marked as a duplicate of bug 194268 ***