Bug 246414 - kontact crashes and thrown an akonadi error.
Summary: kontact crashes and thrown an akonadi error.
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-01 13:23 UTC by PULERI SALVATORE
Modified: 2010-09-19 21:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PULERI SALVATORE 2010-08-01 13:23:36 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
dopo l'avvio di kontact il sistema si blocca per qualche minuto e rilascia un errore nel quale viene indicato che la risorsa akonadi presenta degli errori.
a seguito di questa segnalazione la rubrica dei contatti cessa di funzionare.
disattivando l'applicazione, al riavvio, in alcuni casi non si attiva o, in alternativa, riprende a funzionare perfettamente.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd3d77e8780 (LWP 1454))]

Thread 2 (Thread 0x7fd3ae90b710 (LWP 1621)):
#0  0x00007fd3d48b8f83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd3cd3ed4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fd3cd3ed8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fd3d5ca4566 in QEventDispatcherGlib::processEvents (this=0x24dc9c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007fd3d5c79992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fd3d5c79d6c in QEventLoop::exec (this=0x7fd3ae90ad90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fd3d5b83d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007fd3d5c5a178 in QInotifyFileSystemWatcherEngine::run (this=0x2348160) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd3d5b86775 in QThreadPrivate::start (arg=0x2348160) at thread/qthread_unix.cpp:248
#9  0x00007fd3cf9649ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007fd3d48c56fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd3d77e8780 (LWP 1454)):
[KCrash Handler]
#5  0x00007fd3d6e4b84a in KontactInterface::Plugin::part (this=0x1c63980) at ../../kontactinterface/plugin.cpp:190
#6  0x00007fd3be1b3e2b in KMailUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#7  0x00007fd3d6e4d0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x1c50450, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007fd3d6e4d114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x1c50450, _c=QMetaObject::InvokeMetaMethod, _id=29768064, _a=0x7fffe7612b00) at ./uniqueapphandler.moc:79
#9  0x00007fd3d30c6486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007fd3d30c76ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1c50450, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007fd3d30c7f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007fd3d30c8468 in QDBusActivateObjectEvent::placeMetaCall (this=0x2b7bda0) at qdbusintegrator.cpp:1477
#13 0x00007fd3d5c8ad49 in QObject::event (this=0x1c50450, e=0x2b7bda0) at kernel/qobject.cpp:1248
#14 0x00007fd3d503422c in QApplicationPrivate::notify_helper (this=0x174cb30, receiver=0x1c50450, e=0x2b7bda0) at kernel/qapplication.cpp:4300
#15 0x00007fd3d503a6fb in QApplication::notify (this=0x7fffe7613880, receiver=0x1c50450, e=0x2b7bda0) at kernel/qapplication.cpp:4183
#16 0x00007fd3d6663526 in KApplication::notify (this=0x7fffe7613880, receiver=0x1c50450, event=0x2b7bda0) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007fd3d5c7b06c in QCoreApplication::notifyInternal (this=0x7fffe7613880, receiver=0x1c50450, event=0x2b7bda0) at kernel/qcoreapplication.cpp:704
#18 0x00007fd3d5c7d7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1721620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1721620) at kernel/qcoreapplication.cpp:1345
#20 0x00007fd3d5ca49d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007fd3cd3e98c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007fd3cd3ed748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007fd3cd3ed8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007fd3d5ca4513 in QEventDispatcherGlib::processEvents (this=0x1720d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007fd3d50e446e in QGuiEventDispatcherGlib::processEvents (this=0x1c63980, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fd3d5c79992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fd3d5c79d6c in QEventLoop::exec (this=0x7fffe76137c0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fd3d5c7daab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 245901, bug 242078, bug 237446, bug 237352, bug 237094.

Reported using DrKonqi
Comment 1 FiNeX 2010-08-02 15:29:08 UTC
Hi Salvatore! Please, would you like to translate the description in english. 

Many thanks! :-) :-)


P.S: Next time remember to write a more descriptive title. :-) :-) :-) :-)
Comment 2 Christophe Giboudeaux 2010-09-19 21:57:37 UTC

*** This bug has been marked as a duplicate of bug 194268 ***