Bug 214750 - kontact crashing with segmentation fault
Summary: kontact crashing with segmentation fault
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-16 02:46 UTC by Vikram Dhillon
Modified: 2009-11-16 10:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vikram Dhillon 2009-11-16 02:46:58 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
While starting up kontact, nothing happens. It doesn't start and after about 5 or 6 times it shows this bug reporting window. And everytime bug reporting gui says the same thing: segmentation fault. My comptuer is updated very often, and I updated it before filing this bug

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7869700 (LWP 3737))]

Thread 2 (Thread 0xad6ffb70 (LWP 3816)):
#0  0x00bcf422 in __kernel_vsyscall ()
#1  0x043c4e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x05ab578d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x03475e67 in QWaitConditionPrivate::wait (this=0xb3dbc68, mutex=0xb3dbc64, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0xb3dbc68, mutex=0xb3dbc64, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0x03959922 in QHostInfoAgent::run (this=0xb3dbc58) at kernel/qhostinfo.cpp:260
#6  0x03474e32 in QThreadPrivate::start (arg=0xb3dbc58) at thread/qthread_unix.cpp:188
#7  0x043c080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x05aa87ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7869700 (LWP 3737)):
[KCrash Handler]
#6  0x00000000 in ?? ()
#7  0x04b5590b in KMailUniqueAppHandler::newInstance (this=0xa1c0e88) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0x006d8ff9 in Kontact::UniqueAppHandler::newInstance (this=0xa1c0e88, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x006d9084 in Kontact::UniqueAppHandler::qt_metacall (this=0xa1c0e88, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe88b9c) at ./uniqueapphandler.moc:73
#10 0x007777b4 in QDBusConnectionPrivate::deliverCall (this=0x9e8dc90, object=0xa1c0e88, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x0077895d in QDBusConnectionPrivate::activateCall (this=0x9e8dc90, object=0xa1c0e88, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00778fc3 in QDBusConnectionPrivate::activateObject (this=0x9e8dc90, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0x007794da in QDBusActivateObjectEvent::placeMetaCall (this=0xa185d28) at qdbusintegrator.cpp:1464
#14 0x035755fe in QObject::event (this=0xa1c0e88, e=0xa185d28) at kernel/qobject.cpp:1111
#15 0x00cf0f54 in QApplicationPrivate::notify_helper (this=0x9e9ea50, receiver=0xa1c0e88, e=0xa185d28) at kernel/qapplication.cpp:4056
#16 0x00cf867c in QApplication::notify (this=0xbfe894e4, receiver=0xa1c0e88, e=0xa185d28) at kernel/qapplication.cpp:3603
#17 0x0048fbfa in KApplication::notify (this=0xbfe894e4, receiver=0xa1c0e88, event=0xa185d28) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x035656cb in QCoreApplication::notifyInternal (this=0xbfe894e4, receiver=0xa1c0e88, event=0xa185d28) at kernel/qcoreapplication.cpp:610
#19 0x035662b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9e75820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9e75820) at kernel/qcoreapplication.cpp:1247
#21 0x0356647d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x035903ff in QCoreApplication::sendPostedEvents (s=0x9e96110) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x9e96110) at kernel/qeventdispatcher_glib.cpp:210
#24 0x01aa8e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x01aac720 in ?? () from /lib/libglib-2.0.so.0
#26 0x01aac853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0359002c in QEventDispatcherGlib::processEvents (this=0x9e759f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x00d91be5 in QGuiEventDispatcherGlib::processEvents (this=0x9e759f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x03563c79 in QEventLoop::processEvents (this=0xbfe89444, flags=) at kernel/qeventloop.cpp:149
#30 0x035640ca in QEventLoop::exec (this=0xbfe89444, flags=...) at kernel/qeventloop.cpp:201
#31 0x0356653f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00cf0dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in main (argc=1, argv=0xbfe89704) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-16 10:31:42 UTC

*** This bug has been marked as a duplicate of bug 194268 ***