Bug 200800 - Kontact not close sometimes
Summary: Kontact not close sometimes
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-19 21:11 UTC by Fabian B.
Modified: 2009-07-19 21:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian B. 2009-07-19 21:11:23 UTC
Application that crashed: kontact
Version of the application: 4.3.0 rc2
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.2
Operating System: Linux 2.6.31-3-generic i686
Distribution: Ubuntu karmic (development branch)

What I was doing when the application crashed:
Sometimes i want close kontact only the gui close but in the processmanager it runs. (so i can not start it again because it runs) and when i klick on the korganizer tray-icon kontact crash

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00000000 in ?? ()
#7  0x00b4f6d3 in Kontact::Plugin::part (this=0x9596290) at ../../kontactinterfaces/plugin.cpp:187
#8  0x0671e99a in KOrganizerUniqueAppHandler::newInstance (this=0x95963d0) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#9  0x00b51fd9 in Kontact::UniqueAppHandler::newInstance (this=0x95963d0, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#10 0x00b52064 in Kontact::UniqueAppHandler::qt_metacall (this=0x95963d0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa1a4ac) at ./uniqueapphandler.moc:73
#11 0x00ac7774 in QDBusConnectionPrivate::deliverCall (this=0x926df70, object=0x95963d0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#12 0x00ac891d in QDBusConnectionPrivate::activateCall (this=0x926df70, object=0x95963d0, flags=272, msg=...) at qdbusintegrator.cpp:796
#13 0x00ac8f83 in QDBusConnectionPrivate::activateObject (this=0x926df70, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#14 0x00ac949a in QDBusActivateObjectEvent::placeMetaCall (this=0x9eadf28) at qdbusintegrator.cpp:1464
#15 0x044d96de in QObject::event (this=0x95963d0, e=0x9eadf28) at kernel/qobject.cpp:1111
#16 0x00f31c34 in QApplicationPrivate::notify_helper (this=0x9279ca0, receiver=0x95963d0, e=0x9eadf28) at kernel/qapplication.cpp:4056
#17 0x00f3935c in QApplication::notify (this=0xbfa1adf4, receiver=0x95963d0, e=0x9eadf28) at kernel/qapplication.cpp:3603
#18 0x00625aaa in KApplication::notify (this=0xbfa1adf4, receiver=0x95963d0, event=0x9eadf28) at ../../kdeui/kernel/kapplication.cpp:302
#19 0x044c97ab in QCoreApplication::notifyInternal (this=0xbfa1adf4, receiver=0x95963d0, event=0x9eadf28) at kernel/qcoreapplication.cpp:610
#20 0x044ca392 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9255b00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9255b00) at kernel/qcoreapplication.cpp:1247
#22 0x044ca55d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#23 0x044f44df in QCoreApplication::sendPostedEvents (s=0x9281f18) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#24 postEventSourceDispatch (s=0x9281f18) at kernel/qeventdispatcher_glib.cpp:210
#25 0x07e23bc8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0x07e27470 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0x07e275a3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0x044f410c in QEventDispatcherGlib::processEvents (this=0x9255cd8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#29 0x00fd27a5 in QGuiEventDispatcherGlib::processEvents (this=0x9255cd8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#30 0x044c7d59 in QEventLoop::processEvents (this=0xbfa1ad54, flags=) at kernel/qeventloop.cpp:149
#31 0x044c81aa in QEventLoop::exec (this=0xbfa1ad54, flags=...) at kernel/qeventloop.cpp:201
#32 0x044ca61f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#33 0x00f31ab7 in QApplication::exec () at kernel/qapplication.cpp:3525
#34 0x0804b4d6 in main (argc=1, argv=0xbfa1aff4) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-19 21:51:02 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***