Bug 214583 - kontact crashed while trying to start
Summary: kontact crashed while trying to start
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-14 22:37 UTC by Joseph Rawson
Modified: 2009-11-15 03:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Rawson 2009-11-14 22:37:15 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
I'm sorry, but I don't have time now to check if this is a duplicate.  I installed debug packages, so I hope that the backtrace is at least a bit more helpful this time. :)

If this happens again, I'll try to be better about searching for a duplicate.


 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007f73c1c1f0bb in QWidget::show (this=0xc28830) at /usr/include/qt4/QtGui/qwidget.h:473
#7  Kontact::UniqueAppHandler::newInstance (this=0xc28830) at ../../kontactinterfaces/uniqueapphandler.cpp:137
#8  0x00007f73c1c1f162 in Kontact::UniqueAppHandler::newInstance (this=0xc28830, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007f73c1c1f1d3 in Kontact::UniqueAppHandler::qt_metacall (this=0xc28830, _c=QMetaObject::InvokeMetaMethod, _id=-1058916528, _a=0x7fff7ed46bf0) at ./uniqueapphandler.moc:73
#10 0x00007f73be05eb83 in QDBusConnectionPrivate::deliverCall (this=0x7df320, object=0xc28830, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x00007f73be05fe38 in QDBusConnectionPrivate::activateCall (this=0x7df320, object=0xc28830, flags=272, msg=...) at qdbusintegrator.cpp:803
#12 0x00007f73be06025b in QDBusConnectionPrivate::activateObject (this=0x7df320, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x00007f73be060758 in QDBusActivateObjectEvent::placeMetaCall (this=0x32386e0) at qdbusintegrator.cpp:1464
#14 0x00007f73c0b446c8 in QObject::event (this=0xc28830, e=0x32386e0) at kernel/qobject.cpp:1110
#15 0x00007f73bffae01d in QApplicationPrivate::notify_helper (this=0x7ea770, receiver=0xc28830, e=0x32386e0) at kernel/qapplication.cpp:4065
#16 0x00007f73bffb607a in QApplication::notify (this=0x7fff7ed47b80, receiver=0xc28830, e=0x32386e0) at kernel/qapplication.cpp:4030
#17 0x00007f73c14d40db in KApplication::notify (this=0x7fff7ed47b80, receiver=0xc28830, event=0x32386e0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f73c0b34c9c in QCoreApplication::notifyInternal (this=0x7fff7ed47b80, receiver=0xc28830, event=0x32386e0) at kernel/qcoreapplication.cpp:610
#19 0x00007f73c0b358e4 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x7c2340) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x7c2340) at kernel/qcoreapplication.cpp:1247
#21 0x00007f73c0b5d7d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#23 0x00007f73b9c6412a in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f73b9c67988 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f73b9c67b3c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f73c0b5d39c in QEventDispatcherGlib::processEvents (this=0x7c1f70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#27 0x00007f73c0044f1f in QGuiEventDispatcherGlib::processEvents (this=0x9ff6a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#28 0x00007f73c0b33562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f73c0b33934 in QEventLoop::exec (this=0x7fff7ed479e0, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007f73c0b35ba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#31 0x0000000000404751 in main (argc=1, argv=0x7fff7ed48168) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-15 03:07:56 UTC

*** This bug has been marked as a duplicate of bug 194268 ***