Bug 246527 - First time crash
Summary: First time crash
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-02 17:37 UTC by Tonny van Bommel
Modified: 2010-09-19 13:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tonny van Bommel 2010-08-02 17:37:41 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kontact crashes after first time start after boot or reboot

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78b2990 (LWP 1688))]

Thread 2 (Thread 0xb2fffb70 (LWP 1777)):
#0  0x025cce16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x02af36fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x02af8825 in QTimerInfoList::updateCurrentTime (this=0xa2a6604) at kernel/qeventdispatcher_unix.cpp:340
#3  0x02af886a in QTimerInfoList::timerWait (this=0xa2a6604, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x02af6818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb2fff0ac) at kernel/qeventdispatcher_glib.cpp:136
#5  0x02af68a5 in timerSourcePrepare (source=0x0, timeout=0x25d0ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x01c67aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x01c67ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x01c684b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x02af660f in QEventDispatcherGlib::processEvents (this=0x9ca3658, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x02ac9059 in QEventLoop::processEvents (this=0xb2fff270, flags=) at kernel/qeventloop.cpp:149
#11 0x02ac94aa in QEventLoop::exec (this=0xb2fff270, flags=...) at kernel/qeventloop.cpp:201
#12 0x029c55a8 in QThread::exec (this=0x9eefdf8) at thread/qthread.cpp:487
#13 0x02aa8c1b in QInotifyFileSystemWatcherEngine::run (this=0x9eefdf8) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x029c832e in QThreadPrivate::start (arg=0x9eefdf8) at thread/qthread_unix.cpp:248
#15 0x01be996e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x00b32a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78b2990 (LWP 1688)):
[KCrash Handler]
#6  0x00771b50 in KontactInterface::Plugin::part (this=0x9b766f8) at ../../kontactinterface/plugin.cpp:190
#7  0x09418a7d in KMailUniqueAppHandler::newInstance (this=0x9da4cc8) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0x007737e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x9da4cc8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00773874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x9da4cc8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfea063c) at ./uniqueapphandler.moc:79
#10 0x0060ab34 in QDBusConnectionPrivate::deliverCall (this=0x9a512c8, object=0x9da4cc8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x0060bddf in QDBusConnectionPrivate::activateCall (this=0x9a512c8, object=0x9da4cc8, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x0060c5ac in QDBusConnectionPrivate::activateObject (this=0x9a512c8, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0x0060cb1a in QDBusActivateObjectEvent::placeMetaCall (this=0xa1d4a50) at qdbusintegrator.cpp:1477
#14 0x02adb3fe in QObject::event (this=0x9da4cc8, e=0xa1d4a50) at kernel/qobject.cpp:1248
#15 0x011c54dc in QApplicationPrivate::notify_helper (this=0x9a590a8, receiver=0x9da4cc8, e=0xa1d4a50) at kernel/qapplication.cpp:4300
#16 0x011cc05e in QApplication::notify (this=0xbfea1054, receiver=0x9da4cc8, e=0xa1d4a50) at kernel/qapplication.cpp:3704
#17 0x00eb8f2a in KApplication::notify (this=0xbfea1054, receiver=0x9da4cc8, event=0xa1d4a50) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x02acaa3b in QCoreApplication::notifyInternal (this=0xbfea1054, receiver=0x9da4cc8, event=0xa1d4a50) at kernel/qcoreapplication.cpp:704
#19 0x02acd473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9a39a60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9a39a60) at kernel/qcoreapplication.cpp:1345
#21 0x02acd5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x02af6adf in QCoreApplication::sendPostedEvents (s=0x9a5eb90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x9a5eb90) at kernel/qeventdispatcher_glib.cpp:276
#24 0x01c645e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x01c682d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x01c684b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x02af65d5 in QEventDispatcherGlib::processEvents (this=0x9a39588, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x01285135 in QGuiEventDispatcherGlib::processEvents (this=0x9a39588, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x02ac9059 in QEventLoop::processEvents (this=0xbfea0fb4, flags=) at kernel/qeventloop.cpp:149
#30 0x02ac94aa in QEventLoop::exec (this=0xbfea0fb4, flags=...) at kernel/qeventloop.cpp:201
#31 0x02acd69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x011c5577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=1, argv=0xbfea1274) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 246414, bug 245901, bug 242078, bug 237446, bug 237352.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-09-19 13:40:46 UTC

*** This bug has been marked as a duplicate of bug 194268 ***