Bug 214609 - Kontact crashes after closing and trying to restart.
Summary: Kontact crashes after closing and trying to restart.
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-15 04:30 UTC by Bret Fledderjohn
Modified: 2009-11-16 00:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bret Fledderjohn 2009-11-15 04:30:28 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
When I close Kontact and try to restart the application it crashes.  It won't even register a crash when trying to load kontact directly, but when I try to start Akkregator it displays the crash report.

kontact PID: 1662 Signal: 11 (Segmentation fault)

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00000000024c4f70 in ?? ()
#6  0x00007f3fbabbccf9 in Kontact::Plugin::part (this=0x24e2520) at ../../kontactinterfaces/plugin.cpp:187
#7  0x00007f3fa4618777 in AkregatorUniqueAppHandler::newInstance (this=0x24cc310) at ../../../../kontact/plugins/akregator/akregator_plugin.cpp:155
#8  0x00007f3fbabbf0f9 in Kontact::UniqueAppHandler::newInstance (this=0x24cc310, asn_id=<value optimized out>, args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007f3fbabbf164 in Kontact::UniqueAppHandler::qt_metacall (this=0x24cc310, _c=QMetaObject::InvokeMetaMethod, _id=38661136, _a=0x7fffec29f070) at ./uniqueapphandler.moc:73
#10 0x00007f3fb7047ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#11 0x00007f3fb7048c69 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x24cc310, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00007f3fb70492d5 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=..., msg=<value optimized out>, pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1370
#13 0x00007f3fb70497c8 in QDBusActivateObjectEvent::placeMetaCall (this=0x3843890) at qdbusintegrator.cpp:1464
#14 0x00007f3fb8f270f9 in QObject::event (this=0x24cc310, e=0x3843890) at kernel/qobject.cpp:1111
#15 0x00007f3fb9837efc in QApplicationPrivate::notify_helper (this=0x203b070, receiver=0x24cc310, e=0x3843890) at kernel/qapplication.cpp:4056
#16 0x00007f3fb983f1ce in QApplication::notify (this=0x7fffec29fc80, receiver=0x24cc310, e=0x3843890) at kernel/qapplication.cpp:4021
#17 0x00007f3fba46eab6 in KApplication::notify (this=0x7fffec29fc80, receiver=0x24cc310, event=0x3843890) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f3fb8f17c2c in QCoreApplication::notifyInternal (this=0x7fffec29fc80, receiver=0x24cc310, event=0x3843890) at kernel/qcoreapplication.cpp:610
#19 0x00007f3fb8f1880a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x2006080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x2006080) at kernel/qcoreapplication.cpp:1247
#21 0x00007f3fb8f40533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#23 0x00007f3fb2791bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f3fb2795588 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f3fb27956b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f3fb8f401a6 in QEventDispatcherGlib::processEvents (this=0x2005cb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#27 0x00007f3fb98cc4be in QGuiEventDispatcherGlib::processEvents (this=0x24e2520, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#28 0x00007f3fb8f16532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f3fb8f16904 in QEventLoop::exec (this=0x7fffec29fbc0, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f3fb8f18ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#31 0x0000000000403f47 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 206675

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-16 00:30:19 UTC

*** This bug has been marked as a duplicate of bug 194268 ***