Bug 206710 - After close of kontact the process does not quit and starting akregator causes segfault
Summary: After close of kontact the process does not quit and starting akregator cause...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-08 05:08 UTC by kbogert
Modified: 2009-09-08 09:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kbogert 2009-09-08 05:08:52 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-server i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
The kontact process seems to have trouble exiting.  Sometimes starting one of its sub applications after closing kontact (akregator does it most often for me) will cause a segfault, but most of the time it completely prevents another kontact instance from starting or any of the sub apps from starting when this occurs.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x000000a8 in ?? ()
#7  0xb0f953bf in AkregatorUniqueAppHandler::newInstance (this=0x8582a98) at /build/buildd/kdepim-4.3.1/kontact/plugins/akregator/akregator_plugin.cpp:155
#8  0xb7963f39 in Kontact::UniqueAppHandler::newInstance (this=0x8582a98, asn_id=@0x82d9858, args=@0x82d77a8) at /build/buildd/kdepim-4.3.1/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7963fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x8582a98, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfff4708)
    at /build/buildd/kdepim-4.3.1/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e6ae5a in QDBusConnectionPrivate::deliverCall (this=0x80a8f40, object=0x8582a98, msg=@0xc8bc340, metaTypes=@0xbfff47b8, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e6c072 in QDBusConnectionPrivate::activateCall (this=0x80a8f40, object=0x8582a98, flags=272, msg=@0xc8bc340) at qdbusintegrator.cpp:796
#12 0xb5e6c5e1 in QDBusConnectionPrivate::activateObject (this=0x80a8f40, node=@0xc8bc32c, msg=@0xc8bc340, pathStartPos=25) at qdbusintegrator.cpp:1370
#13 0xb5e6cada in QDBusActivateObjectEvent::placeMetaCall (this=0xc8bc300) at qdbusintegrator.cpp:1464
#14 0xb5d633b0 in QObject::event (this=0x8582a98, e=0xc8bc300) at kernel/qobject.cpp:1111
#15 0xb6215d3c in QApplicationPrivate::notify_helper (this=0x80b77e8, receiver=0x8582a98, e=0xc8bc300) at kernel/qapplication.cpp:4056
#16 0xb621e03e in QApplication::notify (this=0xbfff4f88, receiver=0x8582a98, e=0xc8bc300) at kernel/qapplication.cpp:3603
#17 0xb6e0f85d in KApplication::notify (this=0xbfff4f88, receiver=0x8582a98, event=0xc8bc300) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5d52bcb in QCoreApplication::notifyInternal (this=0xbfff4f88, receiver=0x8582a98, event=0xc8bc300) at kernel/qcoreapplication.cpp:610
#19 0xb5d53825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8091440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5d53a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d7e6af in postEventSourceDispatch (s=0x80bf710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4e23b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4e270eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4e27268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5d7e2f8 in QEventDispatcherGlib::processEvents (this=0x8091028, flags={i = -1073787304}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb62b7a75 in QGuiEventDispatcherGlib::processEvents (this=0x8091028, flags={i = -1073787256}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5d511fa in QEventLoop::processEvents (this=0xbfff4f00, flags={i = -1073787192}) at kernel/qeventloop.cpp:149
#28 0xb5d51642 in QEventLoop::exec (this=0xbfff4f00, flags={i = -1073787128}) at kernel/qeventloop.cpp:201
#29 0xb5d53ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb6215bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=1, argv=0xbfff5284) at /build/buildd/kdepim-4.3.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 206002

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-08 09:29:40 UTC

*** This bug has been marked as a duplicate of bug 194268 ***