Bug 205334 - Kontact crashes after exit when clicking on korganizer system tray icon
Summary: Kontact crashes after exit when clicking on korganizer system tray icon
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-27 14:23 UTC by boris64
Modified: 2009-08-27 14:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boris64 2009-08-27 14:23:55 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-rc7-2k9-gcc441-00094-g9c93768-dirty x86_64

What I was doing when the application crashed:
1. Exit Kontact (after using Kmail/Akregator for about a day)
2. Try to restart Kontact (doesn't work, no error message)
3. Doubleclick on the KOrganizer-Icon in the system tray
--> Kontact crashes with the following backtrace

This doesn't seem to happen everytime, but it did 
more than 4 time the last week.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000000001 in ?? ()
#6  0x0000003002c0d859 in Kontact::Plugin::part (this=<value optimized out>) at /tmp/portage/portage/kde-base/kontactinterfaces-4.3.0/work/kontactinterfaces-4.3.0/kontactinterfaces/plugin.cpp:187
#7  0x00007fc792456971 in KOrganizerUniqueAppHandler::newInstance (this=0x1c1cc40)
    at /tmp/portage/portage/kde-base/korganizer-4.3.0/work/korganizer-4.3.0/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0x0000003002c0fd72 in Kontact::UniqueAppHandler::newInstance (this=<value optimized out>, asn_id=<value optimized out>, args=<value optimized out>)
    at /tmp/portage/portage/kde-base/kontactinterfaces-4.3.0/work/kontactinterfaces-4.3.0/kontactinterfaces/uniqueapphandler.cpp:128
#9  0x0000003002c0fde4 in Kontact::UniqueAppHandler::qt_metacall (this=<value optimized out>, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>)
    at /tmp/portage/portage/kde-base/kontactinterfaces-4.3.0/work/kontactinterfaces-4.3.0_build/kontactinterfaces/uniqueapphandler.moc:73
#10 0x0000003b4de213d4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=<value optimized out>, 
    slotIdx=<value optimized out>) at qdbusintegrator.cpp:891
#11 0x0000003b4de2238a in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=<value optimized out>, flags=<value optimized out>, msg=<value optimized out>)
    at qdbusintegrator.cpp:796
#12 0x0000003b4de22845 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=<value optimized out>, pathStartPos=<value optimized out>)
    at qdbusintegrator.cpp:1370
#13 0x0000003b4de22d38 in QDBusActivateObjectEvent::placeMetaCall (this=<value optimized out>) at qdbusintegrator.cpp:1464
#14 0x0000003b4d14a589 in QObject::event (this=<value optimized out>, e=<value optimized out>) at kernel/qobject.cpp:1099
#15 0x0000003001b8bb6c in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4056
#16 0x0000003001b92a60 in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4021
#17 0x00000030043f4b81 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>)
    at /tmp/portage/portage/kde-base/kdelibs-4.3.0/work/kdelibs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0x0000003b4d13af1b in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:606
#19 0x0000003b4d13d43b in QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0x0000003b4d162823 in postEventSourceDispatch (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 0x0000003b4983766d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0x0000003b4983ae18 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#23 0x0000003b4983af40 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0x0000003b4d162556 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#25 0x0000003001c18bde in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x0000003b4d139a52 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#27 0x0000003b4d139bed in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:197
#28 0x0000003b4d13d84b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#29 0x0000000000403a8d in main (argc=<value optimized out>, argv=<value optimized out>) at /tmp/portage/portage/kde-base/kontact-4.3.0/work/kontact-4.3.0/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-08-27 14:30:14 UTC

*** This bug has been marked as a duplicate of bug 194268 ***