Bug 255029 - Kontact crashed after closing Kontact
Summary: Kontact crashed after closing Kontact
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.5
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-23 11:32 UTC by Christopher Yeleighton
Modified: 2010-10-31 01:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Yeleighton 2010-10-23 11:32:39 UTC
Application: kontact (4.4.5)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.4-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I closed Kontact to avoid the "too many files open" instability and tried to launch it again.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#5  0x00007f440023e4a3 in KontactInterface::Plugin::part (this=0xb118c0) at /usr/src/debug/kdepimlibs-4.4.4/kontactinterface/plugin.cpp:191
#6  0x00007f43e7f9310b in KMailUniqueAppHandler::newInstance (this=0x985900) at /usr/src/debug/kdepim-4.4.4/kontact/plugins/kmail/kmail_plugin.cpp:216
#7  0x00007f440023cb89 in KontactInterface::UniqueAppHandler::newInstance (this=0x985900, asn_id=<value optimized out>, args=...)
    at /usr/src/debug/kdepimlibs-4.4.4/kontactinterface/uniqueapphandler.cpp:129
#8  0x00007f440023e574 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x985900, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff82d33e10)
    at /usr/src/debug/kdepimlibs-4.4.4/build/kontactinterface/uniqueapphandler.moc:79
#9  0x00007f43fc636188 in QDBusConnectionPrivate::deliverCall (this=0x62f1b0, object=0x985900, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#10 0x00007f43fc6381ae in QDBusConnectionPrivate::activateCall (this=0x62f1b0, object=0x985900, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f43fc63885c in QDBusConnectionPrivate::activateObject (this=0x62f1b0, node=..., msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f43fc638cf8 in QDBusActivateObjectEvent::placeMetaCall (this=0x12727d0) at qdbusintegrator.cpp:1477
#13 0x00007f43ff134509 in QObject::event (this=0x985900, e=0x12727d0) at kernel/qobject.cpp:1248
#14 0x00007f43fe5144d4 in QApplicationPrivate::notify_helper (this=0x643270, receiver=0x985900, e=0x12727d0) at kernel/qapplication.cpp:4302
#15 0x00007f43fe51caca in QApplication::notify (this=<value optimized out>, receiver=0x985900, e=0x12727d0) at kernel/qapplication.cpp:4185
#16 0x00007f43ffa05c06 in KApplication::notify (this=0x7fff82d34b60, receiver=0x985900, event=0x12727d0) at /usr/src/debug/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#17 0x00007f43ff122e4c in QCoreApplication::notifyInternal (this=0x7fff82d34b60, receiver=0x985900, event=0x12727d0) at kernel/qcoreapplication.cpp:726
#18 0x00007f43ff1265ba in sendEvent (receiver=0x0, event_type=0, data=0x60db90) at kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60db90) at kernel/qcoreapplication.cpp:1367
#20 0x00007f43ff14b173 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f43f6c4ba93 in g_main_dispatch (context=0x63c920) at gmain.c:1960
#23 IA__g_main_context_dispatch (context=0x63c920) at gmain.c:2513
#24 0x00007f43f6c4c270 in g_main_context_iterate (context=0x63c920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#25 0x00007f43f6c4c510 in IA__g_main_context_iteration (context=0x63c920, may_block=1) at gmain.c:2654
#26 0x00007f43ff14b67f in QEventDispatcherGlib::processEvents (this=0x613220, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x00007f43fe5b514e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f43ff122292 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f43ff122495 in QEventLoop::exec (this=0x7fff82d34ab0, flags=...) at kernel/qeventloop.cpp:201
#30 0x00007f43ff12688b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#31 0x000000000040417e in main (argc=1, argv=0x7fff82d35148) at /usr/src/debug/kdepim-4.4.4/kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 253472, bug 249231, bug 246527, bug 246414, bug 245901.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-31 01:14:38 UTC

*** This bug has been marked as a duplicate of bug 194268 ***