Bug 205023 - Starting Korganizer from system tray causes seg fault error 11
Summary: Starting Korganizer from system tray causes seg fault error 11
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-25 00:19 UTC by Kevin Kraft
Modified: 2009-08-25 00:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Kraft 2009-08-25 00:19:57 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-14-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Clicked on the Korganizer icon and received a seg fault error 11 message.  This is after Kontact would not load, Akonadi was restarted and have received numerous Akonadi-related errors since upgrading to KDE 4.3.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x89d86e0) at /build/buildd/kdepim-4.3.0/kontactinterfaces/plugin.cpp:186
#7  0xb19b226a in KOrganizerUniqueAppHandler::newInstance (this=0x89ee248) at /build/buildd/kdepim-4.3.0/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb7947f39 in Kontact::UniqueAppHandler::newInstance (this=0x89ee248, asn_id=@0x8a1e528, args=@0x8b87078) at /build/buildd/kdepim-4.3.0/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7947fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x89ee248, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfada918)
    at /build/buildd/kdepim-4.3.0/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5e51e5a in QDBusConnectionPrivate::deliverCall (this=0x8665f40, object=0x89ee248, msg=@0x9d9a238, metaTypes=@0xbfada9c8, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5e53072 in QDBusConnectionPrivate::activateCall (this=0x8665f40, object=0x89ee248, flags=272, msg=@0x9d9a238) at qdbusintegrator.cpp:796
#12 0xb5e535e1 in QDBusConnectionPrivate::activateObject (this=0x8665f40, node=@0x9d9a224, msg=@0x9d9a238, pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0xb5e53ada in QDBusActivateObjectEvent::placeMetaCall (this=0x9d9a1f8) at qdbusintegrator.cpp:1464
#14 0xb5d4b3b0 in QObject::event (this=0x89ee248, e=0x9d9a1f8) at kernel/qobject.cpp:1111
#15 0xb61fbd3c in QApplicationPrivate::notify_helper (this=0x8671cd8, receiver=0x89ee248, e=0x9d9a1f8) at kernel/qapplication.cpp:4056
#16 0xb620403e in QApplication::notify (this=0xbfadb198, receiver=0x89ee248, e=0x9d9a1f8) at kernel/qapplication.cpp:3603
#17 0xb6df45cd in KApplication::notify (this=0xbfadb198, receiver=0x89ee248, event=0x9d9a1f8) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0xb5d3abcb in QCoreApplication::notifyInternal (this=0xbfadb198, receiver=0x89ee248, event=0x9d9a1f8) at kernel/qcoreapplication.cpp:610
#19 0xb5d3b825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x864e440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5d3ba1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5d666af in postEventSourceDispatch (s=0x86765a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4e0cb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4e100eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4e10268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5d662f8 in QEventDispatcherGlib::processEvents (this=0x864e028, flags={i = -1079136152}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb629da75 in QGuiEventDispatcherGlib::processEvents (this=0x864e028, flags={i = -1079136104}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5d391fa in QEventLoop::processEvents (this=0xbfadb110, flags={i = -1079136040}) at kernel/qeventloop.cpp:149
#28 0xb5d39642 in QEventLoop::exec (this=0xbfadb110, flags={i = -1079135976}) at kernel/qeventloop.cpp:201
#29 0xb5d3bae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb61fbbb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=1, argv=0xbfadb494) at /build/buildd/kdepim-4.3.0/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-08-25 00:23:55 UTC

*** This bug has been marked as a duplicate of bug 194268 ***