Bug 256717 - Kontact crashes on opening
Summary: Kontact crashes on opening
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-12 16:56 UTC by Michael
Modified: 2010-11-29 16:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2010-11-12 16:56:47 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Kontact would bring up error message re. Akonadi / MySQL, as per 
The MySQL server error log file /home/vincent/.local/share/akonadi/db_data/mysql.err contains errors.
... no resource found.
I stopped akonadictl, hid the db_data sudirectory, recreated mysqldb with:
mysql_install_db --force --datadir=$HOME/.local/share/akonadi/db_data/
restarted akonadictl
and restarted Kontact. First time it appeared to work OK, then once I'd closed it the present error happened repeatedly.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb788c990 (LWP 14378))]

Thread 2 (Thread 0xb19d0b70 (LWP 14401)):
#0  0x05589e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x022366fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x0223b825 in QTimerInfoList::updateCurrentTime (this=0xa051bc4) at kernel/qeventdispatcher_unix.cpp:340
#3  0x0223b86a in QTimerInfoList::timerWait (this=0xa051bc4, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x02239818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb19d00ac) at kernel/qeventdispatcher_glib.cpp:136
#5  0x022398a5 in timerSourcePrepare (source=0x0, timeout=0x558dff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x0968faca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x0968fee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x096904b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x0223960f in QEventDispatcherGlib::processEvents (this=0xa265788, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x0220c059 in QEventLoop::processEvents (this=0xb19d0270, flags=) at kernel/qeventloop.cpp:149
#11 0x0220c4aa in QEventLoop::exec (this=0xb19d0270, flags=...) at kernel/qeventloop.cpp:201
#12 0x021085a8 in QThread::exec (this=0xa2615a8) at thread/qthread.cpp:487
#13 0x021ebc1b in QInotifyFileSystemWatcherEngine::run (this=0xa2615a8) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x0210b32e in QThreadPrivate::start (arg=0xa2615a8) at thread/qthread_unix.cpp:248
#15 0x06eb896e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x00c53a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb788c990 (LWP 14378)):
[KCrash Handler]
#6  QBasicAtomicInt::deref (this=0x9b97e08) at /usr/include/qt4/QtCore/qatomic_i386.h:132
#7  ~QString (this=0x9b97e08) at /usr/include/qt4/QtCore/qstring.h:869
#8  KCMultiDialog::slotHelpClicked (this=0x9b97e08) at ../../kutils/kcmultidialog.cpp:304
#9  0x0954cd7a in ?? () from /usr/lib/kde4/kontact_todoplugin.so
#10 0x008907e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x99531a8, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#11 0x00890874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x99531a8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf90c56c) at ./uniqueapphandler.moc:79
#12 0x007d2b34 in QDBusConnectionPrivate::deliverCall (this=0x9823d88, object=0x99531a8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#13 0x007d3ddf in QDBusConnectionPrivate::activateCall (this=0x9823d88, object=0x99531a8, flags=272, msg=...) at qdbusintegrator.cpp:809
#14 0x007d45ac in QDBusConnectionPrivate::activateObject (this=0x9823d88, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#15 0x007d4b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9d224d0) at qdbusintegrator.cpp:1477
#16 0x0221e3fe in QObject::event (this=0x99531a8, e=0x9d224d0) at kernel/qobject.cpp:1248
#17 0x0317f4dc in QApplicationPrivate::notify_helper (this=0x982de28, receiver=0x99531a8, e=0x9d224d0) at kernel/qapplication.cpp:4300
#18 0x0318605e in QApplication::notify (this=0xbf90cf84, receiver=0x99531a8, e=0x9d224d0) at kernel/qapplication.cpp:3704
#19 0x00393f2a in KApplication::notify (this=0xbf90cf84, receiver=0x99531a8, event=0x9d224d0) at ../../kdeui/kernel/kapplication.cpp:302
#20 0x0220da3b in QCoreApplication::notifyInternal (this=0xbf90cf84, receiver=0x99531a8, event=0x9d224d0) at kernel/qcoreapplication.cpp:704
#21 0x02210473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x980c4e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x980c4e0) at kernel/qcoreapplication.cpp:1345
#23 0x022105dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#24 0x02239adf in QCoreApplication::sendPostedEvents (s=0x9832a80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0x9832a80) at kernel/qeventdispatcher_glib.cpp:276
#26 0x0968c5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x096902d8 in ?? () from /lib/libglib-2.0.so.0
#28 0x096904b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x022395d5 in QEventDispatcherGlib::processEvents (this=0x980c070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#30 0x0323f135 in QGuiEventDispatcherGlib::processEvents (this=0x980c070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x0220c059 in QEventLoop::processEvents (this=0xbf90cee4, flags=) at kernel/qeventloop.cpp:149
#32 0x0220c4aa in QEventLoop::exec (this=0xbf90cee4, flags=...) at kernel/qeventloop.cpp:201
#33 0x0221069f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#34 0x0317f577 in QApplication::exec () at kernel/qapplication.cpp:3579
#35 0x0804b472 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-11-29 16:01:44 UTC

*** This bug has been marked as a duplicate of bug 194268 ***