Bug 215169 - Kontact crashes while startup
Summary: Kontact crashes while startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-18 20:28 UTC by Max Rohland
Modified: 2009-11-18 21:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Rohland 2009-11-18 20:28:33 UTC
Application that crashed: kontact
Version of the application: 4.3.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00007fba6dddbcca in Kontact::Plugin::part (this=0x206f970) at ../../kontactinterfaces/plugin.cpp:186
#6  0x00007fba57d23bb6 in KMailUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:208
#7  0x00007fba6ddde0f9 in Kontact::UniqueAppHandler::newInstance (this=0x2079390, asn_id=<value optimized out>, args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#8  0x00007fba6ddde164 in Kontact::UniqueAppHandler::qt_metacall (this=0x2079390, _c=QMetaObject::InvokeMetaMethod, _id=34011504, _a=0x7fff7a74ee60) at ./uniqueapphandler.moc:73
#9  0x00007fba6a267ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#10 0x00007fba6a268c69 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x2079390, flags=272, msg=...) at qdbusintegrator.cpp:796
#11 0x00007fba6a2692d5 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=..., msg=<value optimized out>, pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1370
#12 0x00007fba6a2697c8 in QDBusActivateObjectEvent::placeMetaCall (this=0x1cb4ce0) at qdbusintegrator.cpp:1464
#13 0x00007fba6c1460f9 in QObject::event (this=0x2079390, e=0x1cb4ce0) at kernel/qobject.cpp:1111
#14 0x00007fba6ca56efc in QApplicationPrivate::notify_helper (this=0x1b6f790, receiver=0x2079390, e=0x1cb4ce0) at kernel/qapplication.cpp:4056
#15 0x00007fba6ca5e1ce in QApplication::notify (this=0x7fff7a74fa70, receiver=0x2079390, e=0x1cb4ce0) at kernel/qapplication.cpp:4021
#16 0x00007fba6d68de56 in KApplication::notify (this=0x7fff7a74fa70, receiver=0x2079390, event=0x1cb4ce0) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007fba6c136c2c in QCoreApplication::notifyInternal (this=0x7fff7a74fa70, receiver=0x2079390, event=0x1cb4ce0) at kernel/qcoreapplication.cpp:610
#18 0x00007fba6c13780a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1b3c080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1b3c080) at kernel/qcoreapplication.cpp:1247
#20 0x00007fba6c15f533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#22 0x00007fba659b1bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007fba659b5588 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007fba659b56b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007fba6c15f1a6 in QEventDispatcherGlib::processEvents (this=0x1b3bcb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007fba6caeb4be in QGuiEventDispatcherGlib::processEvents (this=0x206f970, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007fba6c135532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007fba6c135904 in QEventLoop::exec (this=0x7fff7a74f9b0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007fba6c137ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000403f47 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-18 21:46:57 UTC

*** This bug has been marked as a duplicate of bug 194268 ***