Bug 223045 - kcontact error jan 16 2010
Summary: kcontact error jan 16 2010
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-16 23:35 UTC by Chuck
Modified: 2010-01-18 22:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck 2010-01-16 23:35:05 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
started kmail and obtained crash error

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1fe8e33750 (LWP 4229))]

Thread 2 (Thread 0x7f1fc9804910 (LWP 4918)):
#0  0x00007f1fe01a85a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f1fe6a954fb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f1fe1cca78c in ?? () from /usr/lib/libQtNetwork.so.4
#3  0x00007f1fe6a94445 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f1fe01a3a04 in start_thread () from /lib/libpthread.so.0
#5  0x00007f1fe649680d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1fe8e33750 (LWP 4229)):
[KCrash Handler]
#5  0x00007f1fe881fcf3 in Kontact::Plugin::part() () from /usr/lib/libkontactinterfaces.so.4
#6  0x00007f1fd28d3bf1 in ?? () from /usr/lib/kde4/kontact_korganizerplugin.so
#7  0x00007f1fe88220f9 in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterfaces.so.4
#8  0x00007f1fe8822164 in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterfaces.so.4
#9  0x00007f1fe4caaad4 in ?? () from /usr/lib/libQtDBus.so.4
#10 0x00007f1fe4cabc69 in ?? () from /usr/lib/libQtDBus.so.4
#11 0x00007f1fe4cac2d5 in ?? () from /usr/lib/libQtDBus.so.4
#12 0x00007f1fe4cac7c8 in ?? () from /usr/lib/libQtDBus.so.4
#13 0x00007f1fe6b8a0f9 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0x00007f1fe749aefc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x00007f1fe74a21ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f1fe80d1ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x00007f1fe6b7ac2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x00007f1fe6b7b80a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#19 0x00007f1fe6ba3533 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f1fe03f4bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#21 0x00007f1fe03f8598 in ?? () from /lib/libglib-2.0.so.0
#22 0x00007f1fe03f86c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#23 0x00007f1fe6ba31a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#24 0x00007f1fe752f4be in ?? () from /usr/lib/libQtGui.so.4
#25 0x00007f1fe6b79532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f1fe6b79904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f1fe6b7bab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#28 0x0000000000403f47 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-18 22:08:44 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***