Bug 254686 - Kontact crash when using "Kalender-Export" in Application TV Browser 3.0
Summary: Kontact crash when using "Kalender-Export" in Application TV Browser 3.0
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-19 21:24 UTC by uwe.helms
Modified: 2010-10-20 12:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description uwe.helms 2010-10-19 21:24:48 UTC
Application: kontact (4.4.6)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Using the "Kaledner-Export"-Plugin --> export to KOrgenazier in Application TV Browser (http://www.tvbrowser.org/).
This happend from Time to Time.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb9e47b6780 (LWP 3368))]

Thread 4 (Thread 0x7fb9bd185710 (LWP 3385)):
#0  0x00007fb9e17f21d3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb9da565009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fb9da56545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fb9e1f361e6 in QEventDispatcherGlib::processEvents (this=0x1b85780, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fb9e1f08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fb9e1f08dec in QEventLoop::exec (this=0x7fb9bd184d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fb9e1e132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fb9e1ee85f8 in QInotifyFileSystemWatcherEngine::run (this=0x1cdaf60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb9e1e1627e in QThreadPrivate::start (arg=0x1cdaf60) at thread/qthread_unix.cpp:266
#9  0x00007fb9dc8f4971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fb9e17fe91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb9ab553710 (LWP 3505)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007fb9b49239b1 in ?? () from /usr/local/lib/libxine.so.1
#2  0x00007fb9dc8f4971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007fb9e17fe91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb9a9f2c710 (LWP 3507)):
#0  0x00007fb9e1f36387 in timerSourceCheck (source=0x5addc00) at kernel/qeventdispatcher_glib.cpp:175
#1  0x00007fb9da56466a in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0x00007fb9da565023 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007fb9da56545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007fb9e1f361e6 in QEventDispatcherGlib::processEvents (this=0x4589fa0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007fb9e1f08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007fb9e1f08dec in QEventLoop::exec (this=0x7fb9a9f2bd70, flags=) at kernel/qeventloop.cpp:201
#7  0x00007fb9e1e132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fb9b4b7f2b0 in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#9  0x00007fb9e1e1627e in QThreadPrivate::start (arg=0x5f74770) at thread/qthread_unix.cpp:266
#10 0x00007fb9dc8f4971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007fb9e17fe91d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb9e47b6780 (LWP 3368)):
[KCrash Handler]
#6  0x00007fb9e3e219da in KontactInterface::Plugin::part (this=0xa2c8b0) at ../../kontactinterface/plugin.cpp:190
#7  0x00007fb9c8088711 in KOrganizerUniqueAppHandler::newInstance (this=0x157f020) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x00007fb9e3e229f9 in KontactInterface::UniqueAppHandler::newInstance (this=0x157f020, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007fb9e3e22a64 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x157f020, _c=QMetaObject::InvokeMetaMethod, _id=10668208, _a=0x7fffbf5a0d60) at ./uniqueapphandler.moc:79
#10 0x00007fb9dffd30ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#11 0x00007fb9dffd436f in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x157f020, flags=272, msg=...) at qdbusintegrator.cpp:822
#12 0x00007fb9dffd4bae in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1399
#13 0x00007fb9dffd5108 in QDBusActivateObjectEvent::placeMetaCall (this=0x7b282c0) at qdbusintegrator.cpp:1493
#14 0x00007fb9e1f1bbde in QObject::event (this=0x157f020, e=0xa2c8b0) at kernel/qobject.cpp:1219
#15 0x00007fb9e28bffdc in QApplicationPrivate::notify_helper (this=0x857520, receiver=0x157f020, e=0x7b282c0) at kernel/qapplication.cpp:4396
#16 0x00007fb9e28c5aed in QApplication::notify (this=0x7fffbf5a1ae0, receiver=0x157f020, e=0x7b282c0) at kernel/qapplication.cpp:4277
#17 0x00007fb9e3612156 in KApplication::notify (this=0x7fffbf5a1ae0, receiver=0x157f020, event=0x7b282c0) at ../../kdeui/kernel/kapplication.cpp:310
#18 0x00007fb9e1f09cdc in QCoreApplication::notifyInternal (this=0x7fffbf5a1ae0, receiver=0x157f020, event=0x7b282c0) at kernel/qcoreapplication.cpp:732
#19 0x00007fb9e1f0cc22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x826380) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x826380) at kernel/qcoreapplication.cpp:1373
#21 0x00007fb9e1f36653 in sendPostedEvents (s=0x853990) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=0x853990) at kernel/qeventdispatcher_glib.cpp:277
#23 0x00007fb9da561342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007fb9da5652a8 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007fb9da56545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007fb9e1f36193 in QEventDispatcherGlib::processEvents (this=0x825e90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#27 0x00007fb9e2972a4e in QGuiEventDispatcherGlib::processEvents (this=0xa2c8b0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fb9e1f08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007fb9e1f08dec in QEventLoop::exec (this=0x7fffbf5a1a20, flags=) at kernel/qeventloop.cpp:201
#30 0x00007fb9e1f0cebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#31 0x0000000000403b4e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

Possible duplicates by query: bug 247000, bug 246954, bug 246813, bug 246445, bug 245977.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-10-20 12:15:01 UTC

*** This bug has been marked as a duplicate of bug 194268 ***