Bug 242078 - Kontact crashes at startup
Summary: Kontact crashes at startup
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-18 15:56 UTC by dotby
Modified: 2010-06-19 11:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dotby 2010-06-18 15:56:47 UTC
Application: kontact (4.4.3)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
First launch is successfull. Another one can crash randomly. It can be second, third or ...rd.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76ff990 (LWP 1841))]

Thread 2 (Thread 0xafbc8b70 (LWP 1916)):
#0  0x021f5e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x05484f5b in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x0548a085 in QTimerInfoList::updateCurrentTime (this=0xa363eb4) at kernel/qeventdispatcher_unix.cpp:340
#3  0x0548a0ca in QTimerInfoList::timerWait (this=0xa363eb4, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x05488078 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xafbc80ac) at kernel/qeventdispatcher_glib.cpp:136
#5  0x05488105 in timerSourcePrepare (source=0x0, timeout=0x21f9ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x066d8aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x066d8ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x066d94b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x05487e6f in QEventDispatcherGlib::processEvents (this=0xa3eb660, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x0545a759 in QEventLoop::processEvents (this=0xafbc8270, flags=) at kernel/qeventloop.cpp:149
#11 0x0545abaa in QEventLoop::exec (this=0xafbc8270, flags=...) at kernel/qeventloop.cpp:201
#12 0x0535bfc9 in QThread::exec (this=0x966bd10) at thread/qthread.cpp:487
#13 0x0543a1db in QInotifyFileSystemWatcherEngine::run (this=0x966bd10) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x0535e97e in QThreadPrivate::start (arg=0x966bd10) at thread/qthread_unix.cpp:248
#15 0x0086a96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x00d21a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76ff990 (LWP 1841)):
[KCrash Handler]
#6  0x00e20b50 in KontactInterface::Plugin::part (this=0x9768468) at ../../kontactinterface/plugin.cpp:190
#7  0x02198a7d in KMailUniqueAppHandler::newInstance (this=0x9769b38) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0x00e227e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x9769b38, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00e22874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x9769b38, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf90e38c) at ./uniqueapphandler.moc:79
#10 0x00471df4 in QDBusConnectionPrivate::deliverCall (this=0x941ee98, object=0x9769b38, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x0047309f in QDBusConnectionPrivate::activateCall (this=0x941ee98, object=0x9769b38, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x0047386c in QDBusConnectionPrivate::activateObject (this=0x941ee98, node=..., msg=..., pathStartPos=21) at qdbusintegrator.cpp:1383
#13 0x00473dda in QDBusActivateObjectEvent::placeMetaCall (this=0xa496550) at qdbusintegrator.cpp:1477
#14 0x0546cc0e in QObject::event (this=0x9769b38, e=0xa496550) at kernel/qobject.cpp:1248
#15 0x0449de8c in QApplicationPrivate::notify_helper (this=0x942c7a0, receiver=0x9769b38, e=0xa496550) at kernel/qapplication.cpp:4302
#16 0x044a4a0e in QApplication::notify (this=0xbf90eda4, receiver=0x9769b38, e=0xa496550) at kernel/qapplication.cpp:3706
#17 0x01006ffa in KApplication::notify (this=0xbf90eda4, receiver=0x9769b38, event=0xa496550) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0545c13b in QCoreApplication::notifyInternal (this=0xbf90eda4, receiver=0x9769b38, event=0xa496550) at kernel/qcoreapplication.cpp:726
#19 0x0545fbfc in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x94074d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x94074d8) at kernel/qcoreapplication.cpp:1367
#21 0x0545fd7d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#22 0x0548833f in QCoreApplication::sendPostedEvents (s=0x942ee80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x942ee80) at kernel/qeventdispatcher_glib.cpp:276
#24 0x066d55e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x066d92d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x066d94b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x05487e35 in QEventDispatcherGlib::processEvents (this=0x9407070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x0455de15 in QGuiEventDispatcherGlib::processEvents (this=0x9407070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x0545a759 in QEventLoop::processEvents (this=0xbf90ed04, flags=) at kernel/qeventloop.cpp:149
#30 0x0545abaa in QEventLoop::exec (this=0xbf90ed04, flags=...) at kernel/qeventloop.cpp:201
#31 0x0545fe3f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#32 0x0449df27 in QApplication::exec () at kernel/qapplication.cpp:3581
#33 0x0804b472 in main (argc=1, argv=0xbf90efc4) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 237446, bug 237352, bug 237094, bug 234172, bug 232851.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-19 11:22:20 UTC

*** This bug has been marked as a duplicate of bug 194268 ***