Bug 213629 - crash when opened korganizer reminder from tray bar
Summary: crash when opened korganizer reminder from tray bar
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-08 02:43 UTC by virusmiurasv
Modified: 2009-11-10 02:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description virusmiurasv 2009-11-08 02:43:02 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-16-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x819e780) at /build/buildd/kdepim-4.3.2/kontactinterfaces/plugin.cpp:186
#7  0xb154e26a in KOrganizerUniqueAppHandler::newInstance (this=0x81a4ee0) at /build/buildd/kdepim-4.3.2/kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb7781f39 in Kontact::UniqueAppHandler::newInstance (this=0x81a4ee0, asn_id=@0x848f908, args=@0x847ac18) at /build/buildd/kdepim-4.3.2/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7781fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x81a4ee0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc8b578)
    at /build/buildd/kdepim-4.3.2/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5c87e5a in QDBusConnectionPrivate::deliverCall (this=0x8153150, object=0x81a4ee0, msg=@0x84df480, metaTypes=@0x897f84c, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5c89179 in QDBusConnectionPrivate::activateCall (this=0x8153150, object=0x81a4ee0, flags=272, msg=@0x84df480) at qdbusintegrator.cpp:803
#12 0xb5c895e1 in QDBusConnectionPrivate::activateObject (this=0x8153150, node=@0x84df46c, msg=@0x84df480, pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0xb5c89ada in QDBusActivateObjectEvent::placeMetaCall (this=0x84df440) at qdbusintegrator.cpp:1464
#14 0xb5b803b0 in QObject::event (this=0x81a4ee0, e=0x84df440) at kernel/qobject.cpp:1111
#15 0xb6033d3c in QApplicationPrivate::notify_helper (this=0x816db08, receiver=0x81a4ee0, e=0x84df440) at kernel/qapplication.cpp:4056
#16 0xb603c03e in QApplication::notify (this=0xbfc8bdf8, receiver=0x81a4ee0, e=0x84df440) at kernel/qapplication.cpp:3603
#17 0xb6c2d49d in KApplication::notify (this=0xbfc8bdf8, receiver=0x81a4ee0, event=0x84df440) at /build/buildd/kde4libs-4.3.2/kdeui/kernel/kapplication.cpp:302
#18 0xb5b6fbcb in QCoreApplication::notifyInternal (this=0xbfc8bdf8, receiver=0x81a4ee0, event=0x84df440) at kernel/qcoreapplication.cpp:610
#19 0xb5b70825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x813b440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5b70a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5b9b6af in postEventSourceDispatch (s=0x8160f58) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4c40b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4c440eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4c44268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5b9b2f8 in QEventDispatcherGlib::processEvents (this=0x813b028, flags={i = -1077363512}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb60d5a75 in QGuiEventDispatcherGlib::processEvents (this=0x813b028, flags={i = -1077363464}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5b6e1fa in QEventLoop::processEvents (this=0xbfc8bd70, flags={i = -1077363400}) at kernel/qeventloop.cpp:149
#28 0xb5b6e642 in QEventLoop::exec (this=0xbfc8bd70, flags={i = -1077363336}) at kernel/qeventloop.cpp:201
#29 0xb5b70ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb6033bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=3, argv=0xbfc8c0f4) at /build/buildd/kdepim-4.3.2/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 212261

Reported using DrKonqi
Comment 1 Jonathan Thomas 2009-11-10 02:35:25 UTC

*** This bug has been marked as a duplicate of bug 194268 ***