Bug 242278 - Plantage Kontact apres redemarrage de l'application sans dialogue avec Akonadi
Summary: Plantage Kontact apres redemarrage de l'application sans dialogue avec Akonadi
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-20 17:55 UTC by florianbfr
Modified: 2010-07-05 15:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description florianbfr 2010-06-20 17:55:12 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
1- start Kontact : ok but no answer from Akonadi
2- shutdown Kontact
3- start Kontact => Out

The crash can be reproduced every time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7744730 (LWP 1480))]

Thread 2 (Thread 0xb1806b70 (LWP 1551)):
#0  0x00bdaf5b in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1  0x00ce7ba6 in pthread_mutex_lock () from /lib/tls/i686/cmov/libc.so.6
#2  0x018acb03 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x018acee9 in ?? () from /lib/libglib-2.0.so.0
#4  0x018ad4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0117a60f in QEventDispatcherGlib::processEvents (this=0x94627e8, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0x0114d059 in QEventLoop::processEvents (this=0xb1806270, flags=) at kernel/qeventloop.cpp:149
#7  0x0114d4aa in QEventLoop::exec (this=0xb1806270, flags=...) at kernel/qeventloop.cpp:201
#8  0x010495a8 in QThread::exec (this=0x944db90) at thread/qthread.cpp:487
#9  0x0112cc1b in QInotifyFileSystemWatcherEngine::run (this=0x944db90) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0104c32e in QThreadPrivate::start (arg=0x944db90) at thread/qthread_unix.cpp:248
#11 0x00bd896e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x00cdaa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7744730 (LWP 1480)):
[KCrash Handler]
#6  0x0072ab50 in KontactInterface::Plugin::part (this=0x8e004e0) at ../../kontactinterface/plugin.cpp:190
#7  0x036d7eaa in KOrganizerUniqueAppHandler::newInstance (this=0x8e0a288) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:33
#8  0x0072c7e9 in KontactInterface::UniqueAppHandler::newInstance (this=0x8e0a288, asn_id=..., args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x0072c874 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x8e0a288, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff75e9c) at ./uniqueapphandler.moc:79
#10 0x00d87b34 in QDBusConnectionPrivate::deliverCall (this=0x8ad8d60, object=0x8e0a288, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:904
#11 0x00d88ddf in QDBusConnectionPrivate::activateCall (this=0x8ad8d60, object=0x8e0a288, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00d895ac in QDBusConnectionPrivate::activateObject (this=0x8ad8d60, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1383
#13 0x00d89b1a in QDBusActivateObjectEvent::placeMetaCall (this=0x8d51c30) at qdbusintegrator.cpp:1477
#14 0x0115f3fe in QObject::event (this=0x8e0a288, e=0x8d51c30) at kernel/qobject.cpp:1248
#15 0x042b34dc in QApplicationPrivate::notify_helper (this=0x8ae1ed8, receiver=0x8e0a288, e=0x8d51c30) at kernel/qapplication.cpp:4300
#16 0x042ba05e in QApplication::notify (this=0xbff768b4, receiver=0x8e0a288, e=0x8d51c30) at kernel/qapplication.cpp:3704
#17 0x0097cf2a in KApplication::notify (this=0xbff768b4, receiver=0x8e0a288, event=0x8d51c30) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0114ea3b in QCoreApplication::notifyInternal (this=0xbff768b4, receiver=0x8e0a288, event=0x8d51c30) at kernel/qcoreapplication.cpp:704
#19 0x01151473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8ac14e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8ac14e0) at kernel/qcoreapplication.cpp:1345
#21 0x011515dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#22 0x0117aadf in QCoreApplication::sendPostedEvents (s=0x8ae5d90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x8ae5d90) at kernel/qeventdispatcher_glib.cpp:276
#24 0x018a95e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x018ad2d8 in ?? () from /lib/libglib-2.0.so.0
#26 0x018ad4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0117a5d5 in QEventDispatcherGlib::processEvents (this=0x8ac1070, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#28 0x04373135 in QGuiEventDispatcherGlib::processEvents (this=0x8ac1070, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x0114d059 in QEventLoop::processEvents (this=0xbff76814, flags=) at kernel/qeventloop.cpp:149
#30 0x0114d4aa in QEventLoop::exec (this=0xbff76814, flags=...) at kernel/qeventloop.cpp:201
#31 0x0115169f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#32 0x042b3577 in QApplication::exec () at kernel/qapplication.cpp:3579
#33 0x0804b472 in main (argc=1, argv=0xbff76ad4) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 240876, bug 239984, bug 235846, bug 235668, bug 234971.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-07-05 15:15:26 UTC

*** This bug has been marked as a duplicate of bug 194268 ***