Bug 214315 - opened kaddressbook while kmail was open
Summary: opened kaddressbook while kmail was open
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-12 22:46 UTC by Daniel Charp
Modified: 2009-11-12 23:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Charp 2009-11-12 22:46:29 UTC
Application that crashed: kontact
Version of the application: 4.3.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
i started kaddressbook while kontact was in kmail and fetching imap mails

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x00000012 in ?? ()
#7  0x022b21cb in ?? () from /usr/lib/kde4/kontact_kaddressbookplugin.so
#8  0x004c6ff9 in Kontact::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterfaces.so.4
#9  0x004c7084 in Kontact::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterfaces.so.4
#10 0x02e647b4 in QDBusConnectionPrivate::deliverCall (this=0x992ac90, object=0x9d2bae8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x02e6595d in QDBusConnectionPrivate::activateCall (this=0x992ac90, object=0x9d2bae8, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x02e65fc3 in QDBusConnectionPrivate::activateObject (this=0x992ac90, node=..., msg=..., pathStartPos=28) at qdbusintegrator.cpp:1370
#13 0x02e664da in QDBusActivateObjectEvent::placeMetaCall (this=0xaec8a60) at qdbusintegrator.cpp:1464
#14 0x0773c5fe in QObject::event (this=0x9d2bae8, e=0xaec8a60) at kernel/qobject.cpp:1111
#15 0x00c48f54 in QApplicationPrivate::notify_helper (this=0x9937888, receiver=0x9d2bae8, e=0xaec8a60) at kernel/qapplication.cpp:4056
#16 0x00c5067c in QApplication::notify (this=0xbfb5ba94, receiver=0x9d2bae8, e=0xaec8a60) at kernel/qapplication.cpp:3603
#17 0x0069f14a in KApplication::notify (this=0xbfb5ba94, receiver=0x9d2bae8, event=0xaec8a60) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0772c6cb in QCoreApplication::notifyInternal (this=0xbfb5ba94, receiver=0x9d2bae8, event=0xaec8a60) at kernel/qcoreapplication.cpp:610
#19 0x0772d2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9912820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9912820) at kernel/qcoreapplication.cpp:1247
#21 0x0772d47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x077573ff in QCoreApplication::sendPostedEvents (s=0x993bb90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x993bb90) at kernel/qeventdispatcher_glib.cpp:210
#24 0x0710ae78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x0710e720 in ?? () from /lib/libglib-2.0.so.0
#26 0x0710e853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0775702c in QEventDispatcherGlib::processEvents (this=0x99129f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x00ce9be5 in QGuiEventDispatcherGlib::processEvents (this=0x99129f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x0772ac79 in QEventLoop::processEvents (this=0xbfb5b9f4, flags=) at kernel/qeventloop.cpp:149
#30 0x0772b0ca in QEventLoop::exec (this=0xbfb5b9f4, flags=...) at kernel/qeventloop.cpp:201
#31 0x0772d53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00c48dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-11-12 23:15:14 UTC

*** This bug has been marked as a duplicate of bug 194268 ***