Bug 215512 - Kontact crashed when clicking korgac icon
Summary: Kontact crashed when clicking korgac icon
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-21 02:48 UTC by Thomas Tanghus
Modified: 2009-11-21 14:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2009-11-21 02:48:52 UTC
Application that crashed: kontact
Version of the application: 4.3.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I accidentally closed Kontact on the window button (not File=>Quit) and wanted to reopen it by clicking on the korgac reminder systray icon. I thought that it was supposed to work that way.
BTW: Kontact doesn't quit all the time when using File=>Quit so you have to kill a stale process to be able to open it again.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x009636d0 in Kontact::Plugin::part (this=0x98e19b8) at ../../kontactinterfaces/plugin.cpp:186
#7  0x0242c39a in KOrganizerUniqueAppHandler::newInstance (this=0x98e36f8) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0x00965ff9 in Kontact::UniqueAppHandler::newInstance (this=0x98e36f8, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00966084 in Kontact::UniqueAppHandler::qt_metacall (this=0x98e36f8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbdcabc) at ./uniqueapphandler.moc:73
#10 0x008ad7b4 in QDBusConnectionPrivate::deliverCall (this=0x957fc90, object=0x98e36f8, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x008ae95d in QDBusConnectionPrivate::activateCall (this=0x957fc90, object=0x98e36f8, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x008aefc3 in QDBusConnectionPrivate::activateObject (this=0x957fc90, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0x008af4da in QDBusActivateObjectEvent::placeMetaCall (this=0xa91b500) at qdbusintegrator.cpp:1464
#14 0x0075e5fe in QObject::event (this=0x98e36f8, e=0xa91b500) at kernel/qobject.cpp:1111
#15 0x00e1ef54 in QApplicationPrivate::notify_helper (this=0x9586c08, receiver=0x98e36f8, e=0xa91b500) at kernel/qapplication.cpp:4056
#16 0x00e2667c in QApplication::notify (this=0xbfbdd404, receiver=0x98e36f8, e=0xa91b500) at kernel/qapplication.cpp:3603
#17 0x00b3e14a in KApplication::notify (this=0xbfbdd404, receiver=0x98e36f8, event=0xa91b500) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x0074e6cb in QCoreApplication::notifyInternal (this=0xbfbdd404, receiver=0x98e36f8, event=0xa91b500) at kernel/qcoreapplication.cpp:610
#19 0x0074f2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9567820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9567820) at kernel/qcoreapplication.cpp:1247
#21 0x0074f47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x007793ff in QCoreApplication::sendPostedEvents (s=0x9587990) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x9587990) at kernel/qeventdispatcher_glib.cpp:210
#24 0x02592e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x02596720 in ?? () from /lib/libglib-2.0.so.0
#26 0x02596853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0077902c in QEventDispatcherGlib::processEvents (this=0x95679f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x00ebfbe5 in QGuiEventDispatcherGlib::processEvents (this=0x95679f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x0074cc79 in QEventLoop::processEvents (this=0xbfbdd364, flags=) at kernel/qeventloop.cpp:149
#30 0x0074d0ca in QEventLoop::exec (this=0xbfbdd364, flags=...) at kernel/qeventloop.cpp:201
#31 0x0074f53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00e1edd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in main (argc=1, argv=0xbfbdd624) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 205334

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-21 14:43:00 UTC
Thanks for the information

*** This bug has been marked as a duplicate of bug 194268 ***