Bug 217773 - kontact just crashed. Dont know...
Summary: kontact just crashed. Dont know...
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-07 22:05 UTC by Felix Rabeler
Modified: 2009-12-10 17:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Rabeler 2009-12-07 22:05:12 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-6.slh.1-sidux-686 i686

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4097920 (LWP 7267))]

Thread 2 (Thread 0xadaffb70 (LWP 8391)):
#0  0xb779d424 in __kernel_vsyscall ()
#1  0xb49b40a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb632082d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3  0xb6e8f5c2 in QWaitConditionPrivate::wait (this=0xbd2fc28, mutex=0xbd2fc24, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0xbd2fc28, mutex=0xbd2fc24, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb4b8ca9a in QHostInfoAgent::run (this=0xbd2fc18) at kernel/qhostinfo.cpp:260
#6  0xb6e8e5e2 in QThreadPrivate::start (arg=0xbd2fc18) at thread/qthread_unix.cpp:188
#7  0xb49b0585 in start_thread () from /lib/i686/cmov/libpthread.so.0
#8  0xb63132be in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4097920 (LWP 7267)):
[KCrash Handler]
#6  0x00000004 in ?? ()
#7  0xb0f6a0ea in KOrganizerUniqueAppHandler::newInstance (this=0x9c2fd10) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0xb775afb9 in Kontact::UniqueAppHandler::newInstance (this=0xbcc41f8, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb775b044 in Kontact::UniqueAppHandler::qt_metacall (this=0x9c2fd10, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd294f8) at ./uniqueapphandler.moc:73
#10 0xb58a0be5 in QDBusConnectionPrivate::deliverCall (this=0x995c4e0, object=0x9c2fd10, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb58a1d32 in QDBusConnectionPrivate::activateCall (this=0x995c4e0, object=0x9c2fd10, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0xb58a2254 in QDBusConnectionPrivate::activateObject (this=0x995c4e0, node=..., msg=..., pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0xb58a273a in QDBusActivateObjectEvent::placeMetaCall (this=0xb99d7c8) at qdbusintegrator.cpp:1464
#14 0xb6f8f5e0 in QObject::event (this=0x9c2fd10, e=0xb99d7c8) at kernel/qobject.cpp:1110
#15 0xb65bea94 in QApplicationPrivate::notify_helper (this=0x99642a0, receiver=0x9c2fd10, e=0xb99d7c8) at kernel/qapplication.cpp:4065
#16 0xb65c6bee in QApplication::notify (this=0xbfd29f0c, receiver=0x9c2fd10, e=0xb99d7c8) at kernel/qapplication.cpp:3605
#17 0xb74820fd in KApplication::notify (this=0xbfd29f0c, receiver=0x9c2fd10, event=0xb99d7c8) at ../../kdeui/kernel/kapplication.cpp:302
#18 0xb6f7f1eb in QCoreApplication::notifyInternal (this=0xbfd29f0c, receiver=0x9c2fd10, event=0xb99d7c8) at kernel/qcoreapplication.cpp:610
#19 0xb6f7fe2e in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x99449b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x99449b0) at kernel/qcoreapplication.cpp:1247
#21 0xb6f8000d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0xb6faa4cf in QCoreApplication::sendPostedEvents (s=0x9966510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x9966510) at kernel/qeventdispatcher_glib.cpp:276
#24 0xb49fef28 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0xb4a026b3 in ?? () from /lib/libglib-2.0.so.0
#26 0xb4a02838 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0xb6faa041 in QEventDispatcherGlib::processEvents (this=0x9944700, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#28 0xb665e305 in QGuiEventDispatcherGlib::processEvents (this=0x9944700, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0xb6f7d83a in QEventLoop::processEvents (this=0xbfd29d80, flags=...) at kernel/qeventloop.cpp:149
#30 0xb6f7dc82 in QEventLoop::exec (this=0xbfd29d80, flags=...) at kernel/qeventloop.cpp:201
#31 0xb6f800d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0xb65be917 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804bd40 in main (argc=1, argv=0xbfd2a104) at ../../../kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-10 17:38:40 UTC
This is being tracked at bug 194268 Thanks

*** This bug has been marked as a duplicate of bug 194268 ***