Bug 206675 - kontact chrashed after closing it I restated and it crashed
Summary: kontact chrashed after closing it I restated and it crashed
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-07 21:21 UTC by Jonathan Kolberg
Modified: 2009-09-07 21:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Kolberg 2009-09-07 21:21:57 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb78a3500 in Kontact::Plugin::part () from /usr/lib/libkontactinterfaces.so.4
#7  0xb15d422e in ?? () from /usr/lib/kde4/kontact_kmailplugin.so
#8  0xb78a5f39 in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#9  0xb78a5fc6 in Kontact::UniqueAppHandler::qt_metacall () from /usr/lib/libkontactinterfaces.so.4
#10 0xb5dace5a in QDBusConnectionPrivate::deliverCall (this=0x8c2ff48, object=0x9005608, msg=@0xa3b4c08, metaTypes=@0xbf83d768, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5dae072 in QDBusConnectionPrivate::activateCall (this=0x8c2ff48, object=0x9005608, flags=272, msg=@0xa3b4c08) at qdbusintegrator.cpp:796
#12 0xb5dae5e1 in QDBusConnectionPrivate::activateObject (this=0x8c2ff48, node=@0xa3b4bf4, msg=@0xa3b4c08, pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb5daeada in QDBusActivateObjectEvent::placeMetaCall (this=0xa3b4bc8) at qdbusintegrator.cpp:1464
#14 0xb5ca53b0 in QObject::event (this=0x9005608, e=0xa3b4bc8) at kernel/qobject.cpp:1111
#15 0xb6157d3c in QApplicationPrivate::notify_helper (this=0x8c4c2b0, receiver=0x9005608, e=0xa3b4bc8) at kernel/qapplication.cpp:4056
#16 0xb616003e in QApplication::notify (this=0xbf83df38, receiver=0x9005608, e=0xa3b4bc8) at kernel/qapplication.cpp:3603
#17 0xb6d5185d in KApplication::notify (this=0xbf83df38, receiver=0x9005608, event=0xa3b4bc8) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5c94bcb in QCoreApplication::notifyInternal (this=0xbf83df38, receiver=0x9005608, event=0xa3b4bc8) at kernel/qcoreapplication.cpp:610
#19 0xb5c95825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8c18440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5c95a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5cc06af in postEventSourceDispatch (s=0x8c47fb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4d65b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4d690eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4d69268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5cc02f8 in QEventDispatcherGlib::processEvents (this=0x8c18028, flags={i = -1081876984}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb61f9a75 in QGuiEventDispatcherGlib::processEvents (this=0x8c18028, flags={i = -1081876936}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5c931fa in QEventLoop::processEvents (this=0xbf83deb0, flags={i = -1081876872}) at kernel/qeventloop.cpp:149
#28 0xb5c93642 in QEventLoop::exec (this=0xbf83deb0, flags={i = -1081876808}) at kernel/qeventloop.cpp:201
#29 0xb5c95ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb6157bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-07 21:33:49 UTC

*** This bug has been marked as a duplicate of bug 194268 ***