Bug 203019 - Kontact close app when i select pictures for contact
Summary: Kontact close app when i select pictures for contact
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-07 23:25 UTC by Wolfrod
Modified: 2009-08-08 15:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfrod 2009-08-07 23:25:01 UTC
Application that crashed: kontact
Version of the application: 4.3.0
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-14-generic i686
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 0 (LWP 22307)]

Thread 3 (Thread 0xabbffb90 (LWP 25696)):
#0  0xb8020430 in __kernel_vsyscall ()
#1  0xb51b1412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb59d2344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0xa98a7ae3 in ?? () from /usr/lib/libxine.so.1

Thread 2 (Thread 0xa7b6bb90 (LWP 25698)):
#0  0xb4cde0ac in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0xb5cd704b in QTimerInfoList::getTime (this=0xa859734, t=@0xa859758) at kernel/qeventdispatcher_unix.cpp:339
#2  0xb5cd7221 in QTimerInfoList::updateCurrentTime (this=0xa859734) at kernel/qeventdispatcher_unix.cpp:297
#3  0xb5cd8e0c in QTimerInfoList::timerWait (this=0xa859734, tm=@0xa7b6b124) at kernel/qeventdispatcher_unix.cpp:420
#4  0xb5cd54da in timerSourcePrepare (source=0xb4ce1ff4, timeout=0xa7b6b178) at kernel/qeventdispatcher_glib.cpp:141
#5  0xb4d7e9c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0xb4d7edda in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb4d7f268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0xb5cd5317 in QEventDispatcherGlib::processEvents (this=0x9bcc060, flags={i = -1481199000}) at kernel/qeventdispatcher_glib.cpp:329
#9  0xb5ca81fa in QEventLoop::processEvents (this=0xa7b6b2e0, flags={i = -1481198936}) at kernel/qeventloop.cpp:149
#10 0xb5ca8642 in QEventLoop::exec (this=0xa7b6b2e0, flags={i = -1481198872}) at kernel/qeventloop.cpp:201
#11 0xb5bb1e19 in QThread::exec (this=0xa8587b8) at thread/qthread.cpp:487
#12 0xa98f520a in ?? () from /usr/lib/kde4/plugins/phonon_backend/phonon_xine.so
#13 0xb5bb5132 in QThreadPrivate::start (arg=0xa8587b8) at thread/qthread_unix.cpp:188
#14 0xb51ad4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0xb59c349e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb48c5b30 (LWP 22307)):
[KCrash Handler]
#6  0xb78b4500 in Kontact::Plugin::part () from /usr/lib/libkontactinterfaces.so.4
#7  0xb196a26a in ?? () from /usr/lib/kde4/kontact_todoplugin.so
#8  0xb78b6f39 in Kontact::UniqueAppHandler::newInstance () from /usr/lib/libkontactinterfaces.so.4
#9  0xb78b6fc6 in Kontact::UniqueAppHandler::qt_metacall () from /usr/lib/libkontactinterfaces.so.4
#10 0xb5dc1e5a in QDBusConnectionPrivate::deliverCall (this=0x830cf48, object=0x864e940, msg=@0xa0448a0, metaTypes=@0xbf83d788, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5dc3072 in QDBusConnectionPrivate::activateCall (this=0x830cf48, object=0x864e940, flags=272, msg=@0xa0448a0) at qdbusintegrator.cpp:796
#12 0xb5dc35e1 in QDBusConnectionPrivate::activateObject (this=0x830cf48, node=@0xa04488c, msg=@0xa0448a0, pathStartPos=26) at qdbusintegrator.cpp:1370
#13 0xb5dc3ada in QDBusActivateObjectEvent::placeMetaCall (this=0xa044860) at qdbusintegrator.cpp:1464
#14 0xb5cba3b0 in QObject::event (this=0x864e940, e=0xa044860) at kernel/qobject.cpp:1111
#15 0xb616ad3c in QApplicationPrivate::notify_helper (this=0x8318d20, receiver=0x864e940, e=0xa044860) at kernel/qapplication.cpp:4056
#16 0xb617303e in QApplication::notify (this=0xbf83df58, receiver=0x864e940, e=0xa044860) at kernel/qapplication.cpp:3603
#17 0xb6d645cd in KApplication::notify (this=0xbf83df58, receiver=0x864e940, event=0xa044860) at /build/buildd/kde4libs-4.3.0/kdeui/kernel/kapplication.cpp:302
#18 0xb5ca9bcb in QCoreApplication::notifyInternal (this=0xbf83df58, receiver=0x864e940, event=0xa044860) at kernel/qcoreapplication.cpp:610
#19 0xb5caa825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82f5440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5caaa1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5cd56af in postEventSourceDispatch (s=0x831c718) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4d7bb88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb4d7f0eb in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb4d7f268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb5cd52f8 in QEventDispatcherGlib::processEvents (this=0x82f5028, flags={i = -1081876952}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb620ca75 in QGuiEventDispatcherGlib::processEvents (this=0x82f5028, flags={i = -1081876904}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5ca81fa in QEventLoop::processEvents (this=0xbf83ded0, flags={i = -1081876840}) at kernel/qeventloop.cpp:149
#28 0xb5ca8642 in QEventLoop::exec (this=0xbf83ded0, flags={i = -1081876776}) at kernel/qeventloop.cpp:201
#29 0xb5caaae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb616abb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-08 15:58:37 UTC
Merging with bug 194268. Thanks

*** This bug has been marked as a duplicate of bug 194268 ***