Bug 223788 - Kontact crashes upon hitting feeds
Summary: Kontact crashes upon hitting feeds
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-22 14:45 UTC by julio
Modified: 2010-01-22 16:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description julio 2010-01-22 14:45:59 UTC
Application that crashed: kontact
Version of the application: 4.3.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kontact crashes upon trying to view my feeds.  I cannot run Akregator as a stand alone application.  

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0x0012c6d0 in Kontact::Plugin::part (this=0x9376d70) at ../../kontactinterfaces/plugin.cpp:186
#7  0x05db63bf in AkregatorUniqueAppHandler::newInstance (this=0x93784f0) at ../../../../kontact/plugins/akregator/akregator_plugin.cpp:155
#8  0x0012eff9 in Kontact::UniqueAppHandler::newInstance (this=0x93784f0, asn_id=..., args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x0012f084 in Kontact::UniqueAppHandler::qt_metacall (this=0x93784f0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfee638c) at ./uniqueapphandler.moc:73
#10 0x00a847b4 in QDBusConnectionPrivate::deliverCall (this=0x8ef3c90, object=0x93784f0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:891
#11 0x00a8595d in QDBusConnectionPrivate::activateCall (this=0x8ef3c90, object=0x93784f0, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00a85fc3 in QDBusConnectionPrivate::activateObject (this=0x8ef3c90, node=..., msg=..., pathStartPos=25) at qdbusintegrator.cpp:1370
#13 0x00a864da in QDBusActivateObjectEvent::placeMetaCall (this=0x9f446f0) at qdbusintegrator.cpp:1464
#14 0x004755fe in QObject::event (this=0x93784f0, e=0x9f446f0) at kernel/qobject.cpp:1111
#15 0x0101bf54 in QApplicationPrivate::notify_helper (this=0x8f035c0, receiver=0x93784f0, e=0x9f446f0) at kernel/qapplication.cpp:4056
#16 0x0102367c in QApplication::notify (this=0xbfee6cd4, receiver=0x93784f0, e=0x9f446f0) at kernel/qapplication.cpp:3603
#17 0x0075e1aa in KApplication::notify (this=0xbfee6cd4, receiver=0x93784f0, event=0x9f446f0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x004656cb in QCoreApplication::notifyInternal (this=0xbfee6cd4, receiver=0x93784f0, event=0x9f446f0) at kernel/qcoreapplication.cpp:610
#19 0x004662b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8edb820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8edb820) at kernel/qcoreapplication.cpp:1247
#21 0x0046647d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#22 0x004903ff in QCoreApplication::sendPostedEvents (s=0x8efbb00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#23 postEventSourceDispatch (s=0x8efbb00) at kernel/qeventdispatcher_glib.cpp:210
#24 0x01e0fe88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x01e13730 in ?? () from /lib/libglib-2.0.so.0
#26 0x01e13863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0049002c in QEventDispatcherGlib::processEvents (this=0x8edb9f8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#28 0x010bcbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8edb9f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00463c79 in QEventLoop::processEvents (this=0xbfee6c34, flags=) at kernel/qeventloop.cpp:149
#30 0x004640ca in QEventLoop::exec (this=0xbfee6c34, flags=...) at kernel/qeventloop.cpp:201
#31 0x0046653f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x0101bdd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#33 0x0804b4e6 in main (argc=1, argv=0xbfee6ef4) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 204420

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-22 16:00:11 UTC
This is being tracked at bug 194268. Regards

*** This bug has been marked as a duplicate of bug 194268 ***