Bug 237094 - first start kontact - works. second start does not
Summary: first start kontact - works. second start does not
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-10 12:52 UTC by tom
Modified: 2010-06-06 17:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tom 2010-05-10 12:52:16 UTC
Application: kontact (4.4.2)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Only the first run of contact works. If I then close and restart kontact, nothing happens. Starting kmail then results in a crash of kontact.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f885a977780 (LWP 1803))]

Thread 2 (Thread 0x7f8838a09710 (LWP 1862)):
#0  0x00007f8857a47f53 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f885057d4a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f885057d8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f8858e32566 in QEventDispatcherGlib::processEvents (this=0x7f8834000ba0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f8858e07992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f8858e07d6c in QEventLoop::exec (this=0x7f8838a08d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f8858d11d59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f8858de8178 in QInotifyFileSystemWatcherEngine::run (this=0x1767050) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8858d14775 in QThreadPrivate::start (arg=0x1767050) at thread/qthread_unix.cpp:248
#9  0x00007f8852af39ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f8857a5469d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f885a977780 (LWP 1803)):
[KCrash Handler]
#5  0x00007f8859fd984a in KontactInterface::Plugin::part (this=0x1137fc0) at ../../kontactinterface/plugin.cpp:190
#6  0x00007f8841526e2b in KMailUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#7  0x00007f8859fdb0a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x112b530, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#8  0x00007f8859fdb114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x112b530, _c=QMetaObject::InvokeMetaMethod, _id=18055104, _a=0x7fff81cbeb70) at ./uniqueapphandler.moc:79
#9  0x00007f8856255486 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#10 0x00007f88562566ef in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x112b530, flags=272, msg=...) at qdbusintegrator.cpp:809
#11 0x00007f8856256f0e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#12 0x00007f8856257468 in QDBusActivateObjectEvent::placeMetaCall (this=0x212adc0) at qdbusintegrator.cpp:1477
#13 0x00007f8858e18d49 in QObject::event (this=0x112b530, e=0x212adc0) at kernel/qobject.cpp:1248
#14 0x00007f88581c222c in QApplicationPrivate::notify_helper (this=0xc67290, receiver=0x112b530, e=0x212adc0) at kernel/qapplication.cpp:4300
#15 0x00007f88581c86fb in QApplication::notify (this=0x7fff81cbf8f0, receiver=0x112b530, e=0x212adc0) at kernel/qapplication.cpp:4183
#16 0x00007f88597f1526 in KApplication::notify (this=0x7fff81cbf8f0, receiver=0x112b530, event=0x212adc0) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x00007f8858e0906c in QCoreApplication::notifyInternal (this=0x7fff81cbf8f0, receiver=0x112b530, event=0x212adc0) at kernel/qcoreapplication.cpp:704
#18 0x00007f8858e0b7e7 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xc3b620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xc3b620) at kernel/qcoreapplication.cpp:1345
#20 0x00007f8858e329d3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x00007f88505798c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f885057d748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f885057d8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f8858e32513 in QEventDispatcherGlib::processEvents (this=0xc3ad70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x00007f885827246e in QGuiEventDispatcherGlib::processEvents (this=0x1137fc0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f8858e07992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f8858e07d6c in QEventLoop::exec (this=0x7fff81cbf830, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f8858e0baab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 234172.

Possible duplicates by query: bug 234172, bug 232851.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-06-06 17:36:40 UTC

*** This bug has been marked as a duplicate of bug 194268 ***