Bug 253472 - Kontact crashes after clicking a mailto: link
Summary: Kontact crashes after clicking a mailto: link
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 07:03 UTC by Florian
Modified: 2010-10-15 23:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian 2010-10-07 07:03:07 UTC
Application: kontact (4.4.5)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
I clicked on a mailto link in Chromium 6.x, expecting that a new E-mail composing window opens. However, Kontact chrashed.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2f12b97780 (LWP 29104))]

Thread 2 (Thread 0x7f2eeaeba710 (LWP 29132)):
#0  0x00007f2f0fc61f83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2f087904a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f2f087908fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f2f1104d406 in QEventDispatcherGlib::processEvents (this=0x37cbaf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f2f110226c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f2f11022a9c in QEventLoop::exec (this=0x7f2eeaeb9d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f2f10f318db in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f2f11002dd8 in QInotifyFileSystemWatcherEngine::run (this=0x37c0d50) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2f10f33f95 in QThreadPrivate::start (arg=0x37c0d50) at thread/qthread_unix.cpp:248
#9  0x00007f2f0ad079ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f2f0fc6e6fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2f12b97780 (LWP 29104)):
[KCrash Handler]
#5  0x0000000002781a90 in ?? ()
#6  0x00007f2f121f5879 in KontactInterface::Plugin::part (this=0x27a4c00) at ../../kontactinterface/plugin.cpp:191
#7  0x00007f2ef9fb1e2b in KMailUniqueAppHandler::newInstance (this=<value optimized out>) at ../../../../kontact/plugins/kmail/kmail_plugin.cpp:216
#8  0x00007f2f121f70a9 in KontactInterface::UniqueAppHandler::newInstance (this=0x27726a0, asn_id=<value optimized out>, args=...) at ../../kontactinterface/uniqueapphandler.cpp:129
#9  0x00007f2f121f7114 in KontactInterface::UniqueAppHandler::qt_metacall (this=0x27726a0, _c=QMetaObject::InvokeMetaMethod, _id=41424656, _a=0x7fffcb9a1cf0) at ./uniqueapphandler.moc:79
#10 0x00007f2f0e46b5a6 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#11 0x00007f2f0e46c80f in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x27726a0, flags=272, msg=...) at qdbusintegrator.cpp:809
#12 0x00007f2f0e46d02e in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1383
#13 0x00007f2f0e46d588 in QDBusActivateObjectEvent::placeMetaCall (this=0x2b216f0) at qdbusintegrator.cpp:1477
#14 0x00007f2f11033b79 in QObject::event (this=0x27726a0, e=0x2b216f0) at kernel/qobject.cpp:1248
#15 0x00007f2f103ddc0c in QApplicationPrivate::notify_helper (this=0x22df7d0, receiver=0x27726a0, e=0x2b216f0) at kernel/qapplication.cpp:4302
#16 0x00007f2f103e40eb in QApplication::notify (this=0x7fffcb9a2a70, receiver=0x27726a0, e=0x2b216f0) at kernel/qapplication.cpp:4185
#17 0x00007f2f11a0da16 in KApplication::notify (this=0x7fffcb9a2a70, receiver=0x27726a0, event=0x2b216f0) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f2f11023d9c in QCoreApplication::notifyInternal (this=0x7fffcb9a2a70, receiver=0x27726a0, event=0x2b216f0) at kernel/qcoreapplication.cpp:726
#19 0x00007f2f11027454 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x22b4620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x22b4620) at kernel/qcoreapplication.cpp:1367
#21 0x00007f2f1104d873 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#23 0x00007f2f0878c8c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f2f08790748 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f2f087908fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f2f1104d3b3 in QEventDispatcherGlib::processEvents (this=0x22b3d70, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x00007f2f1048e18e in QGuiEventDispatcherGlib::processEvents (this=0x27a4c00, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f2f110226c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f2f11022a9c in QEventLoop::exec (this=0x7fffcb9a29b0, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f2f1102773b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#31 0x0000000000403e8e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224

This bug may be a duplicate of or related to bug 194268.

Possible duplicates by query: bug 249231, bug 246527, bug 246414, bug 245901, bug 242078.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-10-15 23:35:21 UTC

*** This bug has been marked as a duplicate of bug 194268 ***