Bug 208177 - kontact crashes when it is started
Summary: kontact crashes when it is started
Status: RESOLVED DUPLICATE of bug 194268
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-22 13:42 UTC by FranJPR
Modified: 2009-09-22 21:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FranJPR 2009-09-22 13:42:41 UTC
Application that crashed: kontact
Version of the application: 4.3.1
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-14-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I open kontact an nothing happens. After a while the kontact crash reporting assistant pops up to report the bug. 

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  Kontact::Plugin::part (this=0x9ed2e50) at /build/buildd/kdepim-4.3.1/kontactinterfaces/plugin.cpp:186
#7  0xb16c022e in KMailUniqueAppHandler::newInstance (this=0x9bc9a68) at /build/buildd/kdepim-4.3.1/kontact/plugins/kmail/kmail_plugin.cpp:208
#8  0xb7776f39 in Kontact::UniqueAppHandler::newInstance (this=0x9bc9a68, asn_id=@0x9f45848, args=@0x9f62418) at /build/buildd/kdepim-4.3.1/kontactinterfaces/uniqueapphandler.cpp:128
#9  0xb7776fc6 in Kontact::UniqueAppHandler::qt_metacall (this=0x9bc9a68, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc02268)
    at /build/buildd/kdepim-4.3.1/obj-i486-linux-gnu/kontactinterfaces/uniqueapphandler.moc:73
#10 0xb5c7de5a in QDBusConnectionPrivate::deliverCall (this=0x9b8af40, object=0x9bc9a68, msg=@0xad25af0, metaTypes=@0xbfc02318, slotIdx=4) at qdbusintegrator.cpp:891
#11 0xb5c7f072 in QDBusConnectionPrivate::activateCall (this=0x9b8af40, object=0x9bc9a68, flags=272, msg=@0xad25af0) at qdbusintegrator.cpp:796
#12 0xb5c7f5e1 in QDBusConnectionPrivate::activateObject (this=0x9b8af40, node=@0xad25adc, msg=@0xad25af0, pathStartPos=21) at qdbusintegrator.cpp:1370
#13 0xb5c7fada in QDBusActivateObjectEvent::placeMetaCall (this=0xad25ab0) at qdbusintegrator.cpp:1464
#14 0xb5b763b0 in QObject::event (this=0x9bc9a68, e=0xad25ab0) at kernel/qobject.cpp:1111
#15 0xb6028d3c in QApplicationPrivate::notify_helper (this=0x9b928e8, receiver=0x9bc9a68, e=0xad25ab0) at kernel/qapplication.cpp:4056
#16 0xb603103e in QApplication::notify (this=0xbfc02ae8, receiver=0x9bc9a68, e=0xad25ab0) at kernel/qapplication.cpp:3603
#17 0xb6c2285d in KApplication::notify (this=0xbfc02ae8, receiver=0x9bc9a68, event=0xad25ab0) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#18 0xb5b65bcb in QCoreApplication::notifyInternal (this=0xbfc02ae8, receiver=0x9bc9a68, event=0xad25ab0) at kernel/qcoreapplication.cpp:610
#19 0xb5b66825 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9b73440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0xb5b66a1d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#21 0xb5b916af in postEventSourceDispatch (s=0x9b95310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 0xb4c36b88 in IA__g_main_context_dispatch (context=0x9b95290) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#23 0xb4c3a0eb in g_main_context_iterate (context=0x9b95290, block=1, dispatch=1, self=0x9b91a18) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#24 0xb4c3a268 in IA__g_main_context_iteration (context=0x9b95290, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#25 0xb5b912f8 in QEventDispatcherGlib::processEvents (this=0x9b73028, flags={i = -1077925448}) at kernel/qeventdispatcher_glib.cpp:327
#26 0xb60caa75 in QGuiEventDispatcherGlib::processEvents (this=0x9b73028, flags={i = -1077925400}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0xb5b641fa in QEventLoop::processEvents (this=0xbfc02a60, flags={i = -1077925336}) at kernel/qeventloop.cpp:149
#28 0xb5b64642 in QEventLoop::exec (this=0xbfc02a60, flags={i = -1077925272}) at kernel/qeventloop.cpp:201
#29 0xb5b66ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0xb6028bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0804bfef in main (argc=1, argv=0xbfc02de4) at /build/buildd/kdepim-4.3.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 206429

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-09-22 21:15:25 UTC

*** This bug has been marked as a duplicate of bug 194268 ***