Bug 345675

Summary: deco kcm segfault in QSGOpaqueTextureMaterial::setTexture()
Product: kwin Reporter: massimiliano <maxfact12>
Component: decorationsAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: 1979bearcat, albertsmus, amfabc, ant978red, aussiefeld, bamiller, belyj, bgkd.x.loki04, bionaut, bloodlegion, bugs, carlon.luca, centturion_01, cfeck, chne, cooker, cro22, dallasbates79, danas.anis, dyle71, dyonessouza, flowwolf, garethic, gerald.edward.butler, hixian, jimy.byerley, jjones, jmdh01, john.lundmolfese, john.moore.ga, jungchuhsu, KDE.Bug.Tracking.System, kde, kde, kleidokrators, krabz, kristian.hermann.karl, lesezirkel, LinuxNooby, llbl, lynoure, makozoe, michal.lipinski, motaro55555i10, mukongishto, n6ozi, naltalef, oleg.karbushev, pakosik, patrick, pheonix11026, piedro.kulman, pjb69, pkapica, pmlsantos, pragalathanm, r.altieri357, rdieter, rhinobird, robert, rohdef, rz100, settenop, sofian.dumitru, stef_eck, tassosvallas, terran20008, tommyjspace, ulrich.gruen, w, wacha, wurstigkeitsgefuel, xoom007, yassine_ssm
Priority: NOR Keywords: drkonqi
Version: 5.2.2   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
See Also: https://bugs.kde.org/show_bug.cgi?id=346272
Latest Commit: Version Fixed In:
Attachments: attachment-21478-0.html
attachment-11301-0.html
attachment-25760-0.html

Description massimiliano 2015-03-29 19:43:48 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-9-generic x86_64
Distribution: Ubuntu Vivid Vervet (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
when open the systemsetting and change the decoration windows the app is crash

The crash can be reproduced every time.

-- Backtrace:
Application: Impostazioni di sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe7a246b780 (LWP 1789))]

Thread 5 (Thread 0x7fe7932d0700 (LWP 1790)):
#0  0x00007fe79ebd98dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe79d91eb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe79d92064f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe79581b049 in QXcbEventReader::run (this=0x176b630) at qxcbconnection.cpp:1105
#4  0x00007fe79f25ab0e in QThreadPrivate::start (arg=0x176b630) at thread/qthread_unix.cpp:337
#5  0x00007fe79c8386aa in start_thread (arg=0x7fe7932d0700) at pthread_create.c:333
#6  0x00007fe79ebe4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fe783dab700 (LWP 1791)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fe786de7d7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
#2  0x00007fe786de7507 in ?? () from /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
#3  0x00007fe79c8386aa in start_thread (arg=0x7fe783dab700) at pthread_create.c:333
#4  0x00007fe79ebe4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fe77ec7f700 (LWP 1794)):
#0  0x00007fe79ebd549d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe79c35d2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe79c31996c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe79c319e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe79c319fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe79f4f1bfc in QEventDispatcherGlib::processEvents (this=0x7fe7780008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007fe79f4963b2 in QEventLoop::exec (this=this@entry=0x7fe77ec7ee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007fe79f255b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007fe77f593f45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007fe79f25ab0e in QThreadPrivate::start (arg=0x1c8e200) at thread/qthread_unix.cpp:337
#10 0x00007fe79c8386aa in start_thread (arg=0x7fe77ec7f700) at pthread_create.c:333
#11 0x00007fe79ebe4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fe7773ed700 (LWP 1795)):
#0  0x00007fe79ebd98dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe79c319ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe79c319fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe79f4f1bfc in QEventDispatcherGlib::processEvents (this=0x7fe7700008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fe79f4963b2 in QEventLoop::exec (this=this@entry=0x7fe7773ece20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fe79f255b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fe77f593f45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fe79f25ab0e in QThreadPrivate::start (arg=0x1f7afd0) at thread/qthread_unix.cpp:337
#8  0x00007fe79c8386aa in start_thread (arg=0x7fe7773ed700) at pthread_create.c:333
#9  0x00007fe79ebe4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fe7a246b780 (LWP 1789)):
[KCrash Handler]
#6  0x0000000000650000 in ?? ()
#7  0x00007fe77fce0628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fe77fcdfd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fe77d64b142 in Plasma::FrameSvgItem::updatePaintNode (this=0x35b1390, oldNode=0x36aad80) at ../../../../src/declarativeimports/core/framesvgitem.cpp:473
#10 0x00007fe77fd334bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fe77fd344cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fe77fd34d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fe77fd03f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fe77fd04979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fe7a0283b2c in QApplicationPrivate::notify_helper (this=0x1750680, receiver=0x1c35870, e=0x7ffcab408400) at kernel/qapplication.cpp:3720
#16 0x00007fe7a0289000 in QApplication::notify (this=0x7ffcab408770, receiver=0x1c35870, e=0x7ffcab408400) at kernel/qapplication.cpp:3503
#17 0x00007fe79f498bfb in QCoreApplication::notifyInternal (this=0x7ffcab408770, receiver=0x1c35870, event=event@entry=0x7ffcab408400) at kernel/qcoreapplication.cpp:935
#18 0x00007fe79f4f0a75 in sendEvent (event=0x7ffcab408400, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x17a1350) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fe79f4f0ef1 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fe79c319c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fe79c319f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fe79c319fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fe79f4f1be7 in QEventDispatcherGlib::processEvents (this=0x1794ed0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fe79f4963b2 in QEventLoop::exec (this=this@entry=0x7ffcab408650, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fe79f49dffc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fe79fcbe31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fe7a027f7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Thomas Lübking 2015-04-16 19:57:56 UTC
*** Bug 346180 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Lübking 2015-04-16 20:15:36 UTC
*** Bug 345894 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Lübking 2015-04-18 15:23:38 UTC
*** Bug 346334 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Lübking 2015-04-24 09:21:20 UTC
*** Bug 346523 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Feck 2015-04-25 08:34:06 UTC
*** Bug 346572 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2015-04-25 08:34:36 UTC
*** Bug 346596 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2015-04-28 10:39:31 UTC
*** Bug 346659 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2015-04-28 10:39:51 UTC
*** Bug 346670 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2015-04-28 10:40:09 UTC
*** Bug 346707 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2015-04-28 10:40:31 UTC
*** Bug 346709 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2015-04-28 10:41:00 UTC
*** Bug 346708 has been marked as a duplicate of this bug. ***
Comment 12 David Edmundson 2015-05-01 11:06:11 UTC
Should be fixed in the next frameworks release in a few days.

*** This bug has been marked as a duplicate of bug 345660 ***
Comment 13 Christoph Feck 2015-05-02 23:49:50 UTC
*** Bug 346832 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2015-05-02 23:50:18 UTC
*** Bug 346863 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2015-05-02 23:50:53 UTC
*** Bug 346965 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2015-05-02 23:51:19 UTC
*** Bug 346977 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2015-05-02 23:51:41 UTC
*** Bug 346981 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2015-05-02 23:52:04 UTC
*** Bug 346986 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2015-05-02 23:52:38 UTC
*** Bug 347081 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2015-05-03 00:39:28 UTC
*** Bug 346842 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2015-05-09 19:12:08 UTC
*** Bug 347124 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2015-05-09 19:12:27 UTC
*** Bug 347186 has been marked as a duplicate of this bug. ***
Comment 23 Christoph Feck 2015-05-09 19:12:47 UTC
*** Bug 347464 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2015-05-16 17:00:47 UTC
*** Bug 347531 has been marked as a duplicate of this bug. ***
Comment 25 Christoph Feck 2015-05-16 17:01:05 UTC
*** Bug 347617 has been marked as a duplicate of this bug. ***
Comment 26 Christoph Feck 2015-05-16 17:01:23 UTC
*** Bug 347677 has been marked as a duplicate of this bug. ***
Comment 27 Christoph Feck 2015-05-23 14:34:13 UTC
*** Bug 347867 has been marked as a duplicate of this bug. ***
Comment 28 Christoph Feck 2015-05-23 14:34:32 UTC
*** Bug 347890 has been marked as a duplicate of this bug. ***
Comment 29 Christoph Feck 2015-05-23 14:34:48 UTC
*** Bug 347945 has been marked as a duplicate of this bug. ***
Comment 30 Christoph Feck 2015-05-23 14:35:08 UTC
*** Bug 347953 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2015-05-23 14:35:25 UTC
*** Bug 347954 has been marked as a duplicate of this bug. ***
Comment 32 Christoph Feck 2015-05-23 14:35:42 UTC
*** Bug 348011 has been marked as a duplicate of this bug. ***
Comment 33 Christoph Feck 2015-05-23 14:35:59 UTC
*** Bug 348028 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2015-05-23 14:36:27 UTC
*** Bug 348100 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2015-05-31 13:51:29 UTC
*** Bug 348245 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Feck 2015-05-31 13:51:52 UTC
*** Bug 348164 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2015-05-31 13:52:14 UTC
*** Bug 348291 has been marked as a duplicate of this bug. ***
Comment 38 Christoph Feck 2015-05-31 13:52:32 UTC
*** Bug 348292 has been marked as a duplicate of this bug. ***
Comment 39 Christoph Feck 2015-05-31 13:52:51 UTC
*** Bug 348313 has been marked as a duplicate of this bug. ***
Comment 40 Christoph Feck 2015-05-31 13:53:18 UTC
*** Bug 348440 has been marked as a duplicate of this bug. ***
Comment 41 Ron 2015-05-31 13:57:13 UTC
Created attachment 92935 [details]
attachment-21478-0.html

STOP

Sent from Type Mail



On May 31, 2015, 6:51 AM, at 6:51 AM, Christoph Feck <cfeck@kde.org> wrote:
>https://bugs.kde.org/show_bug.cgi?id=345675
>
>Christoph Feck <cfeck@kde.org> changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>                 CC|                            |w@w-495.ru
>
>--- Comment #35 from Christoph Feck <cfeck@kde.org> ---
>*** Bug 348245 has been marked as a duplicate of this bug. ***
>
>--
>You are receiving this mail because:
>You are on the CC list for the bug.
Comment 42 Christoph Feck 2015-05-31 18:43:06 UTC
*** Bug 348512 has been marked as a duplicate of this bug. ***
Comment 43 Ron 2015-05-31 20:27:50 UTC
Created attachment 92942 [details]
attachment-11301-0.html

REMOVE

Sent from Type Mail



On May 31, 2015, 11:44 AM, at 11:44 AM, Christoph Feck <cfeck@kde.org> wrote:
>https://bugs.kde.org/show_bug.cgi?id=345675
>
>Christoph Feck <cfeck@kde.org> changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>                 CC|pinstripedtie@yahoo.com     |
>
>--
>You are receiving this mail because:
>You are on the CC list for the bug.
Comment 44 Christoph Feck 2015-05-31 22:36:15 UTC
*** Bug 348512 has been marked as a duplicate of this bug. ***
Comment 45 Christoph Feck 2015-06-07 09:54:37 UTC
*** Bug 348706 has been marked as a duplicate of this bug. ***
Comment 46 Christoph Feck 2015-06-07 09:54:56 UTC
*** Bug 348707 has been marked as a duplicate of this bug. ***
Comment 47 Christoph Feck 2015-06-16 17:23:23 UTC
*** Bug 348849 has been marked as a duplicate of this bug. ***
Comment 48 Christoph Feck 2015-06-16 17:23:42 UTC
*** Bug 349153 has been marked as a duplicate of this bug. ***
Comment 49 Martin Flöser 2015-06-17 16:07:51 UTC
This issue seems to be fixed in updated framework releases.

For Kubuntu users this will soon come to the backports ppa.
Comment 50 Christoph Feck 2015-06-23 22:33:49 UTC
*** Bug 349518 has been marked as a duplicate of this bug. ***
Comment 51 piedro 2015-07-02 10:59:33 UTC
For me this component "windows decorations" still crashes with plasma 5.3.1 on Arch. 

Just opening the component results in segfault, rest of systemsettings is alright. 

How can I manually change the decoration? Maybe that's enough repair it? 
btw: no additional windows decorations are installed (as far as I know), is there a documentation of "where the themes are in the system" and how to add/remove/cleanup manually? 

Thx for reading, 
p.
Comment 52 David Edmundson 2015-07-02 11:05:10 UTC
Piedro, same backtrace?
Comment 53 Thomas Lübking 2015-07-02 11:10:10 UTC
(In reply to piedro from comment #51)
> For me this component "windows decorations" still crashes with plasma 5.3.1

The bug (given it's *this* bug with *this* backtrace) is in kdeclarative (fix should be in 5.10 or 5.11) - the plasma workspace or kwin version is irrelevant.

> How can I manually change the decoration?
~/.config/kwinrc

[org.kde.kdecoration2]
library=org.kde.breeze

> Maybe that's enough repair it? 
Unlikely - the kcm should still act the very same.

> btw: no additional windows decorations are installed (as far as I know), is
> there a documentation of "where the themes are in the system" and how to
> add/remove/cleanup manually? 

Aurorae themes installed from kde-look go to ~/.local/share/aurorae/themes/
For themes installed with pacman, please use pacman to remove them (or you'll run into out-of-sync packages)
Comment 54 piedro 2015-07-02 14:18:17 UTC
Thx for your comments: 

First: I use kdeclarative 5.11 

Second: thx for your help here - changing the line 
'library=org.kde.oxygen' 
to 
'library=org.kde.breeze' 

fixed it! :-) 

so I guess there is another thing wrong and it is not *this* bug...
The good news for me is it is fixed and doesn't crash anymore... 
The bad news is there is something wrong with "library=org.kde.oxygen"... 

FYI: Before I also deleted all aurorae themes (though I have no idea how they got there in the first place...) I do not even know what aurorae really is and the only two themes I ever checked out years ago with aurorae didn't work at all... why there have been about 8 or nine themes to delete now is beyond me... But deleting them has not repaired the crash! 

thx for your help and for your quick response, 
cheers, piedro
Comment 55 piedro 2015-07-02 14:32:21 UTC
Follow up: 

The kcm still crashes when i use the mouse wheel to scroll though the installed themes. 

Also there is an aurorae theme "Ambiance" present though I deleted it as you suggested. 

Also I still have the windows decorations of "Oxygen" though "Breeze" is the marked and chosen decoration. 

Also: There are only 4 themes installed and the aurorae one must have been installed by "getnewstuff". When I uninstall it with "getnewstuff" the crashes seem to have stopped for now... 

Maybe there should be a sanity check pn this "getnewstuff" idea, so much crap and so many broken things to download... 

Well anyway, I hope for me stuff stabilized, 
thx again, piedro
Now my problem
Comment 56 Thomas Lübking 2015-07-02 20:58:14 UTC
Sounds like it crashes when rendering the oxygen (which is NOT an aurorae theme but a decoration plugin of it's own, installed in some /usr/share/foobar path by the package manager) decoration?

=> Please open a new bug with the corresponding backtrace.
Comment 57 Christoph Feck 2015-07-10 14:15:01 UTC
*** Bug 349559 has been marked as a duplicate of this bug. ***
Comment 58 Christoph Feck 2015-07-10 14:15:22 UTC
*** Bug 349560 has been marked as a duplicate of this bug. ***
Comment 59 Christoph Feck 2015-07-10 14:15:41 UTC
*** Bug 349649 has been marked as a duplicate of this bug. ***
Comment 60 Christoph Feck 2015-07-10 14:15:57 UTC
*** Bug 349674 has been marked as a duplicate of this bug. ***
Comment 61 Christoph Feck 2015-07-10 14:16:17 UTC
*** Bug 349716 has been marked as a duplicate of this bug. ***
Comment 62 Christoph Feck 2015-07-10 14:16:34 UTC
*** Bug 349797 has been marked as a duplicate of this bug. ***
Comment 63 Christoph Feck 2015-07-10 14:16:52 UTC
*** Bug 349811 has been marked as a duplicate of this bug. ***
Comment 64 Christoph Feck 2015-07-10 14:17:09 UTC
*** Bug 350064 has been marked as a duplicate of this bug. ***
Comment 65 Christoph Feck 2015-07-28 11:38:28 UTC
*** Bug 350443 has been marked as a duplicate of this bug. ***
Comment 66 Christoph Feck 2015-08-02 09:27:28 UTC
*** Bug 350712 has been marked as a duplicate of this bug. ***
Comment 67 Christoph Feck 2015-08-13 00:06:08 UTC
*** Bug 350936 has been marked as a duplicate of this bug. ***
Comment 68 Christoph Feck 2015-08-13 00:06:25 UTC
*** Bug 350988 has been marked as a duplicate of this bug. ***
Comment 69 Christoph Feck 2015-08-13 00:06:46 UTC
*** Bug 351107 has been marked as a duplicate of this bug. ***
Comment 70 Christoph Feck 2015-08-13 00:07:06 UTC
*** Bug 351230 has been marked as a duplicate of this bug. ***
Comment 71 Christoph Feck 2015-08-22 14:39:22 UTC
*** Bug 351583 has been marked as a duplicate of this bug. ***
Comment 72 Christoph Feck 2015-08-22 14:39:48 UTC
*** Bug 351419 has been marked as a duplicate of this bug. ***
Comment 73 piedro 2015-08-22 22:32:31 UTC
What is wrong with this bug report, it seems to be spamming empty entries creating notification emails for everyone evertime - I am still interested in the resolve but could someone fix this thread? 

thx, p.
Comment 74 Thomas Lübking 2015-08-23 06:11:15 UTC
It's getting assigned duplicates because it happens for a hell lot of users which all report it against systemsettings and Christoph correctly marks them as (direct) dupe for this one (in a batch process eg. once a week)

Those posts are folded by default in bugzilla.

The bug itself is in the plasma QML components (or QtQuick itself), central report is bug #345660 - one must doubt it's actually fixed.
Comment 75 Mark 2015-08-23 09:38:29 UTC
Created attachment 94182 [details]
attachment-25760-0.html

Well I have managed to work around it. It is owing to multiple aurorae
decorations. I deleted them from the folder in config and I can reopen the
settings.
On 23 Aug 2015 07:11, "Thomas Lübking" <thomas.luebking@gmail.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=345675
>
> --- Comment #74 from Thomas Lübking <thomas.luebking@gmail.com> ---
> It's getting assigned duplicates because it happens for a hell lot of users
> which all report it against systemsettings and Christoph correctly marks
> them
> as (direct) dupe for this one (in a batch process eg. once a week)
>
> Those posts are folded by default in bugzilla.
>
> The bug itself is in the plasma QML components (or QtQuick itself), central
> report is bug #345660 - one must doubt it's actually fixed.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 76 Thomas Lübking 2015-08-23 09:50:32 UTC
It may very well be triggered by eg. incomplete themes, but that doesn't change the nature of the bug. QtQuick is sold "idiot proof" and would likely not even provide the infrastructure to test problematic conditions (declarative "programming") on the QML side.
Comment 77 Christoph Feck 2015-08-23 11:50:25 UTC
Checked only the three newest duplicates, they are all from a default Kubuntu install (Plasma 5.2.2), so I guess with updated packages (from some PPA), it should be fixed.
Comment 78 Christoph Feck 2015-09-03 09:13:08 UTC
*** Bug 351745 has been marked as a duplicate of this bug. ***
Comment 79 Christoph Feck 2015-09-03 09:13:40 UTC
*** Bug 351764 has been marked as a duplicate of this bug. ***
Comment 80 Christoph Feck 2015-09-14 09:37:08 UTC
*** Bug 352330 has been marked as a duplicate of this bug. ***
Comment 81 Christoph Feck 2015-09-14 09:44:49 UTC
*** Bug 352606 has been marked as a duplicate of this bug. ***
Comment 82 Christoph Feck 2015-09-14 09:45:22 UTC
*** Bug 352646 has been marked as a duplicate of this bug. ***
Comment 83 Christoph Feck 2015-09-14 09:45:56 UTC
*** Bug 352676 has been marked as a duplicate of this bug. ***
Comment 84 Christoph Feck 2015-09-23 14:43:30 UTC
*** Bug 352766 has been marked as a duplicate of this bug. ***
Comment 85 Christoph Feck 2015-09-23 14:43:52 UTC
*** Bug 352804 has been marked as a duplicate of this bug. ***
Comment 86 Christoph Feck 2015-09-23 14:44:13 UTC
*** Bug 352849 has been marked as a duplicate of this bug. ***
Comment 87 Christoph Feck 2015-10-10 21:37:40 UTC
*** Bug 353265 has been marked as a duplicate of this bug. ***
Comment 88 Christoph Feck 2015-10-10 21:38:04 UTC
*** Bug 353408 has been marked as a duplicate of this bug. ***
Comment 89 Christoph Feck 2015-10-10 21:38:33 UTC
*** Bug 353493 has been marked as a duplicate of this bug. ***
Comment 90 Christoph Feck 2015-10-21 20:29:22 UTC
*** Bug 353979 has been marked as a duplicate of this bug. ***
Comment 91 Christoph Feck 2015-11-16 01:15:16 UTC
*** Bug 354992 has been marked as a duplicate of this bug. ***
Comment 92 Christoph Feck 2015-11-16 01:15:37 UTC
*** Bug 355066 has been marked as a duplicate of this bug. ***
Comment 93 Christoph Feck 2015-12-03 13:09:26 UTC
*** Bug 355826 has been marked as a duplicate of this bug. ***
Comment 94 Christoph Feck 2017-04-27 01:02:49 UTC
*** Bug 348313 has been marked as a duplicate of this bug. ***