Bug 352330 - Window Decoration Crash on scrooling down decorations
Summary: Window Decoration Crash on scrooling down decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-06 00:06 UTC by s0me0ne
Modified: 2015-09-14 09:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description s0me0ne 2015-09-06 00:06:46 UTC
Application: kcmshell5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-26-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
It seems that it is caused by one of the downloaded Decorations.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Control Module (kcmshell5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe3370d7800 (LWP 25754))]

Thread 5 (Thread 0x7fe322ac1700 (LWP 25755)):
#0  0x00007fe336bbc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe32f2aab72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe32f2ac64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe3249e5099 in QXcbEventReader::run (this=0x233cd80) at qxcbconnection.cpp:1105
#4  0x00007fe334c3fb0e in QThreadPrivate::start (arg=0x233cd80) at thread/qthread_unix.cpp:337
#5  0x00007fe3346766aa in start_thread (arg=0x7fe322ac1700) at pthread_create.c:333
#6  0x00007fe336bc7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fe31863e700 (LWP 25756)):
#0  0x00007fe336bbc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe32eb86ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe32eb86fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe334ed6c6c in QEventDispatcherGlib::processEvents (this=0x7fe3100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fe334e7b3e2 in QEventLoop::exec (this=this@entry=0x7fe31863dda0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fe334c3ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fe334080f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fe334c3fb0e in QThreadPrivate::start (arg=0x249c9e0) at thread/qthread_unix.cpp:337
#8  0x00007fe3346766aa in start_thread (arg=0x7fe31863e700) at pthread_create.c:333
#9  0x00007fe336bc7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fe315210700 (LWP 25757)):
#0  0x00007fe336bbc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe32eb86ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe32eb86fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe334ed6c6c in QEventDispatcherGlib::processEvents (this=0x7fe3080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fe334e7b3e2 in QEventLoop::exec (this=this@entry=0x7fe31520fda0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fe334c3ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fe334080f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fe334c3fb0e in QThreadPrivate::start (arg=0x27f3020) at thread/qthread_unix.cpp:337
#8  0x00007fe3346766aa in start_thread (arg=0x7fe315210700) at pthread_create.c:333
#9  0x00007fe336bc7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fe30d8e4700 (LWP 25761)):
#0  0x00007fe336bbc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe32eb86ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe32eb86fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe334ed6c6c in QEventDispatcherGlib::processEvents (this=0x7fe2fc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fe334e7b3e2 in QEventLoop::exec (this=this@entry=0x7fe30d8e3dc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fe334c3ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fe334c3fb0e in QThreadPrivate::start (arg=0x2b1cb30) at thread/qthread_unix.cpp:337
#7  0x00007fe3346766aa in start_thread (arg=0x7fe30d8e4700) at pthread_create.c:333
#8  0x00007fe336bc7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fe3370d7800 (LWP 25754)):
[KCrash Handler]
#6  0x0000000000000100 in ?? ()
#7  0x00007fe333b05628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fe333b04d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fe3170e8c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x36adf70, oldNode=0x3581b60) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fe333b584bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fe333b594cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fe333b59d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fe333b28f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fe333b29979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fe33523ab2c in QApplicationPrivate::notify_helper (this=0x2326e70, receiver=0x2531420, e=0x7ffedfe7cc20) at kernel/qapplication.cpp:3720
#16 0x00007fe335240000 in QApplication::notify (this=0x7ffedfe7cff0, receiver=0x2531420, e=0x7ffedfe7cc20) at kernel/qapplication.cpp:3503
#17 0x00007fe334e7dc2b in QCoreApplication::notifyInternal (this=0x7ffedfe7cff0, receiver=0x2531420, event=event@entry=0x7ffedfe7cc20) at kernel/qcoreapplication.cpp:935
#18 0x00007fe334ed5ae5 in sendEvent (event=0x7ffedfe7cc20, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x2366390) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fe334ed5f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fe32eb86c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fe32eb86f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fe32eb86fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fe334ed6c57 in QEventDispatcherGlib::processEvents (this=0x236e680, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fe334e7b3e2 in QEventLoop::exec (this=this@entry=0x7ffedfe7ce80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fe33543c4b5 in QDialog::exec (this=0x2401810) at dialogs/qdialog.cpp:541
#27 0x00007fe336e939cb in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ../../kcmshell/main.cpp:307
#28 0x00007fe336ae1a40 in __libc_start_main (main=0x400730 <main(int, char**)>, argc=2, argv=0x7ffedfe7d138, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffedfe7d128) at libc-start.c:289
#29 0x0000000000400769 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-14 09:37:08 UTC

*** This bug has been marked as a duplicate of bug 345675 ***