Bug 351745 - 2015.08.25.03:27
Summary: 2015.08.25.03:27
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-25 08:34 UTC by bamiller
Modified: 2015-09-03 09:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bamiller 2015-08-25 08:34:38 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-26-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
	Attempting to change Window Decorations in System Settings. The application crashed on 	launch with error: Executable: systemsettings5 PID: 16081 Signal: Segmentation fault 		(11) Time: 8/25/15 03:31:10 
- Unusual behavior I noticed:
	 App was completely unresponsive and crashed immediately.
- Custom settings of the application:
	Using custom window decorations.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fabb7b4b780 (LWP 15628))]

Thread 5 (Thread 0x7faba5356700 (LWP 15629)):
#0  0x00007fabb42b48dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fabb25ceb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fabb25d064f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007faba810f099 in QXcbEventReader::run (this=0x1c8aa30) at qxcbconnection.cpp:1105
#4  0x00007fabb4935b0e in QThreadPrivate::start (arg=0x1c8aa30) at thread/qthread_unix.cpp:337
#5  0x00007fabb14e86aa in start_thread (arg=0x7faba5356700) at pthread_create.c:333
#6  0x00007fabb42bfeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fab8eb6e700 (LWP 15633)):
#0  0x00007fff24da594f in clock_gettime ()
#1  0x00007fabb42ce38d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fabb49ebcb6 in qt_clock_gettime (ts=0x7fab8eb6db80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007fabb4bca639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fab88134ac0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007fabb4bcaba5 in QTimerInfoList::timerWait (this=0x7fab88134ac0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007fabb4bcc03e in timerSourcePrepareHelper (timeout=0x7fab8eb6dc54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7fab8eb6dc54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007fabb0fc93fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fabb0fc9de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fabb0fc9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fabb4bccc6c in QEventDispatcherGlib::processEvents (this=0x7fab88139440, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007fabb4b713e2 in QEventLoop::exec (this=this@entry=0x7fab8eb6de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007fabb4930b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007fabb38fbf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007fabb4935b0e in QThreadPrivate::start (arg=0x22cbc00) at thread/qthread_unix.cpp:337
#17 0x00007fabb14e86aa in start_thread (arg=0x7fab8eb6e700) at pthread_create.c:333
#18 0x00007fabb42bfeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fab95fa0700 (LWP 15634)):
#0  0x00007fabb0fc9362 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fabb0fc9de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fabb0fc9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fabb4bccc6c in QEventDispatcherGlib::processEvents (this=0x7fab900ff210, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fabb4b713e2 in QEventLoop::exec (this=this@entry=0x7fab95f9fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fabb4930b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fabb38fbf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fabb4935b0e in QThreadPrivate::start (arg=0x27d1360) at thread/qthread_unix.cpp:337
#8  0x00007fabb14e86aa in start_thread (arg=0x7fab95fa0700) at pthread_create.c:333
#9  0x00007fabb42bfeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fab867e6700 (LWP 15635)):
[KCrash Handler]
#6  0x00007fabb3380625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fabb337fd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fab94635c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x393f0e0, oldNode=0x7fab82a8fd20) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fabb33d34bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fabb33d44cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fabb33d4d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fabb33a61dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fabb33a70a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fabb33a8360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fabb4935b0e in QThreadPrivate::start (arg=0x2fa16f0) at thread/qthread_unix.cpp:337
#16 0x00007fabb14e86aa in start_thread (arg=0x7fab867e6700) at pthread_create.c:333
#17 0x00007fabb42bfeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fabb7b4b780 (LWP 15628)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fabb4936c6b in wait (time=18446744073709551615, this=0x2eeedb0) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2fa1730, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007fabb33a9c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007fabb33aacad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007fabb595fb2c in QApplicationPrivate::notify_helper (this=0x1c5d550, receiver=0x21537c0, e=0x7fff24c6a8f0) at kernel/qapplication.cpp:3720
#6  0x00007fabb5965000 in QApplication::notify (this=0x7fff24c6ac60, receiver=0x21537c0, e=0x7fff24c6a8f0) at kernel/qapplication.cpp:3503
#7  0x00007fabb4b73c2b in QCoreApplication::notifyInternal (this=0x7fff24c6ac60, receiver=0x21537c0, event=event@entry=0x7fff24c6a8f0) at kernel/qcoreapplication.cpp:935
#8  0x00007fabb4bcbae5 in sendEvent (event=0x7fff24c6a8f0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x1cc9610) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007fabb4bcbf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007fabb0fc9c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fabb0fc9f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fabb0fc9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007fabb4bccc57 in QEventDispatcherGlib::processEvents (this=0x1ccd6c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007fabb4b713e2 in QEventLoop::exec (this=this@entry=0x7fff24c6ab40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007fabb4b7902c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007fabb539a31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007fabb595b7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-03 09:13:08 UTC

*** This bug has been marked as a duplicate of bug 345675 ***