Bug 347617 - System Settings crashes every time after install of new windows decorations
Summary: System Settings crashes every time after install of new windows decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-12 15:33 UTC by Rub
Modified: 2015-05-16 17:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rub 2015-05-12 15:33:11 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic i686
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I tried to change newly installed windows decorations. I had two default windows decorations (plastique and Breeze). So I added a few more from the list of window decorations. After I clicked on "Close getting new windows decorations" button the System Settings application crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2916700 (LWP 6093))]

Thread 8 (Thread 0xb23dfb40 (LWP 6094)):
#0  0xb76ecbe0 in __kernel_vsyscall ()
#1  0xb5caa3db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4f633a8 in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb4f65394 in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb25367d3 in ?? () from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/libqxcb.so
#5  0xb5f057eb in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb4b6e1aa in start_thread (arg=0xb23dfb40) at pthread_create.c:333
#7  0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 7 (Thread 0xb07efb40 (LWP 6096)):
#0  0xb76ecbe0 in __kernel_vsyscall ()
#1  0xb5ca475b in read () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4a6f515 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a29a82 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a29faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4a2a439 in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb12202f5 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#7  0xb4a5140a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb4b6e1aa in start_thread (arg=0xb07efb40) at pthread_create.c:333
#9  0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 6 (Thread 0xafdffb40 (LWP 6097)):
#0  0xb76ecbe0 in __kernel_vsyscall ()
#1  0xb5ca475b in read () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4a6f515 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a29a82 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a29faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4a2a156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb4a2a1b0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb4a5140a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb4b6e1aa in start_thread (arg=0xafdffb40) at pthread_create.c:333
#9  0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 5 (Thread 0xaad0eb40 (LWP 6100)):
#0  0xb76ecbe0 in __kernel_vsyscall ()
#1  0xb4b7325c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5cc1cf6 in __pthread_cond_wait (cond=0x92bc024, mutex=0x92bc00c) at forward.c:149
#3  0xad5643bd in ?? () from /usr/lib/i386-linux-gnu/dri/r600_dri.so
#4  0xad5639e5 in ?? () from /usr/lib/i386-linux-gnu/dri/r600_dri.so
#5  0xb4b6e1aa in start_thread (arg=0xaad0eb40) at pthread_create.c:333
#6  0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xa8747b40 (LWP 6103)):
#0  0xb76ecbe0 in __kernel_vsyscall ()
#1  0xb5ca475b in read () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4a6f515 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a29a82 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a29faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4a2a156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb618c9fc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb612dd93 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb612e1fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb5f0040d in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb5f004e8 in QThread::run() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb5f057eb in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#12 0xb4b6e1aa in start_thread (arg=0xa8747b40) at pthread_create.c:333
#13 0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xaebfeb40 (LWP 6135)):
#0  0xb4a70a48 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4a2940b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4a29f24 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a2a156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb618c9fc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#5  0xb612dd93 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb612e1fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb5f0040d in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb586950f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#9  0xb5f057eb in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#10 0xb4b6e1aa in start_thread (arg=0xaebfeb40) at pthread_create.c:333
#11 0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xa661bb40 (LWP 6136)):
#0  0xb76ecbe0 in __kernel_vsyscall ()
#1  0xb5caa3db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4a39120 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a2a014 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a2a156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb618c9fc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#6  0xb612dd93 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#7  0xb612e1fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#8  0xb5f0040d in QThread::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#9  0xb586950f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#10 0xb5f057eb in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#11 0xb4b6e1aa in start_thread (arg=0xa661bb40) at pthread_create.c:333
#12 0xb5cb4fde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb2916700 (LWP 6093)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb528ef0a in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#9  0xb528e4c7 in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#10 0xb5183188 in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) () from /usr/lib/i386-linux-gnu/libKF5QuickAddons.so.5
#11 0xa6e25a5e in ?? () from /usr/lib/i386-linux-gnu/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#12 0xb52e68e5 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#13 0xb52e77dd in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#14 0xb52e80c3 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#15 0xb52b4667 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#16 0xb52b52a8 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#17 0xb6bb282a in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#18 0xb6bb8081 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#19 0xb6130b8a in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#20 0xb618b808 in QTimerInfoList::activateTimers() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#21 0xb618bcd9 in ?? () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#22 0xb4a29d64 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb4a2a089 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb4a2a156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb618c9e4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#26 0xb2563611 in ?? () from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/libqxcb.so
#27 0xb612dd93 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#28 0xb612e1fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#29 0xb6136315 in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5
#30 0xb65e9a41 in QGuiApplication::exec() () from /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5
#31 0xb6badda4 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQt5Widgets.so.5
#32 0x08053f85 in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-16 17:01:05 UTC

*** This bug has been marked as a duplicate of bug 345675 ***