Bug 348440 - Windows Decorations crashes after installing new decorations
Summary: Windows Decorations crashes after installing new decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-30 08:46 UTC by kleidokrators
Modified: 2015-05-31 13:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kleidokrators 2015-05-30 08:46:07 UTC
Application: systemsettings5 (5.3.1)
 (Compiled from sources)
Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: After installing some windows decorations using the 'Get New Decorations' button , System Settings crashed. Since then, every time i open Systerm Settings > Application Style > Windows Decorations it crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Ρυθμίσεις συστήματος (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f0c21145780 (LWP 8050))]

Thread 5 (Thread 0x7f0c0ea21700 (LWP 8051)):
#0  0x00007f0c1d8bf8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0c1bbd9b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f0c1bbdb64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f0c117eb099 in QXcbEventReader::run (this=0x15e6190) at qxcbconnection.cpp:1105
#4  0x00007f0c1df40b0e in QThreadPrivate::start (arg=0x15e6190) at thread/qthread_unix.cpp:337
#5  0x00007f0c1aaf36aa in start_thread (arg=0x7f0c0ea21700) at pthread_create.c:333
#6  0x00007f0c1d8caeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f0bfeb33700 (LWP 8053)):
#0  0x00007ffd30585b4d in clock_gettime ()
#1  0x00007f0c1d8d938d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f0c1dff6cb6 in qt_clock_gettime (ts=0x7f0bfeb32b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f0c1e1d5639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f0bf8002ed0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f0c1e1d5ba5 in QTimerInfoList::timerWait (this=0x7f0bf8002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f0c1e1d703e in timerSourcePrepareHelper (timeout=0x7f0bfeb32c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f0bfeb32c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f0c1a5d43fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f0c1a5d4de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f0c1a5d4fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f0c1e1d7c6c in QEventDispatcherGlib::processEvents (this=0x7f0bf80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f0c1e17c3e2 in QEventLoop::exec (this=this@entry=0x7f0bfeb32e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f0c1df3bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f0c1cf06f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f0c1df40b0e in QThreadPrivate::start (arg=0x1f2ad40) at thread/qthread_unix.cpp:337
#17 0x00007f0c1aaf36aa in start_thread (arg=0x7f0bfeb33700) at pthread_create.c:333
#18 0x00007f0c1d8caeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f0bf70d4700 (LWP 8054)):
[KCrash Handler]
#6  0x0000000200000002 in ?? ()
#7  0x00007f0c1c98b628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f0c1c98ad3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f0bfcf92c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x22b2900, oldNode=0x7f0bf09847e0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f0c1c9de4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f0c1c9df4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f0c1c9dfd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f0c1c9b11dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f0c1c9b20a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f0c1c9b3360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f0c1df40b0e in QThreadPrivate::start (arg=0x21920f0) at thread/qthread_unix.cpp:337
#17 0x00007f0c1aaf36aa in start_thread (arg=0x7f0bf70d4700) at pthread_create.c:333
#18 0x00007f0c1d8caeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f0bf68d3700 (LWP 8055)):
#0  0x00007ffd30585b4d in clock_gettime ()
#1  0x00007f0c1d8d938d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f0c1dff6cb6 in qt_clock_gettime (ts=0x7f0bf68d2b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f0c1e1d5639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f0be8002ed0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f0c1e1d5ba5 in QTimerInfoList::timerWait (this=0x7f0be8002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f0c1e1d703e in timerSourcePrepareHelper (timeout=0x7f0bf68d2c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f0bf68d2c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f0c1a5d43fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f0c1a5d4de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f0c1a5d4fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f0c1e1d7c6c in QEventDispatcherGlib::processEvents (this=0x7f0be80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f0c1e17c3e2 in QEventLoop::exec (this=this@entry=0x7f0bf68d2e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f0c1df3bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f0c1cf06f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f0c1df40b0e in QThreadPrivate::start (arg=0x248e610) at thread/qthread_unix.cpp:337
#17 0x00007f0c1aaf36aa in start_thread (arg=0x7f0bf68d3700) at pthread_create.c:333
#18 0x00007f0c1d8caeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f0c21145780 (LWP 8050)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f0c1df41c6b in wait (time=18446744073709551615, this=0x2228990) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2192130, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f0c1c9b4c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f0c1c9b5cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f0c1ef6ab2c in QApplicationPrivate::notify_helper (this=0x15b9430, receiver=0x1cee330, e=0x7ffd30515520) at kernel/qapplication.cpp:3720
#6  0x00007f0c1ef70000 in QApplication::notify (this=0x7ffd30515890, receiver=0x1cee330, e=0x7ffd30515520) at kernel/qapplication.cpp:3503
#7  0x00007f0c1e17ec2b in QCoreApplication::notifyInternal (this=0x7ffd30515890, receiver=0x1cee330, event=event@entry=0x7ffd30515520) at kernel/qcoreapplication.cpp:935
#8  0x00007f0c1e1d6ae5 in sendEvent (event=0x7ffd30515520, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x16258e0) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f0c1e1d6f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f0c1a5d4c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f0c1a5d4f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f0c1a5d4fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f0c1e1d7c57 in QEventDispatcherGlib::processEvents (this=0x1625a10, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f0c1e17c3e2 in QEventLoop::exec (this=this@entry=0x7ffd30515770, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f0c1e18402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f0c1e9a531c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f0c1ef667a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040ef6b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-31 13:53:18 UTC

*** This bug has been marked as a duplicate of bug 345675 ***