Bug 348292 - Settings crashed when get into "Window Style" and "window declaration"
Summary: Settings crashed when get into "Window Style" and "window declaration"
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-27 07:51 UTC by Jungchu Hsu
Modified: 2015-05-31 13:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jungchu Hsu 2015-05-27 07:51:00 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
1. Launch Settings and get into "Window Style"
2. Choose "Window declaration"
3. Crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: 系統設定 (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fab1982a780 (LWP 8118))]

Thread 4 (Thread 0x7fab08f68700 (LWP 8119)):
#0  0x00007fab15f948dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fab142aeb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fab142b064f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fab0b4b3099 in QXcbEventReader::run (this=0x118f4d0) at qxcbconnection.cpp:1105
#4  0x00007fab16615b0e in QThreadPrivate::start (arg=0x118f4d0) at thread/qthread_unix.cpp:337
#5  0x00007fab131c86aa in start_thread (arg=0x7fab08f68700) at pthread_create.c:333
#6  0x00007fab15f9feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7faaf8591700 (LWP 8143)):
#0  0x00007fab12ca93d4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fab12ca9de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fab12ca9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fab168acc6c in QEventDispatcherGlib::processEvents (this=0x7faaf00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fab168513e2 in QEventLoop::exec (this=this@entry=0x7faaf8590e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fab16610b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fab155dbf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fab16615b0e in QThreadPrivate::start (arg=0x154cd50) at thread/qthread_unix.cpp:337
#8  0x00007fab131c86aa in start_thread (arg=0x7faaf8591700) at pthread_create.c:333
#9  0x00007fab15f9feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7faaf50c2700 (LWP 8144)):
#0  0x00007fab12cee7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fab12ca9490 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fab12ca9de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fab12ca9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fab168acc6c in QEventDispatcherGlib::processEvents (this=0x7faae80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fab168513e2 in QEventLoop::exec (this=this@entry=0x7faaf50c1e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fab16610b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fab155dbf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fab16615b0e in QThreadPrivate::start (arg=0x1892b00) at thread/qthread_unix.cpp:337
#9  0x00007fab131c86aa in start_thread (arg=0x7faaf50c2700) at pthread_create.c:333
#10 0x00007fab15f9feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fab1982a780 (LWP 8118)):
[KCrash Handler]
#6  0x00007fab15060625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fab1505fd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007faaf6f9bc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4687b70, oldNode=0x47ace80) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fab150b34bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fab150b44cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fab150b4d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fab15083f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fab15084979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fab1763fb2c in QApplicationPrivate::notify_helper (this=0x1178b10, receiver=0x142ee70, e=0x7ffdd2bc5bd0) at kernel/qapplication.cpp:3720
#15 0x00007fab17645000 in QApplication::notify (this=0x7ffdd2bc5f40, receiver=0x142ee70, e=0x7ffdd2bc5bd0) at kernel/qapplication.cpp:3503
#16 0x00007fab16853c2b in QCoreApplication::notifyInternal (this=0x7ffdd2bc5f40, receiver=0x142ee70, event=event@entry=0x7ffdd2bc5bd0) at kernel/qcoreapplication.cpp:935
#17 0x00007fab168abae5 in sendEvent (event=0x7ffdd2bc5bd0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#18 QTimerInfoList::activateTimers (this=0x11bf680) at kernel/qtimerinfo_unix.cpp:635
#19 0x00007fab168abf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#20 0x00007fab12ca9c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fab12ca9f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fab12ca9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fab168acc57 in QEventDispatcherGlib::processEvents (this=0x11c4b00, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#24 0x00007fab168513e2 in QEventLoop::exec (this=this@entry=0x7ffdd2bc5e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#25 0x00007fab1685902c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#26 0x00007fab1707a31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#27 0x00007fab1763b7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#28 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-31 13:52:32 UTC

*** This bug has been marked as a duplicate of bug 345675 ***