Bug 351107 - window decorations crash system settings
Summary: window decorations crash system settings
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-09 05:25 UTC by pheonix11026
Modified: 2015-08-13 00:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pheonix11026 2015-08-09 05:25:52 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: changing window decorations.

- Custom settings of the application: downloaded a few themes, can't see which one started issue because of crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe88f8bc780 (LWP 1768))]

Thread 4 (Thread 0x7fe87f033700 (LWP 1769)):
#0  0x00007fe88c01e8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe88a338b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe88a33a64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe88157e099 in QXcbEventReader::run (this=0x1690520) at qxcbconnection.cpp:1105
#4  0x00007fe88c69fb0e in QThreadPrivate::start (arg=0x1690520) at thread/qthread_unix.cpp:337
#5  0x00007fe8892526aa in start_thread (arg=0x7fe87f033700) at pthread_create.c:333
#6  0x00007fe88c029eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fe86ee5c700 (LWP 1770)):
#0  0x00007fe88c01e8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe888d33ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe888d33fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe88c936c6c in QEventDispatcherGlib::processEvents (this=0x7fe8680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fe88c8db3e2 in QEventLoop::exec (this=this@entry=0x7fe86ee5be20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fe88c69ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fe88b665f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fe88c69fb0e in QThreadPrivate::start (arg=0x1a45a40) at thread/qthread_unix.cpp:337
#8  0x00007fe8892526aa in start_thread (arg=0x7fe86ee5c700) at pthread_create.c:333
#9  0x00007fe88c029eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fe867830700 (LWP 1771)):
#0  0x00007fe888d787a2 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fe888d333f0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe888d33de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe888d33fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe88c936c6c in QEventDispatcherGlib::processEvents (this=0x7fe8600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fe88c8db3e2 in QEventLoop::exec (this=this@entry=0x7fe86782fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fe88c69ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fe88b665f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fe88c69fb0e in QThreadPrivate::start (arg=0x1d7b3a0) at thread/qthread_unix.cpp:337
#9  0x00007fe8892526aa in start_thread (arg=0x7fe867830700) at pthread_create.c:333
#10 0x00007fe88c029eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fe88f8bc780 (LWP 1768)):
[KCrash Handler]
#6  0x00007fe88b0ea625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fe88b0e9d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fe86d846c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3e5eb80, oldNode=0x4270d40) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fe88b13d4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fe88b13e4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fe88b13ed80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fe88b10df05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fe88b10e979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fe88d6c9b2c in QApplicationPrivate::notify_helper (this=0x1679b10, receiver=0x1a61ae0, e=0x7ffc2e91e4a0) at kernel/qapplication.cpp:3720
#15 0x00007fe88d6cf000 in QApplication::notify (this=0x7ffc2e91e810, receiver=0x1a61ae0, e=0x7ffc2e91e4a0) at kernel/qapplication.cpp:3503
#16 0x00007fe88c8ddc2b in QCoreApplication::notifyInternal (this=0x7ffc2e91e810, receiver=0x1a61ae0, event=event@entry=0x7ffc2e91e4a0) at kernel/qcoreapplication.cpp:935
#17 0x00007fe88c935ae5 in sendEvent (event=0x7ffc2e91e4a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#18 QTimerInfoList::activateTimers (this=0x16b6ec0) at kernel/qtimerinfo_unix.cpp:635
#19 0x00007fe88c935f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#20 0x00007fe888d33c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fe888d33f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fe888d33fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fe88c936c57 in QEventDispatcherGlib::processEvents (this=0x16b6fa0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#24 0x00007fe88c8db3e2 in QEventLoop::exec (this=this@entry=0x7ffc2e91e6f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#25 0x00007fe88c8e302c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#26 0x00007fe88d10431c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#27 0x00007fe88d6c57a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#28 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-08-13 00:06:46 UTC

*** This bug has been marked as a duplicate of bug 345675 ***