Bug 349811 - Window decoration window in System Settings crashes as soon as I try to open it
Summary: Window decoration window in System Settings crashes as soon as I try to open it
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-02 07:21 UTC by Luca Carlon
Modified: 2015-07-10 14:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Carlon 2015-07-02 07:21:24 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-21-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
I installed a couple of new window decorations and the System Settings application crashed. Now it crashes every time I try to open it.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f63471fb780 (LWP 3229))]

Thread 4 (Thread 0x7f6336989700 (LWP 3230)):
#0  0x00007f63439758dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6341c8fb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f6341c9164f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6338ed4099 in QXcbEventReader::run (this=0xa52590) at qxcbconnection.cpp:1105
#4  0x00007f6343ff6b0e in QThreadPrivate::start (arg=0xa52590) at thread/qthread_unix.cpp:337
#5  0x00007f6340ba96aa in start_thread (arg=0x7f6336989700) at pthread_create.c:333
#6  0x00007f6343980eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f6326296700 (LWP 3232)):
#0  0x00007f63439758dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f634068aebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f634068afcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f634428dc6c in QEventDispatcherGlib::processEvents (this=0x7f63200008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f63442323e2 in QEventLoop::exec (this=this@entry=0x7f6326295e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f6343ff1b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f6342fbcf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f6343ff6b0e in QThreadPrivate::start (arg=0x14af6d0) at thread/qthread_unix.cpp:337
#8  0x00007f6340ba96aa in start_thread (arg=0x7f6326296700) at pthread_create.c:333
#9  0x00007f6343980eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f631ed9e700 (LWP 3233)):
#0  0x00007f634068a480 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f634068ade8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f634068afcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f634428dc6c in QEventDispatcherGlib::processEvents (this=0x7f63180008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f63442323e2 in QEventLoop::exec (this=this@entry=0x7f631ed9de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f6343ff1b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f6342fbcf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f6343ff6b0e in QThreadPrivate::start (arg=0x190a170) at thread/qthread_unix.cpp:337
#8  0x00007f6340ba96aa in start_thread (arg=0x7f631ed9e700) at pthread_create.c:333
#9  0x00007f6343980eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f63471fb780 (LWP 3229)):
[KCrash Handler]
#6  0x00000000037234f0 in ?? ()
#7  0x00007f6342a41628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f6342a40d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f6324cb0c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x44fd1f0, oldNode=0x47b1ba0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f6342a944bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f6342a954cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f6342a95d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f6342a64f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f6342a65979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f6345020b2c in QApplicationPrivate::notify_helper (this=0xa3ab10, receiver=0x15e9eb0, e=0x7ffea0c86050) at kernel/qapplication.cpp:3720
#16 0x00007f6345026000 in QApplication::notify (this=0x7ffea0c863c0, receiver=0x15e9eb0, e=0x7ffea0c86050) at kernel/qapplication.cpp:3503
#17 0x00007f6344234c2b in QCoreApplication::notifyInternal (this=0x7ffea0c863c0, receiver=0x15e9eb0, event=event@entry=0x7ffea0c86050) at kernel/qcoreapplication.cpp:935
#18 0x00007f634428cae5 in sendEvent (event=0x7ffea0c86050, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xa86bb0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f634428cf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f634068ac3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f634068af20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f634068afcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f634428dc57 in QEventDispatcherGlib::processEvents (this=0xa847d0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f63442323e2 in QEventLoop::exec (this=this@entry=0x7ffea0c862a0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f634423a02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f6344a5b31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f634501c7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:16:52 UTC

*** This bug has been marked as a duplicate of bug 345675 ***