Bug 346986 - Plasma Prererencias stop and crash when I change the decoration applications.
Summary: Plasma Prererencias stop and crash when I change the decoration applications.
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-30 22:38 UTC by Jorge
Modified: 2015-05-02 23:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge 2015-04-30 22:38:04 UTC
Application: systemsettings5 (5.3.0)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: changing the decoration aplications.

- Custom settings of the application:  i use some decoration from kde-4.  I updated kubuntu from kde 4 to plasma 5.

The crash can be reproduced every time.

-- Backtrace:
Application: Preferencias del sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5e6d7c5780 (LWP 3798))]

Thread 4 (Thread 0x7f5e5ccd1700 (LWP 3799)):
#0  0x00007f5e69f318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5e6824bb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5e6824d64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5e5f21c099 in QXcbEventReader::run (this=0xb34620) at qxcbconnection.cpp:1105
#4  0x00007f5e6a5b2b0e in QThreadPrivate::start (arg=0xb34620) at thread/qthread_unix.cpp:337
#5  0x00007f5e671656aa in start_thread (arg=0x7f5e5ccd1700) at pthread_create.c:333
#6  0x00007f5e69f3ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f5e4c5a4700 (LWP 3800)):
#0  0x00007f5e69f318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5e66c46ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5e66c46fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5e6a849c6c in QEventDispatcherGlib::processEvents (this=0x7f5e440008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f5e6a7ee3e2 in QEventLoop::exec (this=this@entry=0x7f5e4c5a3e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f5e6a5adb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f5e69578f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5e6a5b2b0e in QThreadPrivate::start (arg=0x16f41a0) at thread/qthread_unix.cpp:337
#8  0x00007f5e671656aa in start_thread (arg=0x7f5e4c5a4700) at pthread_create.c:333
#9  0x00007f5e69f3ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f5e490d7700 (LWP 3803)):
#0  0x00007f5e69f318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5e66c46ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5e66c46fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5e6a849c6c in QEventDispatcherGlib::processEvents (this=0x7f5e3c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f5e6a7ee3e2 in QEventLoop::exec (this=this@entry=0x7f5e490d6e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f5e6a5adb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f5e69578f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5e6a5b2b0e in QThreadPrivate::start (arg=0x1f02680) at thread/qthread_unix.cpp:337
#8  0x00007f5e671656aa in start_thread (arg=0x7f5e490d7700) at pthread_create.c:333
#9  0x00007f5e69f3ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f5e6d7c5780 (LWP 3798)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f5e68ffd628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f5e68ffcd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f5e4aa59c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x685a680, oldNode=0x5898470) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f5e690504bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f5e690514cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f5e69051d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f5e69020f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f5e69022016 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f5e6b0287b5 in QWindow::event (this=0x15957d0, ev=<optimized out>) at kernel/qwindow.cpp:2051
#16 0x00007f5e6905bdd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f5e6b5dcb2c in QApplicationPrivate::notify_helper (this=0xb1db10, receiver=0x15957d0, e=0x7ffe24d9aa10) at kernel/qapplication.cpp:3720
#18 0x00007f5e6b5e2000 in QApplication::notify (this=0x7ffe24d9ae10, receiver=0x15957d0, e=0x7ffe24d9aa10) at kernel/qapplication.cpp:3503
#19 0x00007f5e6a7f0c2b in QCoreApplication::notifyInternal (this=0x7ffe24d9ae10, receiver=receiver@entry=0x15957d0, event=event@entry=0x7ffe24d9aa10) at kernel/qcoreapplication.cpp:935
#20 0x00007f5e6b020e86 in sendSpontaneousEvent (event=0x7ffe24d9aa10, receiver=0x15957d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QGuiApplicationPrivate::processExposeEvent (e=0x1e07c30) at kernel/qguiapplication.cpp:2613
#22 0x00007f5e6b021bbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x1e07c30) at kernel/qguiapplication.cpp:1638
#23 0x00007f5e6b00634f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#24 0x00007f5e5f246590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#25 0x00007f5e66c46c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f5e66c46f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f5e66c46fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f5e6a849c57 in QEventDispatcherGlib::processEvents (this=0xb65b90, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#29 0x00007f5e6a7ee3e2 in QEventLoop::exec (this=this@entry=0x7ffe24d9acf0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#30 0x00007f5e6a7f602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0x00007f5e6b01731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0x00007f5e6b5d87a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x000000000040ef5b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-02 23:52:04 UTC

*** This bug has been marked as a duplicate of bug 345675 ***