Bug 347867 - Crashed while installing custom window style
Summary: Crashed while installing custom window style
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-17 22:20 UTC by Ron
Modified: 2015-05-23 14:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ron 2015-05-17 22:20:24 UTC
Application: systemsettings5 (5.3.0)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic x86_64
Distribution: Netrunner 16

-- Information about the crash:
- What I was doing when the application crashed:  I was installing a new (Top Rated) window dressing and CRASH!

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9fddd2e780 (LWP 2038))]

Thread 6 (Thread 0x7f9fcd4b1700 (LWP 2039)):
#0  0x00007f9fda49d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9fd87b6b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f9fd87b864f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f9fcf9fc099 in QXcbEventReader::run (this=0x118e460) at qxcbconnection.cpp:1105
#4  0x00007f9fdab1eb0e in QThreadPrivate::start (arg=0x118e460) at thread/qthread_unix.cpp:337
#5  0x00007f9fd76d06aa in start_thread (arg=0x7f9fcd4b1700) at pthread_create.c:333
#6  0x00007f9fda4a8eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f9fbdfe7700 (LWP 2385)):
#0  0x00007f9fd71b1ddb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9fd71b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9fdadb5c6c in QEventDispatcherGlib::processEvents (this=0x7f9fb80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#3  0x00007f9fdad5a3e2 in QEventLoop::exec (this=this@entry=0x7f9fbdfe6e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007f9fdab19b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#5  0x00007f9fd9ae3f75 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f9fdab1eb0e in QThreadPrivate::start (arg=0x1559860) at thread/qthread_unix.cpp:337
#7  0x00007f9fd76d06aa in start_thread (arg=0x7f9fbdfe7700) at pthread_create.c:333
#8  0x00007f9fda4a8eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f9fac2bf700 (LWP 2389)):
#0  0x00007f9fd71f6789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9fd71b1dbd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9fd71b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9fdadb5c6c in QEventDispatcherGlib::processEvents (this=0x7f9fa4000910, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f9fdad5a3e2 in QEventLoop::exec (this=this@entry=0x7f9fac2bee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f9fdab19b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f9fd9ae3f75 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f9fdab1eb0e in QThreadPrivate::start (arg=0x1931f10) at thread/qthread_unix.cpp:337
#8  0x00007f9fd76d06aa in start_thread (arg=0x7f9fac2bf700) at pthread_create.c:333
#9  0x00007f9fda4a8eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f9f94f37700 (LWP 2396)):
#0  0x00007f9fdab16a24 in QMutex::lock (this=this@entry=0x1ef31d8) at thread/qmutex.cpp:218
#1  0x00007f9fdadb51db in QMutexLocker (m=0x1ef31d8, this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:128
#2  canWaitLocked (this=0x1ef31b0) at ../../include/QtCore/5.4.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:243
#3  postEventSourcePrepare (s=0x7f9f880012d0, timeout=0x7f9f94f36c74) at kernel/qeventdispatcher_glib.cpp:254
#4  0x00007f9fd71b13fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9fd71b1de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f9fd71b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f9fdadb5c6c in QEventDispatcherGlib::processEvents (this=0x7f9f880008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#8  0x00007f9fdad5a3e2 in QEventLoop::exec (this=this@entry=0x7f9f94f36e40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x00007f9fdab19b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#10 0x00007f9fdab1eb0e in QThreadPrivate::start (arg=0x1ebcab0) at thread/qthread_unix.cpp:337
#11 0x00007f9fd76d06aa in start_thread (arg=0x7f9f94f37700) at pthread_create.c:333
#12 0x00007f9fda4a8eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f9f8ffff700 (LWP 2418)):
#0  0x00007f9fda49949d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9fd71f52f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9fd71b196c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9fd71b1e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9fd71b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f9fdadb5c6c in QEventDispatcherGlib::processEvents (this=0x7f9f840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f9fdad5a3e2 in QEventLoop::exec (this=this@entry=0x7f9f8fffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f9fdab19b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f9fd9ae3f75 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f9fdab1eb0e in QThreadPrivate::start (arg=0x44934b0) at thread/qthread_unix.cpp:337
#10 0x00007f9fd76d06aa in start_thread (arg=0x7f9f8ffff700) at pthread_create.c:333
#11 0x00007f9fda4a8eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f9fddd2e780 (LWP 2038)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f9fd9568628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f9fd9567d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f9fbcc4cc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x1e0ec30, oldNode=0x4694cd0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f9fd95bb4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f9fd95bc4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f9fd95bcd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f9fd958bf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f9fd958d016 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f9fdb5947b5 in QWindow::event (this=0x19307b0, ev=<optimized out>) at kernel/qwindow.cpp:2051
#16 0x00007f9fd95c6dd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f9fdbb48b2c in QApplicationPrivate::notify_helper (this=0x1177b10, receiver=0x19307b0, e=0x7ffd9e65e640) at kernel/qapplication.cpp:3720
#18 0x00007f9fdbb4e000 in QApplication::notify (this=0x7ffd9e65ea40, receiver=0x19307b0, e=0x7ffd9e65e640) at kernel/qapplication.cpp:3503
#19 0x00007f9fdad5cc2b in QCoreApplication::notifyInternal (this=0x7ffd9e65ea40, receiver=receiver@entry=0x19307b0, event=event@entry=0x7ffd9e65e640) at kernel/qcoreapplication.cpp:935
#20 0x00007f9fdb58ce86 in sendSpontaneousEvent (event=0x7ffd9e65e640, receiver=0x19307b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QGuiApplicationPrivate::processExposeEvent (e=0x50b9e60) at kernel/qguiapplication.cpp:2613
#22 0x00007f9fdb58dbbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x50b9e60) at kernel/qguiapplication.cpp:1638
#23 0x00007f9fdb57234f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#24 0x00007f9fcfa26590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#25 0x00007f9fd71b1c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f9fd71b1f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f9fd71b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f9fdadb5c57 in QEventDispatcherGlib::processEvents (this=0x11bcec0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#29 0x00007f9fdad5a3e2 in QEventLoop::exec (this=this@entry=0x7ffd9e65e920, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#30 0x00007f9fdad6202c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0x00007f9fdb58331c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0x00007f9fdbb447a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x000000000040ef5b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:34:13 UTC

*** This bug has been marked as a duplicate of bug 345675 ***