Bug 352766 - SystemSettings crashes while selecting new window decorations
Summary: SystemSettings crashes while selecting new window decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-15 19:39 UTC by cn_kde
Modified: 2015-09-23 14:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cn_kde 2015-09-15 19:39:04 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-28-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
sometimers, not every time, SystemSettings crashes while trying to install a new window decoration. It is not depending on the decoration iteself.

The crash can be reproduced every time.

-- Backtrace:
Application: Systemeinstellungen (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd53023e780 (LWP 8444))]

Thread 5 (Thread 0x7fd51f852700 (LWP 8446)):
#0  0x00007fd52c9b38dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd52accdb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd52accf64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd521d9d099 in QXcbEventReader::run (this=0xd7f7c0) at qxcbconnection.cpp:1105
#4  0x00007fd52d034b0e in QThreadPrivate::start (arg=0xd7f7c0) at thread/qthread_unix.cpp:337
#5  0x00007fd529be76aa in start_thread (arg=0x7fd51f852700) at pthread_create.c:333
#6  0x00007fd52c9beeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fd507b16700 (LWP 8486)):
#0  0x00007fd52970d789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd5296c8641 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5296c8e37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd5296c8fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd52d2cbc6c in QEventDispatcherGlib::processEvents (this=0x7fd5000f0470, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fd52d2703e2 in QEventLoop::exec (this=this@entry=0x7fd507b15e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fd52d02fb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fd52bffaf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fd52d034b0e in QThreadPrivate::start (arg=0x4832980) at thread/qthread_unix.cpp:337
#9  0x00007fd529be76aa in start_thread (arg=0x7fd507b16700) at pthread_create.c:333
#10 0x00007fd52c9beeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fd4ff7ff700 (LWP 8487)):
#0  0x00007fd52970d789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd5296c8dbd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5296c8fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd52d2cbc6c in QEventDispatcherGlib::processEvents (this=0x7fd4f80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fd52d2703e2 in QEventLoop::exec (this=this@entry=0x7fd4ff7fee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fd52d02fb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fd52bffaf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fd52d034b0e in QThreadPrivate::start (arg=0x3f3fe00) at thread/qthread_unix.cpp:337
#8  0x00007fd529be76aa in start_thread (arg=0x7fd4ff7ff700) at pthread_create.c:333
#9  0x00007fd52c9beeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fd4fdbd1700 (LWP 8513)):
#0  0x00007fd52c9b38dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd5296c8ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5296c8fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd52d2cbc6c in QEventDispatcherGlib::processEvents (this=0x7fd4f00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fd52d2703e2 in QEventLoop::exec (this=this@entry=0x7fd4fdbd0e40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fd52d02fb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fd52d034b0e in QThreadPrivate::start (arg=0x1d66fd0) at thread/qthread_unix.cpp:337
#7  0x00007fd529be76aa in start_thread (arg=0x7fd4fdbd1700) at pthread_create.c:333
#8  0x00007fd52c9beeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd53023e780 (LWP 8444)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fd52ba7f628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fd52ba7ed3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fd50da94c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3fd8390, oldNode=0x4dea910) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fd52bad24bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fd52bad34cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fd52bad3d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fd52baa2f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fd52baa3979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fd52e05eb2c in QApplicationPrivate::notify_helper (this=0xd68b10, receiver=0x12e11c0, e=0x7ffee86e7cf0) at kernel/qapplication.cpp:3720
#16 0x00007fd52e064000 in QApplication::notify (this=0x7ffee86e8060, receiver=0x12e11c0, e=0x7ffee86e7cf0) at kernel/qapplication.cpp:3503
#17 0x00007fd52d272c2b in QCoreApplication::notifyInternal (this=0x7ffee86e8060, receiver=0x12e11c0, event=event@entry=0x7ffee86e7cf0) at kernel/qcoreapplication.cpp:935
#18 0x00007fd52d2caae5 in sendEvent (event=0x7ffee86e7cf0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xdabe80) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fd52d2caf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fd5296c8c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fd5296c8f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fd5296c8fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fd52d2cbc6c in QEventDispatcherGlib::processEvents (this=0xdb7980, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fd52d2703e2 in QEventLoop::exec (this=this@entry=0x7ffee86e7f40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fd52d27802c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fd52da9931c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fd52e05a7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-23 14:43:30 UTC

*** This bug has been marked as a duplicate of bug 345675 ***