Bug 349797 - Window Decorations Theme crashes system settings
Summary: Window Decorations Theme crashes system settings
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-01 20:17 UTC by Rohde Fischer
Modified: 2015-07-10 14:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rohde Fischer 2015-07-01 20:17:20 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-21-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
If I go to system settings to change the window decorations system settings will crash. In the beginning I had to scroll down to produce the error, but after uninstalling other themes, the problem occurs every time.

- Custom settings of the application:
The bug is caused (or most likely caused) by a custom theme

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdf6391a780 (LWP 5005))]

Thread 4 (Thread 0x7fdf53099700 (LWP 5006)):
#0  0x00007fdf600848dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fdf5e39eb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fdf5e3a064f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fdf555e4099 in QXcbEventReader::run (this=0x1deb3f0) at qxcbconnection.cpp:1105
#4  0x00007fdf60705b0e in QThreadPrivate::start (arg=0x1deb3f0) at thread/qthread_unix.cpp:337
#5  0x00007fdf5d2b86aa in start_thread (arg=0x7fdf53099700) at pthread_create.c:333
#6  0x00007fdf6008feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fdf42968700 (LWP 5009)):
#0  0x00007fdf5cdde7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fdf5cd996f9 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdf5cd99e37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdf5cd99fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fdf6099cc6c in QEventDispatcherGlib::processEvents (this=0x7fdf3c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fdf609413e2 in QEventLoop::exec (this=this@entry=0x7fdf42967e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fdf60700b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fdf5f6cbf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fdf60705b0e in QThreadPrivate::start (arg=0x22cbdb0) at thread/qthread_unix.cpp:337
#9  0x00007fdf5d2b86aa in start_thread (arg=0x7fdf42968700) at pthread_create.c:333
#10 0x00007fdf6008feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fdf3b4a6700 (LWP 5010)):
#0  0x00007fdf600848dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fdf5cd99ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdf5cd99fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdf6099cc6c in QEventDispatcherGlib::processEvents (this=0x7fdf340008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fdf609413e2 in QEventLoop::exec (this=this@entry=0x7fdf3b4a5e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fdf60700b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fdf5f6cbf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fdf60705b0e in QThreadPrivate::start (arg=0x2622500) at thread/qthread_unix.cpp:337
#8  0x00007fdf5d2b86aa in start_thread (arg=0x7fdf3b4a6700) at pthread_create.c:333
#9  0x00007fdf6008feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fdf6391a780 (LWP 5005)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007fdf5f150628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fdf5f14fd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fdf40e2dc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x5b28c00, oldNode=0x5ea7a00) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fdf5f1a34bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fdf5f1a44cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fdf5f1a4d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fdf5f173f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fdf5f174979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fdf6172fb2c in QApplicationPrivate::notify_helper (this=0x1dd4b10, receiver=0x2326af0, e=0x7ffe8e5691b0) at kernel/qapplication.cpp:3720
#16 0x00007fdf61735000 in QApplication::notify (this=0x7ffe8e569520, receiver=0x2326af0, e=0x7ffe8e5691b0) at kernel/qapplication.cpp:3503
#17 0x00007fdf60943c2b in QCoreApplication::notifyInternal (this=0x7ffe8e569520, receiver=0x2326af0, event=event@entry=0x7ffe8e5691b0) at kernel/qcoreapplication.cpp:935
#18 0x00007fdf6099bae5 in sendEvent (event=0x7ffe8e5691b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1e184e0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fdf6099bf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fdf5cd99c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fdf5cd99f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fdf5cd99fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fdf6099cc57 in QEventDispatcherGlib::processEvents (this=0x1e19030, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fdf609413e2 in QEventLoop::exec (this=this@entry=0x7ffe8e569400, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fdf6094902c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fdf6116a31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fdf6172b7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:16:34 UTC

*** This bug has been marked as a duplicate of bug 345675 ***