Bug 352804 - System Settings crashes when looking at Window Decorations
Summary: System Settings crashes when looking at Window Decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-16 16:13 UTC by Lynoure Braakman
Modified: 2015-09-23 14:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lynoure Braakman 2015-09-16 16:13:27 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-28-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
I had just changed the window decoration in use to a different once, and ever after that, looking at the Window Decorations section causes a crash.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f748bf83780 (LWP 20449))]

Thread 4 (Thread 0x7f747b46c700 (LWP 20450)):
#0  0x00007f74886f88dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7486a12b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f7486a1464f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f747d9b7099 in QXcbEventReader::run (this=0x11bac90) at qxcbconnection.cpp:1105
#4  0x00007f7488d79b0e in QThreadPrivate::start (arg=0x11bac90) at thread/qthread_unix.cpp:337
#5  0x00007f748592c6aa in start_thread (arg=0x7f747b46c700) at pthread_create.c:333
#6  0x00007f7488703eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f746b292700 (LWP 20452)):
#0  0x00007f74886f88dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f748540debc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f748540dfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7489010c6c in QEventDispatcherGlib::processEvents (this=0x7f74640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f7488fb53e2 in QEventLoop::exec (this=this@entry=0x7f746b291e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f7488d74b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f7487d3ff65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f7488d79b0e in QThreadPrivate::start (arg=0x2055c90) at thread/qthread_unix.cpp:337
#8  0x00007f748592c6aa in start_thread (arg=0x7f746b292700) at pthread_create.c:333
#9  0x00007f7488703eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f7463d59700 (LWP 20453)):
#0  0x00007f748540d667 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f748540de37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f748540dfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7489010c6c in QEventDispatcherGlib::processEvents (this=0x7f745c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f7488fb53e2 in QEventLoop::exec (this=this@entry=0x7f7463d58e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f7488d74b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f7487d3ff65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f7488d79b0e in QThreadPrivate::start (arg=0x22cb030) at thread/qthread_unix.cpp:337
#8  0x00007f748592c6aa in start_thread (arg=0x7f7463d59700) at pthread_create.c:333
#9  0x00007f7488703eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f748bf83780 (LWP 20449)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007f74877c4628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f74877c3d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f7469710c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x44be670, oldNode=0x5611bb0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f74878174bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f74878184cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f7487818d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f74877e7f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f74877e8979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f7489da3b2c in QApplicationPrivate::notify_helper (this=0x11a3b10, receiver=0x2055f10, e=0x7ffefdab1990) at kernel/qapplication.cpp:3720
#16 0x00007f7489da9000 in QApplication::notify (this=0x7ffefdab1d00, receiver=0x2055f10, e=0x7ffefdab1990) at kernel/qapplication.cpp:3503
#17 0x00007f7488fb7c2b in QCoreApplication::notifyInternal (this=0x7ffefdab1d00, receiver=0x2055f10, event=event@entry=0x7ffefdab1990) at kernel/qcoreapplication.cpp:935
#18 0x00007f748900fae5 in sendEvent (event=0x7ffefdab1990, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x11f1ae0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f748900ff61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f748540dc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f748540df20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f748540dfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f7489010c57 in QEventDispatcherGlib::processEvents (this=0x11e7fa0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f7488fb53e2 in QEventLoop::exec (this=this@entry=0x7ffefdab1be0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f7488fbd02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f74897de31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f7489d9f7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-23 14:43:52 UTC

*** This bug has been marked as a duplicate of bug 345675 ***