Bug 347945 - System Settings Crashes when clicking Window Decorations
Summary: System Settings Crashes when clicking Window Decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-19 12:48 UTC by ant978red
Modified: 2015-05-23 14:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ant978red 2015-05-19 12:48:22 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

Clicked get new decorations, might have clicked on a decoration and clicked discard.

Every time I click on 'Window Decorations' from 'Application Style' SystemSettings crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f89d3045780 (LWP 2320))]

Thread 6 (Thread 0x7f89c27d5700 (LWP 2321)):
#0  0x00007f89cf7c08dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f89cdadab72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f89cdadc64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f89c4d20099 in QXcbEventReader::run (this=0x18433b0) at qxcbconnection.cpp:1105
#4  0x00007f89cfe41b0e in QThreadPrivate::start (arg=0x18433b0) at thread/qthread_unix.cpp:337
#5  0x00007f89cc9f46aa in start_thread (arg=0x7f89c27d5700) at pthread_create.c:333
#6  0x00007f89cf7cbeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f89b4327700 (LWP 2327)):
#0  0x00007f89cf7c08dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f89cc4d5ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f89cc4d6242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f89c0255ae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f89cc4fc955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f89cc9f46aa in start_thread (arg=0x7f89b4327700) at pthread_create.c:333
#6  0x00007f89cf7cbeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f89b3b26700 (LWP 2328)):
#0  0x00007f89cc51a7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f89cc4d56f9 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f89cc4d5e37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f89cc4d5fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f89cc4d6009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f89cc4fc955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f89cc9f46aa in start_thread (arg=0x7f89b3b26700) at pthread_create.c:333
#7  0x00007f89cf7cbeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f89b2b24700 (LWP 2331)):
#0  0x00007f89cc51a789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f89cc4d4df0 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f89cc4d5d75 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f89cc4d5fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f89d00d8c6c in QEventDispatcherGlib::processEvents (this=0x7f89a8001390, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f89d007d3e2 in QEventLoop::exec (this=this@entry=0x7f89b2b23e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f89cfe3cb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f89cee07f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f89cfe41b0e in QThreadPrivate::start (arg=0x1de8e10) at thread/qthread_unix.cpp:337
#9  0x00007f89cc9f46aa in start_thread (arg=0x7f89b2b24700) at pthread_create.c:333
#10 0x00007f89cf7cbeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f8994eb1700 (LWP 2332)):
#0  0x00007f89cc51a7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f89cc4d53f0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f89cc4d5de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f89cc4d5fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f89d00d8c6c in QEventDispatcherGlib::processEvents (this=0x7f89900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f89d007d3e2 in QEventLoop::exec (this=this@entry=0x7f8994eb0e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f89cfe3cb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f89cee07f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f89cfe41b0e in QThreadPrivate::start (arg=0x35f25a0) at thread/qthread_unix.cpp:337
#9  0x00007f89cc9f46aa in start_thread (arg=0x7f8994eb1700) at pthread_create.c:333
#10 0x00007f89cf7cbeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f89d3045780 (LWP 2320)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007f89ce88c628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f89ce88bd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f8996da1c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x47bf780, oldNode=0x4bb92e0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f89ce8df4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f89ce8e04cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f89ce8e0d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f89ce8aff05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f89ce8b0979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f89d0e6bb2c in QApplicationPrivate::notify_helper (this=0x182cb10, receiver=0x1e1bab0, e=0x7ffd0219acb0) at kernel/qapplication.cpp:3720
#16 0x00007f89d0e71000 in QApplication::notify (this=0x7ffd0219b020, receiver=0x1e1bab0, e=0x7ffd0219acb0) at kernel/qapplication.cpp:3503
#17 0x00007f89d007fc2b in QCoreApplication::notifyInternal (this=0x7ffd0219b020, receiver=0x1e1bab0, event=event@entry=0x7ffd0219acb0) at kernel/qcoreapplication.cpp:935
#18 0x00007f89d00d7ae5 in sendEvent (event=0x7ffd0219acb0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x18cfdb0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f89d00d7f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f89cc4d5c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f89cc4d5f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f89cc4d5fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f89d00d8c57 in QEventDispatcherGlib::processEvents (this=0x18cfc30, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f89d007d3e2 in QEventLoop::exec (this=this@entry=0x7ffd0219af00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f89d008502c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f89d08a631c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f89d0e677a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:34:48 UTC

*** This bug has been marked as a duplicate of bug 345675 ***